Slow Wired Connection Speed

Hi
I just installed Manjaro KDE. I was using Pop Os for a few months. I always use a wired connection from my wifi to get better download and upload speed.
I just saw in the network manager, My wifi is showing 300mbps connection speed but when I connect to the wired connection from the same wifi, it gets reduced to 100mbps.
What is the reason ? I am getting a bit slower speed in wired connectionn than wifi.
I also used KDE Plasma on Pop Os and both my wired and wireless connection speed was 300 mbps.
Wifi and Wired speed attachment



image wired settings

1 Like

Hello,

Better to start with some proper information of your system. Here is how to do that:


Also you can change the settings for Network, and set them manually.

image

1 Like

Which settings should I change to maul? Link Negotiation or MTU?
Also what about the speed and duplex settings in manual mode ?
image

Speed tab.

As you get auto-detected with 100Mbps, try setting it to 1Gbps half duplex and see if that works.

If it doesn't work, change the cable, please!

Wonky cable in 90% of cases, 5% bad port (either side)

:innocent:

here brother https://imgur.com/a/wbx4yjj

but I used this same cable while using Pop Os, and I just changed to Manjaro 2 days ago. I really don't think my cable got damaged in 2 days since in Pop Os( i also used kde in Pop ) it showed 300mbps

95% certain I am...

Just try manually setting 1 Gbps at half duplex (=500 Mbps)...

:stuck_out_tongue_winking_eye:

Hey man. Now I have a interesting problem. My wired connection doesn’t not work at all if I change it to manual and 1gbps half duplex :3
Not working at all, even the blinking light on my cable stops working. When I again set it to automatic 100mbps, it starts working again
What is this man

I am going to guess you are using an Intel based Ethernet adapter.

Is your system fully up to date?

Some Intel Ethernet adapters were having speed isuues on recent kernels, but I thought the changes were implemented to fix this recently.

So, make sure your system is fully up to date first.

If no improvement, then test older kernels where these issues were not present. Test out kernel 4.19, and if no better test kernel 4.14.

If that doesn't help then be sure to post your full system specs.


I clicked install on 4.19, it showed done, but in kernel settings it's still showing that I am running on 5.6.8-1.

  1. Did you try another cable? Yes / No

  2. Which means: please post the output of:

    inxi --full --verbosity=7 --filter --no-host
    
  3. Did you choose another kernel in the grub boot menu?

  1. Yes I did. same issue. Even this cable works fine on other devices.

Blockquote
System:
Kernel: 5.6.8-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: KDE Plasma 5.18.4 tk: Qt 5.14.2 info: latte-dock wm: kwin_x11
dm: SDDM Distro: Manjaro Linux
Machine:
Type: Laptop System: LENOVO product: 20NBS0B800 v: ThinkPad E590
serial: Chassis: type: 10 serial:
Mobo: LENOVO model: 20NBS0B800 serial: UEFI: LENOVO
v: R0YET41W (1.24 ) date: 12/18/2019
Battery:
ID-1: BAT0 charge: 44.5 Wh condition: 44.5/45.7 Wh (97%)
volts: 12.4/11.1 model: SMP 01AV447 type: Li-poly serial:
status: Full cycles: 109
Memory:
RAM: total: 7.62 GiB used: 2.69 GiB (35.3%)
RAM Report:
permissions: Unable to run dmidecode. Root privileges required.
CPU:
Topology: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP
arch: Kaby Lake rev: C L2 cache: 6144 KiB bogomips: 28808
Speed: 800 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 800 2: 800
3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
Flags: 3dnowprefetch abm acpi adx aperfmperf apic arat
arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl
dtes64 dtherm dts epb erms est f16c flush_l1d fma fpu fsgsbase fxsr ht
hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida
intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand rdseed rdtscp
rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
syscall tm tm2 tsc tsc_adjust tsc_deadline_timer vme x2apic xgetbv1
xsave xsavec xsaveopt xsaves xtopology xtpr
Graphics:
Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:3ea0
Device-2: AMD Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X]
vendor: Lenovo driver: amdgpu v: kernel bus ID: 03:00.0
chip ID: 1002:699f
Display: x11 server: X.Org 1.20.8 driver: amdgpu,intel FAILED: ati
unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11
resolution: 1366x768~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2)
v: 4.6 Mesa 20.0.6 direct render: Yes
Audio:
Device-1: Intel Cannon Point-LP High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9dc8
Sound Server: ALSA v: k5.6.8-1-MANJARO
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel port: 2000 bus ID: 04:00.0
chip ID: 10ec:8168
IF: enp4s0 state: up speed: 100 Mbps duplex: full mac:
Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: 2000
bus ID: 05:00.0 chip ID: 8086:2526
IF: wlp5s0 state: up mac:
IP v4: type: noprefixroute scope: global broadcast:
IP v6: type: noprefixroute scope: link
WAN IP:
Drives:
Local Storage: total: 1.14 TiB used: 383.92 GiB (32.8%)
ID-1: /dev/nvme0n1 vendor: Transcend model: TS256GMTE220S
size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 serial:
rev: 42B4S8JA scheme: GPT
ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172
size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm serial:
rev: LFM1 scheme: GPT
Message: No Optical or Floppy data was found.
RAID:
Message: No RAID data was found.
Partition:
ID-1: / size: 224.77 GiB used: 28.51 GiB (12.7%) fs: ext4
dev: /dev/nvme0n1p2 label: N/A
uuid: 208cd469-d8f8-484b-9151-387cf86d168d
ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat
dev: /dev/nvme0n1p1 label: N/A uuid: 690E-D507
ID-3: /run/media/tahmid/3c55e0c3-12cd-4f64-b1c3-451112a4ac35
size: 245.08 GiB used: 231.21 GiB (94.3%) fs: ext4 dev: /dev/sda3
label: N/A uuid: 3c55e0c3-12cd-4f64-b1c3-451112a4ac35
ID-4: /run/media/tahmid/571ea1b1-39ae-4da4-b4ff-99a2f832d10d
size: 245.08 GiB used: 59.1 MiB (0.0%) fs: ext4 dev: /dev/sda1
label: N/A uuid: 571ea1b1-39ae-4da4-b4ff-99a2f832d10d
ID-5: /run/media/tahmid/75fb966c-7ef8-4a2e-abbc-d4ebdd91d2d5
size: 467.4 MiB used: 97.8 MiB (20.9%) fs: ext4 dev: /dev/sda6
label: N/A uuid: 75fb966c-7ef8-4a2e-abbc-d4ebdd91d2d5
ID-6: /run/media/tahmid/9c91d588-c49a-49cd-80b2-4ff5d1e7ac6b
size: 415.38 GiB used: 124.02 GiB (29.9%) fs: ext4 dev: /dev/sda5
label: N/A uuid: 9c91d588-c49a-49cd-80b2-4ff5d1e7ac6b
ID-7: swap-1 size: 8.80 GiB used: 25.2 MiB (0.3%) fs: swap
dev: /dev/nvme0n1p3 label: N/A
uuid: fbd43c9c-e54b-4490-a7ae-05733904fb76
Unmounted:
ID-1: /dev/sda2 size: 4.00 GiB fs: vfat label: N/A uuid: CAE0-444A
ID-2: /dev/sda4 size: 4.00 GiB fs: swap label: N/A
uuid: b9fdadda-045e-4da9-8a77-b9a33958e657
USB:
Hub: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0
speed: 480 Mb/s chip ID: 1d6b:0002
Device-1: 1-4:2 info: Maxxter Wireless Receiver type: Mouse,Keyboard
driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s
chip ID: 248a:8514
Device-2: 1-6:4 info: Acer Integrated Camera type: Video
driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s
chip ID: 5986:2113
Device-3: 1-8:5 info: Synaptics type: driver: N/A
interfaces: 1 rev: 2.0 speed: 12 Mb/s chip ID: 06cb:00a2
serial:
Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1
speed: 10 Gb/s chip ID: 1d6b:0003
Sensors:
System Temperatures: cpu: 54.0 C mobo: 0.0 C gpu: amdgpu temp: 43 C
Fan Speeds (RPM): cpu: 0
Info:
Processes: 287 Uptime: 2h 19m Init: systemd v: 244 Compilers:
gcc: 9.3.0 Shell: bash v: 5.0.16 running in: konsole inxi: 3.0.37

When I restart, my laptop directly boots into manjaro, I don't find any grub menu

  1. Thank you.
  2. Analysing.
  3. Did you disable the grub menu? It looks somewhat like this:

(and you need the "advanced" options)

No sorry I never had this menu even When I used pop os. My laptop directly boots into manjaro.
This is from my bios. What to do now?
image

  1. Get out of the BIOS

  2. Boot into Manjaro

  3. Log on

  4. Execute:

    sudo nano --backup /etc/default/grub
    
  5. Change the following 2 lines:

    GRUB_DEFAULT=saved
    GRUB_TIMEOUT=3
    
  6. Ctrl+X Y Enter to save

  7. Execute:

    sudo update-grub 
    
  8. Reboot

  9. Go to Advanced options

  10. Choose the kernels different from 5.6 and try them out one by one and see if that helps.

:innocent:

I did it. Still laptop directly boots into my login screen
In my grub settings GRUB_DEFAULT was previously set to saved and GRUB_TIMEOUT was set to 10
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.6-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.6-x86_64.img
Found initrd fallback image: /boot/initramfs-5.6-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
done

and during the update grub command, there is a line saying unknown device type (that is my ssd where manjaro is installed)

I am truly sorry for bothering you a lot brother

There has been a bug reported with the r8168 adapter with some revisions. Apparently it is not loading properly on the first attempt. Perhaps reloading the driver after boot up may help until the patch comes through.

Try:

sudo modprobe -r r8169 && sudo modprobe r8169 && sudo systemctl restart NetworkManager 

If that does not work you could test the r8168 driver.

sudo mhwd -i pci network-r8168

Reboot after the driver install is complete.

1 Like

Follow TBG's advice first and if /etc/fefault/grub contains a GRUB_HIDDEN_TIMEOUT=0 add a # before it so it looks like this:

#GRUB_HIDDEN_TIMEOUT=0

and sudo upgate-grub again...

:innocent:

Forum kindly sponsored by