Slow Wired Connection Speed

Update1:
After running this command

sudo mhwd -i pci network-r8168

my wired connection is working when I set the Link Negotiation to Manual and speed to 1gbps and Half duplex
Previously, If I set it to 1gbps, my wired connection did not work at all
image
Yet, my connection speed is still showing 100mbps image

Well if you can live with that, then stick with the r8168 driver for now. You can wait for kernel patches to come through for the r8169 kernel module down the road. If you wish to test the r8169 module after a few kernel update cycles it can be done easily like this:

sudo modprobe -r r8168 && sudo modprobe r8169 && sudo systemctl restart NetworkManager 

This is everything inside the /etc/default/grub file
GRUB_DEFAULT=saved
GRUB_TIMEOUT=3
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=fbd43c9c-e54b-4490-a7ae-05733904fb76 udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

If you want to enable the save default function, uncomment the following

line, and set GRUB_DEFAULT to saved.

GRUB_SAVEDEFAULT=true

Preload both GPT and MBR modules so that they are not missed

GRUB_PRELOAD_MODULES="part_gpt part_msdos"

Uncomment to enable booting from LUKS encrypted devices

#GRUB_ENABLE_CRYPTODISK=y

Uncomment to use basic console

GRUB_TERMINAL_INPUT=console

Uncomment to disable graphical terminal

#GRUB_TERMINAL_OUTPUT=console

The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command 'videoinfo'

GRUB_GFXMODE=auto

Uncomment to allow the kernel use the same resolution used by grub

GRUB_GFXPAYLOAD_LINUX=keep

Uncomment if you want GRUB to pass to the Linux kernel the old parameter

format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

#GRUB_DISABLE_LINUX_UUID=true

Uncomment to disable generation of recovery mode menu entries

GRUB_DISABLE_RECOVERY=true

Uncomment and set to the desired menu colors. Used by normal and wallpaper

modes only. Entries specified as foreground/background.

GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

Uncomment one of them for the gfx desired, a image background or a gfxtheme

#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

Uncomment to get a beep at GRUB start

#GRUB_INIT_TUNE="480 440 1"

To view the grub advanced menu at startup repeatedly press either the ESC, SHIFT, or F8 key.

I GOT IT FINALLY. I went to the advanced options. What now?
image

You only have one kernel installed according to the grub menu.

Try installing alternate kernels from the terminal:

sudo mhwd-kernel -i linux414
sudo mhwd-kernel -i linux419
sudo mhwd-kernel -i linux54

Reboot

Which one should I choose? The one with fallback or without fallback?image

Choose the one without. The fallback image is a last resort.

No changes. Still showing 100mbps :frowning:

You can test out the r8169 module on different kernels via modprobing:

sudo modprobe -r r8168 && sudo modprobe r8169 && sudo systemctl restart NetworkManager 

Rebooting will return the system to using the r8168 driver.

You could also test out installing one of the Real Time kernels if you want to do further testing.

Sometimes kernel regressions don't get back ported as quickly on the real time kernels. You could test one of the Real Time kernels to see if the same issue is present. That would only be a temporary fix at best as the RT kernels eventually see changes from the mainline kernels applied to them as well.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by