So I've had it with Mozilla's incompetence.

Curiously I'm not experiencing any issues...but I've had FF open this whole time. Maybe this might be an explanation for me, but I'd rather wait until some confirmation comes out before doing the next batch of testing updates. I feel bad for people talking about losing 100+ tabs on the discourse site -- I'd never do more than 10 personally and never have FF running when suspending the system. @jonathon, are you monitoring firefox's build server for a version bump to get an expedited release on stable?

I'm also tired of FF, and I wish some new big player joined the fray with actual new ideas (i.e. new engine)


When even obscenely deep pockets like the Microborg give up and move to a branded Chromium clone ... well ... the odds of a new browser "player" sadly become very long indeed.


I've several FF instances.
@start all was ok, but suddendly (in the middle of a session), boom ! 80% of my add-ons where killed. (including ublock origin & decentraleyes)
Ok we're on GNU/Linux and impact shall be non existent, but W$ users will not be relax.
Not that wise at a time M$ adopted Chromium on Edge and campaigns against FF...

The Mozilla thread is here (when not on "429 too many requests")

1 Like

Me neither. Just applied testing updates from this morning (+ rebooted). Addon's are still working.

From that tweet:

We deployed a fix to users who hadn't had their add-ons disabled to make sure they saved that way. You're in that group. :slight_smile:

I'm wondering how that's working without updating FF itself.

I am a linux newbie in general, what should I do to make sure I have an updated firefox when it comes out? 66.0.3 Manjaro - 1.0 is the current version, is this effected by the signature issue? My addons seem fine.

Just wait and apply updates as they arrive. I'm pretty sure if mozilla releases a new version with a fix, the manjaro team will push that to the repos pretty quickly (like they do with security patches for FF). Actually I'm not even sure if it needs an update for FF to get this issue fixed.

Well, then you don't need to bother anyways.

(Hits palm on forehead) Thanks! I forgot about that one. Thank you for reminding me about Opera.:thinking:

Unfortunately, as you stated above, the version that one can trust, Opera 12, does not work on many web pages.

No; a server-side certificate issue can't be fixed by rebuilding a package.


It is the horror for political dissidents and journalists like Assnage who just got their TOR turned into a useless train wreck. You wouldn't be laughing if you had CIA operatives hunting you.

I wonder how many people did Mozilla just kill?

Thankfully the main elements of Tor Browser still work, the only "bundled" extension which was disabled is NoScript.


Would you run scripts if you were behind TOR? Would you allow WebRTC to leak your local IP?

All these can be disabled on TOR browser itself without needing extension.

Tor Browser doesn't disable Javascript by default - it tries to make the browser as "normal" as possible to provide anonymity (e.g. against fingerprinting).

NoScript provides extra things like ClickJacking and XSS protection.

I like how the website you linked say this explicitely.

Set the system clock back 24 hours. This has been tested on some installations of Firefox on Windows and Linux but doesn’t appear to work in all instances, based on our limited testing. The idea is to set your computer's clock back to the time before the certificate was set to expire.

Set the system clock back 24 hours.

It made me laugh a little bit, some people will understand why. :smiley:

EDIT: Even ZDnet give the same kind of workaround.

One possible way to resolve this issue, as recommended by many Firefox users, would be to turn system clocks before May 4, 12:00am UTC (the date at which the Mozilla certificate expired), but this would also break other apps running locally, and which depend on an accurate system clock


Update unstable
firefox-developer-edition 67.0b16-1 (67.0b15-1) community

Yellow warning on top gone but add-ons too, sh!t.

Everybody can make a mistake, ok, but then to report that you should check your internet access is bold.

Back to normal.
Just need to quit & restart FF.

They surely had a sweat day :stuck_out_tongue:

1 Like

it's not like you are wrong, just... dreaming is free (for now)

For those that like me still have this issue and don't want to enable the "Study system"
I found this on the German forum:

  1. Go to about:config
  2. change to true
  3. press shift+ctrl+j
  4. In the input bar at the bottom paste this code and press enter:
// Re-enable *all* extensions
async function set_addons_as_signed() {
 let addons = await XPIDatabase.getAddonList(a => true);

 for (let addon of addons) {
 // The add-on might have vanished, we'll catch that on the next startup
 if (!addon._sourceBundle.exists())

 if( addon.signedState != AddonManager.SIGNEDSTATE_UNKNOWN )

 addon.signedState = AddonManager.SIGNEDSTATE_NOT_REQUIRED;

 await XPIDatabase.updateAddonDisabledState(addon);



It will reenable all addons for 24 hours. After that, run it again, if it is still not fixed.


Forum kindly sponsored by