Software rendering keeps getting enabled

What did you do to get it usable? You solved the screen freezing?

Yes, i solved the screen freezing i put up a while ago, but now cinnamon keeps popping up when i log on saying im running in software rendering mode

Which means something is wrong..

inxi -Fxxxz
mhwd -li
journalctl -b -p 3
dmesg | grep -E "nvidia|nouveau|gpu|error"

output from mhwd -li

output from inxi -Fxxxz

The dmesg | grep -E "nvidia|nouveau|gpu|error" Provided no output
and the journalctl command provided lines flooded with errors about an issue i was facing a long time ago (well over 1 million lines) that has long been resolved

How exactly? Your system is showing 2 graphics devices. In your other thread you mentioned you had Intel graphics but had it disabled. That no longer seems to be the case. This is probably part of the problem.

On a desktop system the onboard graphics is usually turned off in the BIOS (assuming we have dedicated graphics) and should not show.

This command only outputs warnings since the last boot. If you have over 1 million lines of output from this command, it means you have problems. Please show a sample of the output.

Also please give text output if you can, not a screenshot.

like @korealinux said something is wrong with your configuration for nvidia gpu

1 Like

Yup. Your drivers are not configured properly.

You have dual cards.

You should be using either PRIME or bumblebee.

Do you have a preference?

That screen freezing issue usually will come back, but fixes itself somehow after a little while, i rebooted my computer to get fresh output from journalctl, look below, and to @cscs , Which one is recommended and more stable in regards to PRIME or bumblebee, but already looks as if there is something from bumblebee running
journalctl -b -p 3 output:

And a brief history about that error I was speaking of earlier, I ran pacman -Syu, rebooted, and when it started booting again, it was spewing out acpi error: AE_NOT_FOUND, this was fixed when I updated to the latest kernal

imo you should't have any bumblebee stuff installed if you're not using bumblebee.
can you show which gpu/bumblebee related packages are installed?
(e.g. pacman -Q | grep -iE 'bumble|primus|nvidia|video')

acpi errors can usually be ignored, at least for your current issue

Heres the output of the pacman command, the acpi errors were more of an annoyance than anything, but its not an issue now.
the screen will do its freezing once a second for about half a second for like a day, then the next day it would be fine, no clue about that

No. Look at mhwd. See how it reports nvidia, not bumblebee? Thats wrong.

Then in inxi it shows it attempted to load nvidia, but failed .. probably because it was trying to fire up your intel card with nvidia...

If you want to use bumblebee you should do:

sudo mhwd -f -i pci video-hybrid-intel-nvidia-bumblebee

Which would then mean you use the intel card by default, then use something like primusrun when you want to kick in the nvidia card

To my knowledge bumblebee is installed, but i tried the command you sent and I get,

Warning: no matching device for config 'video-hybrid-intel-nvidia-bumblebee' found!
Error: config 'video-hybrid-intel-nvidia-bumblebee' conflicts with config(s): video-nvidia

In manjaro we handle drivers with mhwd - not by just installing packages manually - unless you know what you are doing and are trying to accomplish something specific.

You have 2 graphics cards.
This means you can do one of 3 things
1 - bumblebee
3 - if you are lucky you have an option in BIOS to disable one of the 2 cards

You have done something other than those 3 things, so it is expected that you have issues. to your scenario.
It wont let you install bumblebee? hm. thats odd. Maybe because of the load failures.

I think a good idea is trying to install video-linux, remove video-nvidia, boot with video-linux and try to install bumblebee again.

[oh .. and depending on what you did already .. there might be some cleanup to do in /etc/X11/xorg.conf.d and/or /etc/X11/mhwd.d/]

Shall i reinstall video-nvidia after I install bumblebee or is bumblebee its own thing?
I want to get clarification before I do anything because ive never messed with bumblebee

bumblebee provides both intel and nvidia, and the ability to switch between them - using nvidia alone is why you are having problems.

So no, dont reinstall it or anything.

Alright, so i went ahead and did just that, so the only driver i have installed now is
video-hybrid-intel-nvidia-bumblebee and when i went to reboot it, it stopped at
[ OK ] Started TLP system startup/shutdown, so i went to tty2, (ctrl+alt+f2) to see what was going on, and startx throws out an error.
it wont boot into a GUI, but i still have access to the tty lines
it did the same thing when I reinstalled video-linux to put the bumblebee driver on

Okey. whats the errors?
And maybe
systemctl status lightdm

Active :failed (code=exited, status=1/FAILURE) failed to start light display manager,

startx command:
Server terminated with error (1)
xinit:giving up
xinit: unable to connect to the X server: Connection refused
xinit : server error

(i apologize about not having screenshots, im unable to get to the GUI if you need additional info just ask)

Forum kindly sponsored by