[Solved] 18.04 GNOME, Black screen with only underscore after update, no tty

Black screen happened after I chose from "Manjaro Linux" and "Advanced options for Manjaro Linux".
Then it said

"Loading Linux 5.0-rt-x86_64 ..."
"Loading initial ramdisk ..."
"mount: /sys/firmware/efi/efivars: unknown filesystem"
"Starting version 242.32-3-arch"

Then there's only an underscore on the screen. The underscore would only blink when power button is pushed. Then the computer was turned off.

Ctrl+Alt+F1~F8, Alt+F1~F8 did nothing to the black screen.
Tried different Linux version in the first graph interface. Nothing changed.
Tried to insert acpi_osi=! acpi_osi=“Windows 2009” in the grub file. Nothing changed.

This happened after the computer was updated.


Finally solved by myself. Here is a tutorial for freshmen like me.

If you've got another computer, the best choice is to make an live installation media and chroot. However I didn't so I had to go through the hard way.

For those who has another computer please jump to 4.

  1. Press 'E' at the grub menu. Add
init=/bin/bash

at the end of

linux          /boot/vmlinuz-linux  root-UUID=d474f2-e6a2-4cc3-9899-aa98af13  rw  quiet 

Then press F10 or Ctrl+X. Well, the root UUID may verify.

  1. Mount all your disks. Following are my steps. Check lsblk -f when needed.
mount /dev/sdb3 /boot
mount /dev/sdb2 /boot/efi
mount /dev/sdb5 /home
mount /dev/sda1 /home/Downloads
  1. Deal with the network
lspci -v | grep Ethernet -8
# replace "e1000e" with the name after "Kernel modules: "
modprobe e1000e
ip link
# Find your ethernet card name and replace the following eth0.
# Notice that the one with "LOOPBACK" tag is the wrong one.
ip link set eth0 up
dhcpcd eth0 # try killall dhcpcd if failed
  1. Check your pacman log with
cat /var/log/pacman.log | grep "2019-07-15" |  grep 'installed|upgraded'
# Then try to roll back your operations with pacman.
# That is why we need network here.
  1. Check your system log with
journalctl -x -b -1 | grep -iE 'fail|error|unable'
# -x for more information, -b -1 means the information for last boot

Here I found the error:

loading shared libraries: libnettle.so.6: cannot open shared object file: No such file or directory
Jul 15 22:30:14 manjaro /usr/lib/gdm-x-session[538]: Unable to run X server

So I just reinstalled the nettle package and then entered

exec /sbin/init

And everything went right!

BTW, there's no discrete graphics in this computer.
Integrated graphics is used.

Try in tty

sudo pacman-mirrors -f5 && sudo pacman -Syyu

If that does not help try it with a different kernel.
If you don't have another one installed you can do this with the following command.

sudo mhwd-kernel -i linux419

or

sudo mhwd-kernel -i linux51

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by