[SOLVED] After update, desktop boots into emergency mode

Okay, so I apologize for how rough this is going to be, but I'm trying to troubleshoot this from my phone, rather than my desktop. I recently did a system upgrade (pacman -Syu), which looked fine, but now my poor desktop is booting into "emergency mode". It gives me a list of things during the boot attempt, two of which appear to be of interest:
[FAILED] Failed to start Load Kernel Modules, and
[FAILED] Failed to mount /boot/efi

Now I have a bit of a theory, which may or may not be a crap theory, but after some digging, I suspect that whatever module is used to load FAT-32 filesystems is failing to load, and thus my efi partition is nopeing out. I'm unsure of how to fix this, however.

Edit: I have also noticed that, even though I have kernel package 4.9.77 installed, uname -r tells me my actual kernel version number is 4.9.74. Could this discrepancy be causing the issue?

Can you boot to fallback mode? Are you running kernel 4.15?
Anyway the basics would be to

  1. Boot to TTY from Grub menu (you can add a 3, or systemd.unit=multi-user.target to the linux line) and login
  2. Re-install kernel with sudo mhwd-kernel -i linux414

Reboot and see what happens.

If that fails try just rebuilding the init ram disk with
sudo mkinitcpio -p linux414

If you need detail instructions on the grub part see my general notes here.

Edit, forgot to add >> If using grub does not work, chroot into your manjaro install and run the instructions from there.

I'm currently running kernel 4.9. I didn't want to update the kernel prior to finishing my thesis in a couple of months :weary: - see my edit, maybe it helps?

Ok seems like we are on the right track, just substitute 49 for where ever I write 414.

So, my fallback image just dumps me into emergency mode the same way, and entering into command line mode doesn't change anything (modules still fail to load and /boot/efi fails to mount, and I end up in emergency). Mhwd-kernel tells me I'm not allowed to reinstall my current kernel. I would have thought my fallback should have been kernel 4.4 (which I do have on the system), but grub doesn't seem to have it listed.
Edit: I should say that I have 4.4 in /boot, not that it's installed.

Ok, you will have to use a live usb to chroot into the system and then perform the kernel rebuild from there.
There should be instructions on the Manjaro wiki and in the forums (tutorial section probably).
Good Luck.

If you can get in, do

sudo pacman-mirrors -f 3
sudo pacman -Syyu

You probably just need to fully update your system.

Okay, so, I've fixed it. For future reference, there was in fact a discrepancy between the installed kernel package and the kernel that GRUB was pointing to. I haven't the slightest clue as to how this occurred, but basically, uname -r gave me the previous kernel version (as per the original post), which was also alluded to in the GRUB menu (accessed by hitting 'e' in the GRUB menu). The latest (installed) version of the kernel could be found by searching /var/cache/pacman/pkg | grep linux.

The fix was to remove all the old manjaro GRUB bootloaders from /boot/efi/EFI (which required a liveCD/USB, because for some reason VFAT capability is still a kernel module, rather than baked-in), and running the GRUB reinstall command from chroot, for which I used the commands found here: https://wiki.gentoo.org/wiki/Chroot#Configuration (to set up the chroot environment), and here:

I imagine there are easier ways of fixing this, but my knowledge is largely a patchwork of old pre-systemd Arch and Gentoo/Funtoo stuff, and we all work with what we know :/. Hope this helps somebody else in the future!

Glad you fixed it :grin:
Just in case someone does find this thread please try my instructions in post #2 it would have done the same thing.
It just needed to be chrooted first instead of getting in with grub.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by