[SOLVED] Architect 17.04 is unstable (crashes)

Running Architect on my notebook crashes early on in the install process.

My failing procedure:

  • Used Etcher to burn one USB drive with the rEFInd USB boot image
  • Used Etcher to burn another USB drive with Manjaro Architect ISO 17.04
  • Plug both into my notebook, power on, hit F7 to enter BIOS boot menu, select the rEFInd USB drive
  • rEFInd boot menu starts, hit F2 twice to edit command line, and entered:
    "misobasedir=manjaro misolabel=MJRO1704 linux=boot\vmlinuz-x86_64 initrd=boot\initramfs-x86_64.img"
  • It boots up and I see the Manjaro Architect login/setup prompt.
    Sometimes I'm able to login and start the install but more often it crashes/panics/segfaults with Kernel stack dump at the very beginning after login.
    One time it got as far as wifi connected to and updating then it crashed before even starting the installation.
    For me it is unstable and unusable on this notebook. Since the 17.1-pre2 Xfce ISO works, it looks like Architect needs some updates? I'm guessing some loaded module is crashing. Is there a way to limit what gets loaded? Or how do I debug this?

My notebook's BIOS does not support Linux/Grub booting so I have always used the rEFInd boot loader successfully with various distro's including Manjaro. Note: here that it works fine for installing via the 17.1-pre2 ISO:
https://archived.forum.manjaro.org/t/solved-refind-live-usb-wont-boot-w-manjaro-xfce-17-1-pre2-nor-17-06/34993/15?u=bako62

Did you try just booting from the Architect USB directly?

So your BIOS does not support booting other OS's from USB period?

You sure Secure Boot and Fast Boot are turned off?

Yes, SB & FB are off.
It seems anything using Grub won't work. Supposedly (reportedly) this is due to the BIOS on some machines not being Linux/Grub compatible. The only distro I've been able to boot directly (without rEFInd) is the Antergos Live-USB install ISO. So I'm guessing Antergos uses something other than Grub. The solution for everyone with my notebook - and a very MANY other inexpensive ones (read China made) using Apollo-Lake CPU's (eg. Pentium N4200, Celeron N3450) - is to use the rEFInd boot manager.
PS. My recommendation would be to change to using whatever boot method Antergos is using, if it's not TOO much work. Because this will enable a whole lot more of these inexpensive quad-core machines to install Manjaro. And I can testify Manjaro Xfce runs a lot better (faster) than both Ubuntu and Antergos Gnome on these relatively low powered machines (compared to Intel Core-i3/5/7).

Fair enough.

My guess is that it fails because of the rEFInd way of doing it.
Have you tried with other ISO's, not just Architect?
Like 17.0.6 of XFCE?
You mentioned the XFCE 17.1 pre2 is working, but that's running on unstable/testing branch.

17.06 did not work for me, but I will try it again just to make sure I'm not remembering incorrectly. I've tried so many diff ones, tough to remember :wink:

Well I checked the Sha1 of the Architect ISO which was OK. Then burned again the USB but plugged into the slower USB 2 port rather than USB 3.0 port. Then I tried again the Architect installation and it progressed with no crash. So I'm chalking this up to flaky USB drive or flashing for some reason. The drive is a Sandisk Ultrafit 8GB and these end to run really hot. Anyway, it seems no fault of Architect so I'm closing this issue. Though I may still try 17.06 again with similar procedure.

1 Like

Forum kindly sponsored by