[SOLVED] [Atheros AR9462] Wifi keeps dropping randomly

I have just moved into University accommodation and have started having issues with the WiFi on my desktop. This doesn't seem to be an issue with the WiFi itself because both my Android phone and tablet don't seem to be experiencing this issue.

What keeps happening is when I am using the internet suddenly everything start to drop. The WiFi still appears to be connected but eventually the KDE network applet turns orange. Every time this happens I have to keep reconnecting it which temporarily fixes the issue. The time for it to go down every time is not the same.

This is the WiFi adapter that is in my PC: https://www.amazon.co.uk/fenvi-Desktop-Dual-band-600Mbps-Support/dp/B0721JZZJM/ref=sr_1_5?keywords=fenvi+wifi+adapter&qid=1569839992&s=gateway&sr=8-5

1 Like

From other sources:

And apparently that made the wifi work better.
What else have you tried so far?

I cannot access any of the WiFi infrastructure because I don't own it. It is a private company that provides for the University owned accommodation and the support from the company is shocking. They will never do anything.

I haven't tried anything else. I will set the options iwlwifi 11n_disable=8 and see if that makes it any better. I will get back with the results

Please post:

inxi -Fxxxz

First thing to do is test each kernel available from 4.14 to 5.3. If the kernel version does not bring any improvement then changing the linux-firmware version may help. The iwlwifi firmware has been experiencing many issues recently and older versions may provide more stability.

This is assuming your adapter even has an Intel chip inside. Advertisments mean very little as manufactures can change the chip being used with no notice. Terminal outputs are the only way to accurately identify the chip model in use.

$ inxi -Fxxxz
System:    Host: PICARD Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: KDE Plasma 5.16.4 
           tk: Qt 5.13.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: MSI model: Z97 GAMING 3 (MS-7918) v: 1.0 serial: <filter> UEFI: American Megatrends v: 2.6 
           date: 12/24/2014 
CPU:       Topology: Quad Core model: Intel Core i5-4690K bits: 64 type: MCP arch: Haswell rev: 3 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28015 
           Speed: 2184 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 1628 2: 1520 3: 1664 4: 1588 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: Tul 
           driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.5 driver: amdgpu compositor: kwin_x11 resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.32.0 5.2.11-1-MANJARO LLVM 8.0.1) v: 4.5 Mesa 19.1.5 
           direct render: Yes 
Audio:     Device-1: Intel 9 Series Family HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:8ca0 
           Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Tul driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 1002:aaf0 
           Sound Server: ALSA v: k5.2.11-1-MANJARO 
Network:   Device-1: Qualcomm Atheros Killer E220x Gigabit Ethernet vendor: Micro-Star MSI driver: alx v: kernel port: d000 
           bus ID: 03:00.0 chip ID: 1969:e091 
           IF: enp3s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros AR9462 Wireless Network Adapter vendor: Foxconn driver: ath9k v: kernel port: d000 
           bus ID: 06:00.0 chip ID: 168c:0034 
           IF: wlp6s0 state: up mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 4.78 TiB used: 1.06 TiB (22.2%) 
           ID-1: /dev/sda vendor: Seagate model: ST2000DM006-2DM164 size: 1.82 TiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: CC26 scheme: GPT 
           ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-00BN5A0 size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: 1A01 scheme: GPT 
           ID-3: /dev/sdc vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB speed: 6.0 Gb/s serial: <filter> rev: 023 
           scheme: GPT 
           ID-4: /dev/sdd type: USB vendor: Seagate model: Expansion size: 1.82 TiB serial: <filter> rev: 0710 scheme: GPT 
Partition: ID-1: / size: 212.19 GiB used: 154.41 GiB (72.8%) fs: ext4 dev: /dev/sdc3 
           ID-2: swap-1 size: 16.00 GiB used: 11.86 GiB (74.1%) fs: swap dev: /dev/sdc2 
Sensors:   System Temperatures: cpu: 33.0 C mobo: N/A gpu: amdgpu temp: 29 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 1083 
Info:      Processes: 282 Uptime: 4d 3h 12m Memory: 11.68 GiB used: 9.14 GiB (78.2%) Init: systemd v: 242 Compilers: 
           gcc: 9.1.0 alt: 6 clang: 8.0.1 Shell: zsh v: 5.7.1 running in: tilix inxi: 3.0.36 

I've replaced the card with an intel card and the issue seems to be fixed. It must have been
Atheros card conflicting with the WiFi.

1 Like

So you are saying you replaced the Atheros Killer E220x Gigabit Ethernet adapter with an Intel adapter, and then your Atheros AR9462 Wireless adapter began functioning correctly (or was it the other way around).

I must say that is rather unusual as most Atheros drivers (with a few exceptions) are pretty bug free, and I've never read of any Atheros driver conflicts in recent times.

Some Broadcom driverss are known to cause conflicts, but Atheros drivers seem pretty conflict free. Please do me a favor and clarify your solution, (so as to to remove any uncertainty).

Thank you for reporting your solution.

I completely removed the atheros card and replace it with an intel card. It could be that the driver was fine but just was not playing ball with the particular WiFi that I have.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by