[SOLVED] Atheros QCA6174 - Intermittent WiFi Failure (Dell XPS 9560)

Using a reasonably fresh install (about 1-2 weeks ago) I am now experiencing regular intermittment network failures that I cannot trace the origin of. dmesg and journalctl did not indicate anything out of the ordinary except UFW blocking some DNS multicast requests. After allowing the proper ports out the failures are still occurring.

This failure only occurs on this laptop.

Things I've tried

  1. rfkill does not show any wifi blocks.
  2. Reinstalling NetworkManager.
  3. Replacing dhcpcd with dhclient in NetworkManager and disabling dhcpcd via systemctl.
  4. yay -Syu
  5. Checking router, ISP, etc
  6. Disabling power save in NetworkManager

Current Fixes

The only thing that seems to work is by running sudo dhclient when the failures occur. After this I am able to immediately connect to everything again.

Information

Here is the inxi -Fxxxz report

ystem:    Host: mypc Kernel: 5.4.23-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.1 Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 
           info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: XPS 15 9560 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 05FFDN v: A00 serial: <filter> UEFI: Dell v: 1.9.4 date: 04/23/2018 
Battery:   ID-1: BAT0 charge: 83.5 Wh condition: 83.5/97.0 Wh (86%) volts: 13.1/11.4 model: SMP DELL GPM0365 type: Li-ion 
           serial: <filter> status: Full 
CPU:       Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44817 
           Speed: 1200 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 1200 2: 1200 3: 1200 4: 1200 5: 1200 6: 1200 7: 1200 
           8: 1200 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:591b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Dell driver: N/A bus ID: 01:00.0 chip ID: 10de:1c8d 
           Display: x11 server: X.Org 1.20.7 driver: modesetting alternate: fbdev,intel,vesa 
           resolution: 1920x1080~60Hz, 2560x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.6 Mesa 19.3.5 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a171 
           Sound Server: ALSA v: k5.4.23-1-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Bigfoot Networks driver: ath10k_pci 
           v: kernel port: e000 bus ID: 02:00.0 chip ID: 168c:003e 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1-4:2 chip ID: 0cf3:e301 
Drives:    Local Storage: total: 476.94 GiB used: 15.56 GiB (3.3%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: PM981 NVMe 512GB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: EXA72D1Q scheme: GPT 
Partition: ID-1: / size: 468.16 GiB used: 15.56 GiB (3.3%) fs: ext4 dev: /dev/dm-0 
Sensors:   System Temperatures: cpu: 64.0 C mobo: 43.0 C sodimm: 46.0 C 
           Fan Speeds (RPM): cpu: 3186 

I've never experienced this problem before and I have had quite a few Manjaro installs. It appears many other people are experiencing this as well. Is there a fix available?

Did you disable dhcpd, yor did you mask dhcpd.

I think masking it is the better alternative.

The qca6174 adapter is also experiencing firmware issues ATM.

Try this:

Add ipv6 disable & pcie_aspm=off via grub boot parameters.

The following command will add GRUB kernel boot parameters to /etc/default/grub:

sudo cp /etc/default/grub /etc/default/grub.bak && sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ ipv6.disable=1 pcie_aspm=off "/g' -i /etc/default/grub

After adding the boot parameter(s) and saving your changes, run:

sudo update-grub 

Reboot, and test your connection for improvement.

*sed magic courtesy of @dalto


If the change does not improve your connectivity you can restore the file to its original state with:

sudo cp /etc/default/grub.bak /etc/default/grub
2 Likes

Ah I masked it. I will try that and report back if anything changes. Thank you! I should add that I also upgraded to Kernel 5.5 with no avail.

Also try kernel 5.6


If your wifi is still not working correctly then try adding an ath10k driver option file to /etc/modprobe.d:

echo "options ath10k_core skip_otp=y" | sudo tee /etc/modprobe.d/ath10k.conf 

Reboot.



You may want to test a newer alternate firmware I have found.

The ath10k QCA6174 firmware has been reported as buggy and apparently Arch has recently patched it. However, it may take some time for this to reach the stable branch. In the mean time you could try this:

Rename the /usr/lib/firmware/ath10k/QCA6174/ board-2.bin files:

sudo mv /usr/lib/firmware/ath10k/QCA6174/hw2.1/board-2.bin /usr/lib/firmware/ath10k/QCA6174/hw2.1/board-2.bin.bak
sudo mv /usr/lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin /usr/lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin.bak

Replace the /usr/lib/firmware/ath10k/QCA6174/board.bin files with:

http://www.killernetworking.com/support/K1535_Debian/board.bin

Download the file from http://www.killernetworking.com/support/K1535_Debian/board.bin to your ~/Downloads directory.

Then (on your user account, not root):

cd ~/Downloads
sudo cp ~/Downloads/board.bin /usr/lib/firmware/ath10k/QCA6174/hw2.1/board.bin
sudo cp ~/Downloads/board.bin /usr/lib/firmware/ath10k/QCA6174/hw3.0/board.bin

Reboot.

(Edit)

Overwriting the default firmware with this alternate firmware has tentatively fixed the OP's issue. This firmware swap was also reported to have worked on another QCA6174 problem I worked on yesterday. So, it appears this is a reliable fix for those experiencing firmware issues with this adapter.

This is the second time I've seen you recommend that. I know you know what you're doing, but why are you recommending it? Folks should know what they're installing and why before they blindly follow commands that require sudo on the interwebs.

Because Google often releases newer firmware before it hits the main linux-firmware github repositories. You have the choice of waiting for it to work its way into the main linux-firmware package, or you can test the developmental versions from other sources.

There's really not much risk involved as I always have the user create backups before overwriting any files and it's not some random file from a file sharing service that is suspect. Even then, the system can easily be reverted to its original state by simply reinstalling the linux-firmware package.

Well sure, but how did you know Killer Networking had the driver? I see they partner with various OEM's including Dell, but I don't see a landing page or anything directing anyone to it.

Probably not common knowledge as you say. However, I do a fair bit of sifting the internet for wifi bugs on a daily basis and come across new info regularly:

Aha! Thanks for sharing that. I suggest linking sources like that in the future. :wink:

1 Like

So it doesn't appear the fixes so far have worked. Only thing I havent tried is the driver swap. I will do that tonight.

1 Like

So far so good with the driver swap. I will report back if it doesn't work. If you don't hear from me - this solution will work for the Dell XPS 9560.

Well that is very good news that replacing the firmware has apparently solved your problem. I will be sure to recommend this on other help requests now that it has proven worthwhile.

It was pure luck I found that fix as I was searching Intel firmware issues at the time. I'm so glad I came across that and that it helped with your issue.

Seems I had an intermittent failure this morning after a few days of good progress. Will see if I can get more information from it.

1 Like


Track Network Manager errors in real time:

Enable Network Manager's debugging mode with the following command:

echo -e "[logging]\nlevel=DEBUG" | sudo tee /etc/NetworkManager/conf.d/00-defaults.conf && sudo systemctl restart NetworkManager

This will enable the output of a far more in depth log of Network Manager's activities.

The command below will output a live log in real time detailing your current network status.

To open a live debug log session in terminal, enter:

journalctl -fu NetworkManager 

Let the command run in the terminal, logging all current network activities.

Log at least 50-100 lines of output around times when your connection has failied/restarted.

Post any important looking excerpts from the log (especially around failure events).



2 Likes

Ok I have some logs:

Mar 22 11:29:29 mypc NetworkManager[38354]: <debug> [1584901769.9628] connectivity: (p2p-dev-wlp2s0,IPv4,775) start fake request (fake result)
Mar 22 11:29:29 mypc NetworkManager[38354]: <debug> [1584901769.9628] connectivity: (p2p-dev-wlp2s0,IPv6,776) start fake request (fake result)
Mar 22 11:29:29 mypc NetworkManager[38354]: <debug> [1584901769.9629] connectivity: (p2p-dev-wlp2s0,IPv4,775) check completed: FAKE; fake result
Mar 22 11:29:29 mypc NetworkManager[38354]: <debug> [1584901769.9629] connectivity: (p2p-dev-wlp2s0,IPv6,776) check completed: FAKE; fake result
Mar 22 11:29:39 mypc NetworkManager[38354]: <debug> [1584901779.3225] connectivity: (wlp2s0,IPv6,777) skip connectivity check due to no IP address configured
Mar 22 11:29:39 mypc NetworkManager[38354]: <debug> [1584901779.3226] connectivity: (wlp2s0,IPv6,777) check completed: NONE; no IP address configured
Mar 22 11:29:57 mypc NetworkManager[38354]: <debug> [1584901797.5265] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scanning requested but not allowed at this time
Mar 22 11:29:57 mypc NetworkManager[38354]: <debug> [1584901797.5266] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scheduled in 43 seconds (interval now 43 seconds)
Mar 22 11:30:02 mypc NetworkManager[38354]: <debug> [1584901802.4875] connectivity: (wlp2s0,IPv4,778) start request to 'http://www.archlinux.org/check_network_status.txt' (systemd-resolved not available)
Mar 22 11:30:02 mypc NetworkManager[38354]: <debug> [1584901802.8211] connectivity: (wlp2s0,IPv4,778) check completed: FULL; expected response
Mar 22 11:45:02 mypc NetworkManager[38354]: <debug> [1584902702.4866] connectivity: (wlp2s0,IPv4,790) start request to 'http://www.archlinux.org/check_network_status.txt' (systemd-resolved not available)
Mar 22 11:45:02 mypc NetworkManager[38354]: <debug> [1584902702.8111] connectivity: (wlp2s0,IPv4,790) check completed: FULL; expected response
Mar 22 11:45:43 mypc NetworkManager[38354]: <debug> [1584902743.5231] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scanning requested but not allowed at this time
Mar 22 11:45:43 mypc NetworkManager[38354]: <debug> [1584902743.5232] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scheduled in 43 seconds (interval now 43 seconds)
Mar 22 11:46:26 mypc NetworkManager[38354]: <debug> [1584902786.5230] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scanning requested but not allowed at this time
Mar 22 11:46:26 mypc NetworkManager[38354]: <debug> [1584902786.5231] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scheduled in 43 seconds (interval now 43 seconds)
Mar 22 11:47:09 mypc NetworkManager[38354]: <debug> [1584902829.5229] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scanning requested but not allowed at this time
Mar 22 11:47:09 mypc NetworkManager[38354]: <debug> [1584902829.5230] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scheduled in 43 seconds (interval now 43 seconds)
Mar 22 11:47:52 mypc NetworkManager[38354]: <debug> [1584902872.5278] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scanning requested but not allowed at this time
Mar 22 11:47:52 mypc NetworkManager[38354]: <debug> [1584902872.5278] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scheduled in 43 seconds (interval now 43 seconds)
Mar 22 11:48:35 mypc NetworkManager[38354]: <debug> [1584902915.5218] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scanning requested but not allowed at this time
Mar 22 11:48:35 mypc NetworkManager[38354]: <debug> [1584902915.5219] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scheduled in 43 seconds (interval now 43 seconds)
Mar 22 11:49:18 mypc NetworkManager[38354]: <debug> [1584902958.5229] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scanning requested but not allowed at this time
Mar 22 11:49:18 mypc NetworkManager[38354]: <debug> [1584902958.5230] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scheduled in 43 seconds (interval now 43 seconds)
Mar 22 11:49:29 mypc NetworkManager[38354]: <debug> [1584902969.9631] connectivity: (p2p-dev-wlp2s0,IPv4,791) start fake request (fake result)
Mar 22 11:49:29 mypc NetworkManager[38354]: <debug> [1584902969.9632] connectivity: (p2p-dev-wlp2s0,IPv6,792) start fake request (fake result)
Mar 22 11:49:29 mypc NetworkManager[38354]: <debug> [1584902969.9632] connectivity: (p2p-dev-wlp2s0,IPv4,791) check completed: FAKE; fake result
Mar 22 11:49:29 mypc NetworkManager[38354]: <debug> [1584902969.9633] connectivity: (p2p-dev-wlp2s0,IPv6,792) check completed: FAKE; fake result
Mar 22 11:49:39 mypc NetworkManager[38354]: <debug> [1584902979.3229] connectivity: (wlp2s0,IPv6,793) skip connectivity check due to no IP address configured
Mar 22 11:49:39 mypc NetworkManager[38354]: <debug> [1584902979.3230] connectivity: (wlp2s0,IPv6,793) check completed: NONE; no IP address configured
Mar 22 11:50:01 mypc NetworkManager[38354]: <debug> [1584903001.5232] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scanning requested but not allowed at this time
Mar 22 11:50:01 mypc NetworkManager[38354]: <debug> [1584903001.5233] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scheduled in 43 seconds (interval now 43 seconds)
Mar 22 11:50:02 mypc NetworkManager[38354]: <debug> [1584903002.4845] connectivity: (wlp2s0,IPv4,794) start request to 'http://www.archlinux.org/check_network_status.txt' (systemd-resolved not available)
Mar 22 11:50:02 mypc NetworkManager[38354]: <debug> [1584903002.8119] connectivity: (wlp2s0,IPv4,794) check completed: FULL; expected response
Mar 22 11:50:44 mypc NetworkManager[38354]: <debug> [1584903044.5229] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scanning requested but not allowed at this time
Mar 22 11:50:44 mypc NetworkManager[38354]: <debug> [1584903044.5230] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scheduled in 43 seconds (interval now 43 seconds)
Mar 22 11:51:27 mypc NetworkManager[38354]: <debug> [1584903087.5267] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scanning requested but not allowed at this time
Mar 22 11:51:27 mypc NetworkManager[38354]: <debug> [1584903087.5268] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scheduled in 43 seconds (interval now 43 seconds)
Mar 22 11:52:10 mypc NetworkManager[38354]: <debug> [1584903130.5280] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scanning requested but not allowed at this time
Mar 22 11:52:10 mypc NetworkManager[38354]: <debug> [1584903130.5281] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scheduled in 43 seconds (interval now 43 seconds)
Mar 22 11:52:53 mypc NetworkManager[38354]: <debug> [1584903173.5219] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scanning requested but not allowed at this time
Mar 22 11:52:53 mypc NetworkManager[38354]: <debug> [1584903173.5220] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scheduled in 43 seconds (interval now 43 seconds)
Mar 22 11:53:36 mypc NetworkManager[38354]: <debug> [1584903216.5230] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scanning requested but not allowed at this time
Mar 22 11:53:36 mypc NetworkManager[38354]: <debug> [1584903216.5231] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scheduled in 43 seconds (interval now 43 seconds)
Mar 22 11:54:19 mypc NetworkManager[38354]: <debug> [1584903259.5230] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scanning requested but not allowed at this time
Mar 22 11:54:19 mypc NetworkManager[38354]: <debug> [1584903259.5230] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scheduled in 43 seconds (interval now 43 seconds)
Mar 22 11:54:29 mypc NetworkManager[38354]: <debug> [1584903269.9633] connectivity: (p2p-dev-wlp2s0,IPv4,795) start fake request (fake result)
Mar 22 11:54:29 mypc NetworkManager[38354]: <debug> [1584903269.9634] connectivity: (p2p-dev-wlp2s0,IPv6,796) start fake request (fake result)
Mar 22 11:54:29 mypc NetworkManager[38354]: <debug> [1584903269.9635] connectivity: (p2p-dev-wlp2s0,IPv4,795) check completed: FAKE; fake result
Mar 22 11:54:29 mypc NetworkManager[38354]: <debug> [1584903269.9635] connectivity: (p2p-dev-wlp2s0,IPv6,796) check completed: FAKE; fake result
Mar 22 11:54:39 mypc NetworkManager[38354]: <debug> [1584903279.3221] connectivity: (wlp2s0,IPv6,797) skip connectivity check due to no IP address configured
Mar 22 11:54:39 mypc NetworkManager[38354]: <debug> [1584903279.3222] connectivity: (wlp2s0,IPv6,797) check completed: NONE; no IP address configured
Mar 22 11:55:02 mypc NetworkManager[38354]: <debug> [1584903302.4864] connectivity: (wlp2s0,IPv4,798) start request to 'http://www.archlinux.org/check_network_status.txt' (systemd-resolved not available)
Mar 22 11:55:02 mypc NetworkManager[38354]: <debug> [1584903302.5211] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scanning requested but not allowed at this time
Mar 22 11:55:02 mypc NetworkManager[38354]: <debug> [1584903302.5211] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scheduled in 43 seconds (interval now 43 seconds)
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6902] connectivity: (wlp2s0,IPv4,798) check completed: LIMITED; check failed: (6) Couldn't resolve host name
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6903] device[93c8ab0ff27d061d] (wlp2s0): connectivity state changed from FULL to LIMITED
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6905] manager: connectivity checking indicates LIMITED
Mar 22 11:55:05 mypc NetworkManager[38354]: <info>  [1584903305.6906] manager: NetworkManager state is now CONNECTED_SITE
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6909] dispatcher: (25) dispatching action 'connectivity-change'
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6913] device[93c8ab0ff27d061d] (wlp2s0): ip4-config: update (commit=1, new-config=0x5641b0cbf760)
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6914] platform: (wlp2s0) address: adding or updating IPv4 address: 192.168.1.148/24 lft 69268sec pref 69268sec lifetime 51847-0[69268,69268] dev 2 flags noprefixroute src unknown
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6916] platform: (wlp2s0) signal: address 4 changed: 192.168.1.148/24 lft 69268sec pref 69268sec lifetime 51847-51846[69269,69269] dev 2 flags noprefixroute src kernel
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6916] device[93c8ab0ff27d061d] (wlp2s0): queued IP4 config change
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6917] platform-linux: do-add-ip4-address[2: 192.168.1.148/24]: success
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6917] platform: (wlp2s0) route: append     IPv4 route: 0.0.0.0/0 via 192.168.1.1 dev 2 metric 20600 mss 0 rt-src dhcp
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6918] platform: (wlp2s0) signal: route   4   added: 0.0.0.0/0 via 192.168.1.1 dev 2 metric 20600 mss 0 rt-src rt-dhcp scope global
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6919] platform-linux: do-add-ip4-route[0.0.0.0/0 via 192.168.1.1 dev 2 metric 20600 mss 0 rt-src rt-dhcp scope global]: success
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6919] platform: (wlp2s0) ip4-route: delete 0.0.0.0/0 via 192.168.1.1 dev 2 metric 600 mss 0 rt-src rt-dhcp scope global
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6920] platform: (wlp2s0) signal: route   4 removed: 0.0.0.0/0 via 192.168.1.1 dev 2 metric 600 mss 0 rt-src rt-dhcp scope global
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6920] platform-linux: do-delete-ip4-route[0.0.0.0/0 via 192.168.1.1 dev 2 metric 600 mss 0 rt-src rt-dhcp scope global]: success
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6924] device[93c8ab0ff27d061d] (wlp2s0): ip4-config: update IP Config instance (/org/freedesktop/NetworkManager/IP4Config/3)
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6924] dns-mgr: (device_ip_config_changed): queueing DNS updates (1)
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6925] dns-mgr: (device_ip_config_changed): DNS configuration did not change
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6925] dns-mgr: (device_ip_config_changed): no DNS changes to commit (0)
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6926] connectivity: (wlp2s0,IPv4,799) start request to 'http://www.archlinux.org/check_network_status.txt' (systemd-resolved not available)
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.6969] device[93c8ab0ff27d061d] (wlp2s0): ip4-config: update (commit=0, new-config=0x5641b0cbf760)
Mar 22 11:55:05 mypc NetworkManager[38354]: <debug> [1584903305.7217] dispatcher: (25) succeeded but no scripts invoked
Mar 22 11:55:06 mypc NetworkManager[38354]: <debug> [1584903306.6903] connectivity: (wlp2s0,IPv4,800) start request to 'http://www.archlinux.org/check_network_status.txt' (systemd-resolved not available)
Mar 22 11:55:08 mypc NetworkManager[38354]: <debug> [1584903308.6912] connectivity: (wlp2s0,IPv4,801) start request to 'http://www.archlinux.org/check_network_status.txt' (systemd-resolved not available)
Mar 22 11:55:11 mypc NetworkManager[38354]: <debug> [1584903311.7706] connectivity: (wlp2s0,IPv4,799) check completed: LIMITED; check failed: (6) Couldn't resolve host name
Mar 22 11:55:11 mypc NetworkManager[38354]: <debug> [1584903311.7709] connectivity: (wlp2s0,IPv4,800) check completed: LIMITED; check failed: (6) Couldn't resolve host name
Mar 22 11:55:11 mypc NetworkManager[38354]: <debug> [1584903311.7711] connectivity: (wlp2s0,IPv4,801) check completed: LIMITED; check failed: (6) Couldn't resolve host name
Mar 22 11:55:12 mypc NetworkManager[38354]: <debug> [1584903312.6914] connectivity: (wlp2s0,IPv4,802) start request to 'http://www.archlinux.org/check_network_status.txt' (systemd-resolved not available)
Mar 22 11:55:16 mypc NetworkManager[38354]: <debug> [1584903316.6898] connectivity: (wlp2s0,IPv4,803) start request to 'http://www.archlinux.org/check_network_status.txt' (systemd-resolved not available)
Mar 22 11:55:17 mypc NetworkManager[38354]: <debug> [1584903317.8506] connectivity: (wlp2s0,IPv4,802) check completed: LIMITED; check failed: (6) Couldn't resolve host name
Mar 22 11:55:20 mypc NetworkManager[38354]: <debug> [1584903320.8904] connectivity: (wlp2s0,IPv4,803) check completed: LIMITED; check failed: (6) Couldn't resolve host name
Mar 22 11:55:24 mypc NetworkManager[38354]: <debug> [1584903324.6929] connectivity: (wlp2s0,IPv4,804) start request to 'http://www.archlinux.org/check_network_status.txt' (systemd-resolved not available)
Mar 22 11:55:30 mypc NetworkManager[38354]: <debug> [1584903330.0106] connectivity: (wlp2s0,IPv4,804) check completed: LIMITED; check failed: (6) Couldn't resolve host name
Mar 22 11:55:40 mypc NetworkManager[38354]: <debug> [1584903340.6907] connectivity: (wlp2s0,IPv4,805) start request to 'http://www.archlinux.org/check_network_status.txt' (systemd-resolved not available)
Mar 22 11:55:45 mypc NetworkManager[38354]: <debug> [1584903345.2103] connectivity: (wlp2s0,IPv4,805) check completed: LIMITED; check failed: (6) Couldn't resolve host name
Mar 22 11:55:45 mypc NetworkManager[38354]: <debug> [1584903345.5209] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scanning requested but not allowed at this time
Mar 22 11:55:45 mypc NetworkManager[38354]: <debug> [1584903345.5210] device[93c8ab0ff27d061d] (wlp2s0): wifi-scan: scheduled in 43 seconds (interval now 43 seconds)

Try this for your home connection:

If there is more than one AP in your vicinity (or you have a dual-band AP with a single SSID) this can result in dropped connections.

Your connection can be lost because of constant scanning by Network Manager, and confusion over which AP to connect with.

To eliminate this possibility you can lock your WiFi connection profile to the BSSID of your favored access point in Network Manager.

You can do this in Network Manager's "Wi-Fi" tab in your connection's properties settings.

There is a "BSSID" drop down field where you can select and lock your Wi-Fi to a single BSSID.

Assigning a fixed channel in your router may also help with this problem. Try to select a channel with the least interference.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by