[Solved] Atheros QCA9377 lost wifi connectivity after updating Manjaro today (10/26/18)

This post could be called: I update Manjaro and this happens LOL OMG!!!

I have certainly updated Manjaro and I have lost wifi connectivity, there is no network list. If I execute:

$ ip link show wlan0

This returns me:

Device "wlan0" does not exist

But if I execute:

inxi -Fxz

In the section of Network it appears:


Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lenovo
driver: ath10k_pci v: kernel port: 3040 bus ID: 02:00.0

Device-2: Qualcomm Atheros type: USB driver btusb bus ID: 1-7:4

As you can see, I do not have a network port, it is not that it is not recognized, it does not exist in my laptop, so I do not have an Internet connection.

Can I downgrade? Can I activate wifi using the terminal? Or do I have to re-install Manjaro?

As always try to figure out which packages got updated. Best look at /var/log/pacman.log.

Then try v18.0-rc4 ISO to see if you have internet connection with that release.

You can always use the install media you used for installation of Manjaro and try a chroot for fixing your issue.

Also try the fallback mode of the kernel or try to boot a different kernel.

Solved, I installed the previous version of linux-firmware from the pacman cache

3 Likes

Glad you found the solution. I was just posting a bunch of info for you, but luckily now you won't need it.

My suggestion to you would be to get a backup regimen in place, so a minor issue like this doesn't result in you resorting to a reinstall.

Thanks, I have another question now: When could I update linux-firmware? There isn't any other solution to keep WiFi connection? Can I have WiFi in an updated system?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by