[SOLVED] Atheros QCA9377 - wifi speed very slow

Hello to everyone
I noticed that the download speed of wifi in linux manjaro is quite slow
for instance i can download up to 2mb with my phone but here it's below 100kb
Please if someone can help, i'd appreciate

System:    Host: mtn-lap Kernel: 5.5.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.1 
           Desktop: KDE Plasma 5.17.5 tk: Qt 5.14.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 81DE v: Lenovo ideapad 330-15IKB serial: <filter> Chassis: 
           type: 10 v: Lenovo ideapad 330-15IKB serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <filter> UEFI: LENOVO v: 8TCN53WW date: 05/17/2019 
Battery:   ID-1: BAT0 charge: 24.5 Wh condition: 27.8/30.0 Wh (93%) volts: 8.2/7.6 model: LGC L17L2PF1 
           type: Li-poly serial: <filter> status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake rev: A 
           L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 32012 
           Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 
           7: 800 8: 800 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:5917 
           Device-2: NVIDIA GP108M [GeForce MX150] vendor: Lenovo driver: N/A bus ID: 01:00.0 chip ID: 10de:1d10 
           Display: x11 server: X.Org 1.20.7 driver: modesetting compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.6 Mesa 19.3.4 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.5.7-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 
           v: kernel port: 3000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lenovo 
           driver: ath10k_pci v: kernel port: 3000 bus ID: 03:00.0 chip ID: 168c:0042 
           IF: wlp3s0 state: up mac: <filter> 
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-7:3 chip ID: 0cf3:e500 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
           IF-ID-2: tun1 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 1.82 TiB used: 123.61 GiB (6.6%) 
           ID-1: /dev/sda vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: <filter> rev: LDM2 scheme: GPT 
Partition: ID-1: / size: 1.77 TiB used: 123.61 GiB (6.8%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 17.11 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 56.5 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 260 Uptime: 8h 45m Memory: 15.55 GiB used: 4.20 GiB (27.0%) Init: systemd v: 242 
           Compilers: gcc: 9.2.1 clang: 9.0.1 Shell: bash v: 5.0.16 running in: konsole inxi: 3.0.37


Also see if other things are relevant for you from forum search

1 Like

My kernel is 5.5

It's hard to say, but I'd start by testing every kernel from 4.19 and above including the real time kernels.

I would also be sure your bios is up to date and also disable IPv6.

Thank you
Then there're two things
How to make sure my bios is up to date?
And how to disable IPv6?

Bios: Obtain Motherboard Make and Model number - go to 'Make' website, select 'model number', check latest Bios release version against your Motherboard. If higher download and install.
IPV6 disable in Network settings. Select IPV6 and set to Ignore from dropdown list.


You could also try this:

Add the following kernel boot parameters to grub:

ipv6.disable=1 pcie_aspm=off net.ifnames=0

The following command will automatically add the above kernel boot parameter to /etc/default/grub:

sudo cp /etc/default/grub /etc/default/grub.bak && sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ ipv6.disable=1 pcie_aspm=off net.ifnames=0"/g' -i /etc/default/grub

After adding the boot parameter(s) and saving your changes, run:

sudo update-grub 

Reboot, and test for improvement.

*sed magic courtesy of @dalto

These chamges can be helpful even if they don't appear to resolve your issue.

I would reccommend leaving the changes in place, but you can easily restore the file to its original state with:

sudo cp /etc/default/grub.bak /etc/default/grub

After restoring the file, again run:

sudo update-grub 

Then reboot.


heyyy that worked
i disabled IPv6 and now it's much more better
thanks everyone for helping:)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by