[SOLVED] [BCM4360] - Broadcom WiFi not detected on 2015 Macbook Pro 12,1 (Linux419-rt)

Edit: Didn't find a solution to this, but installing Manjaro without a realtime driver solved the problem :smiley:

Hi, I am having a problem with Wifi on my new install of Manjaro on my early 2015 Macbook Pro. (A1502 EMC 2835, a 13" retina model) Previously I had Antergos installed and the wifi worked fine on that, but I switched to Manjaro because I heard Antergos was being discontinued.

iwconfig shows this:

lo        no wireless extensions.

enp0s20u1u4  no wireless extensions.

The second one is the usb ethernet adaptor I bought to be able to connect to the internet, but obviously I don't want to need an ethernet port or android tether to use internet on a laptop.

journalctl | grep brcmfmac shows these messages, I think every time the OS tries to start up the BCM43602. Please excuse the fact that my computer is called imgay, it's an in joke (I'm a lesbian).

Oct 06 21:02:06 imgay kernel: usbcore: registered new interface driver brcmfmac
Oct 06 21:02:06 imgay kernel: brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43602-pcie for chip BCM43602/1
Oct 06 21:02:06 imgay kernel: brcmfmac 0000:03:00.0: Direct firmware load for brcm/brcmfmac43602-pcie.Apple Inc.-MacBookPro12,1.txt failed with error -2
Oct 06 21:02:06 imgay kernel: brcmfmac 0000:03:00.0: Direct firmware load for brcm/brcmfmac43602-pcie.txt failed with error -2
Oct 06 21:02:07 imgay kernel:  brcmf_fw_complete_request+0x3e9/0xa10 [brcmfmac]
Oct 06 21:02:07 imgay kernel:  brcmf_fw_request_done+0x3d/0xe0 [brcmfmac]
Oct 06 21:02:07 imgay kernel: Modules linked in: brcmfmac brcmutil mmc_core isofs cdc_ether usbnet r8152 mii input_leds bnep hid_apple joydev mousedev hid_generic btusb btrtl btbcm btintel bluetooth ecdh_generic usbhid ecc bcm5974 hid uas usb_storage fuse nf_tables_set nft_fib_inet nft_fib_ipv4 nft_fib_ipv6 nft_fib nft_reject_inet nf_reject_ipv4 nf_reject_ipv6 nft_reject nft_ct nft_chain_nat nf_tables nfnetlink ip6table_nat ip6table_mangle ip6table_raw ip6table_security iptable_nat nf_nat iptable_mangle iptable_raw iptable_security nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c ip6table_filter ip6_tables iptable_filter 8021q garp mrp stp llc nls_iso8859_1 nls_cp437 vfat fat intel_rapl ofpart cmdlinepart intel_spi_platform x86_pkg_temp_thermal mei_hdcp intel_spi intel_powerclamp spi_nor mtd iTCO_wdt coretemp iTCO_vendor_support kvm_intel kvm irqbypass crct10dif_pclmul snd_hda_codec_hdmi crc32_pclmul ghash_clmulni_intel aesni_intel aes_x86_64 crypto_simd cryptd glue_helper applesmc input_polldev

Another possibly relevant thing, if I do sudo modprobe brcm80211 it says this:

modprobe: FATAL: Module brcm80211 not found in directory /lib/modules/4.19.59-rt23-MANJARO

I don't know where to get the module or if that would even fix the problem.

Things I have tried:
I downgraded kernel from linux52-rt to linux419-rt to see if those drivers would work, but the same errors occur. Should I move back to linux52-rt? I'm using the rt kernels because I want to do low-latency audio stuff, should I try a non rt kernel?
I've tried installing broadcom-wl, broadcom-wl DKMS version, but those didn't work.
I've checked the Arch Wiki entry on Mac, but the issues mentioned there didn't apply for me.
I've checked lots of forums where people have similar problems, but the posts I've read about similar issues with wifi not working on linux macbooks seem to have different root causes.

Also, for some reason the macbook has a looot of lag when booting up. In the macOS recovery screen for example, the planet "spins" smoothly, but the input lags and only intermittently moves the cursor or registers keyboard input. This happens in grub as well, it happens right up until I've successfully logged into manjaro. This topic isn't for advice about how to fix that, I only added the info because I thought it could possibly be relevant.

I would appreciate any guidance on how to fix this issue :slight_smile:

Did you install the correct kernel headers with the dkms driver version?

If you must have a real time kernel, then I would use the newest RT kernel.

sudo mhwd-kernel -i linux52-rt

To install the real time linux-headers version:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

The above command (courtesy of @dalto) will install the correct linux headers for each installed kernel on your system.

Restart after installing kernels and headers.

Then install the broadcom-wl-dkms driver from the AUR with whichever AUR helper you prefer.


If you can't get your broadcom Wifi adapter working on the real time kernels then I guess you'll have to try the regular kernels. Install kernel 5.2 first, then try kernel 5.3 (if 5.2 does not work for you).

You can follow my Broadcom driver install guide here:

If you can't get your Wifi working after following those directions please post:

lsmod | sort
rfkill list
hwinfo --netcard --bluetooth | grep -Ei "(speed|hotplug|model|status|cmd|file|detected|driver:)" | grep -v "Config S"
1 Like

Edit: Oops! just read ur edit. I'll try those things then post another reply :slight_smile:
I wasn't sure if I had the kernel headers installed (that's linux419-rt-headers right?) so I tried installing the DKMS version again and rebooting, but it didn't work.

lsmod | sort:

8021q                  40960  0
ac                     16384  0
acpi_als               16384  0
acpi_call              16384  0
aesni_intel           200704  0
aes_x86_64             20480  1 aesni_intel
agpgart                49152  2 intel_gtt,drm
ahci                   40960  3
apple_bl               16384  0
applesmc               24576  0
bcm5974                20480  0
bluetooth             659456  26 btrtl,btintel,btbcm,bnep,btusb
bnep                   24576  2
btbcm                  16384  1 btusb
btintel                24576  1 btusb
btrtl                  16384  1 btusb
btusb                  53248  0
cdc_ether              16384  0
cfg80211              790528  1 wl
cmdlinepart            16384  0
coretemp               16384  0
crc16                  16384  2 bluetooth,ext4
crc32c_generic         16384  0
crc32c_intel           24576  3
crc32_pclmul           16384  0
crct10dif_pclmul       16384  0
cryptd                 28672  3 crypto_simd,ghash_clmulni_intel,aesni_intel
crypto_simd            16384  1 aesni_intel
crypto_user            16384  0
drm                   499712  4 drm_kms_helper,i915
drm_kms_helper        208896  1 i915
ecdh_generic           24576  1 bluetooth
evdev                  20480  15
ext4                  749568  1
facetimehd             98304  0
fat                    86016  1 vfat
fb_sys_fops            16384  1 drm_kms_helper
fscrypto               32768  1 ext4
fuse                  122880  3
garp                   16384  1 8021q
ghash_clmulni_intel    16384  0
glue_helper            16384  1 aesni_intel
hid                   135168  3 usbhid,hid_apple,hid_generic
hid_apple              16384  0
hid_generic            16384  0
i2c_algo_bit           16384  1 i915
i2c_i801               32768  0
i915                 2007040  3
industrialio           81920  2 acpi_als,kfifo_buf
input_leds             16384  0
input_polldev          16384  1 applesmc
intel_cstate           16384  0
intel_gtt              24576  1 i915
intel_pch_thermal      16384  0
intel_powerclamp       16384  0
intel_rapl             24576  0
intel_rapl_perf        16384  0
intel_spi              20480  1 intel_spi_platform
intel_spi_platform     16384  0
intel_uncore          139264  0
ip6table_filter        16384  0
ip6table_mangle        16384  0
ip6table_nat           16384  0
ip6table_raw           16384  0
ip6_tables             32768  5 ip6table_filter,ip6table_raw,ip6table_nat,ip6table_mangle,ip6table_security
ip6table_security      16384  0
iptable_filter         16384  0
iptable_mangle         16384  0
iptable_nat            16384  0
iptable_raw            16384  0
ip_tables              28672  5 iptable_filter,iptable_security,iptable_raw,iptable_nat,iptable_mangle
iptable_security       16384  0
irqbypass              16384  1 kvm
iTCO_vendor_support    16384  1 iTCO_wdt
iTCO_wdt               16384  0
jbd2                  126976  1 ext4
joydev                 24576  0
kfifo_buf              16384  1 acpi_als
kvm                   741376  2 kvmgt,kvm_intel
kvmgt                  28672  0
kvm_intel             245760  0
libahci                40960  1 ahci
libata                270336  2 libahci,ahci
libcrc32c              16384  2 nf_conntrack,nf_nat
llc                    16384  2 stp,garp
lpc_ich                28672  0
mac_hid                16384  0
mbcache                16384  1 ext4
mdev                   20480  2 kvmgt,vfio_mdev
media                  45056  1 videodev
mei                   114688  1 mei_me
mei_me                 49152  0
mii                    16384  2 usbnet,r8152
Module                  Size  Used by
mousedev               24576  1
mrp                    20480  1 8021q
msr                    16384  0
mtd                    69632  5 cmdlinepart,intel_spi,ofpart
nf_conntrack          217088  4 nf_nat,nft_ct,nf_nat_ipv6,nf_nat_ipv4
nf_defrag_ipv4         16384  1 nf_conntrack
nf_defrag_ipv6         20480  1 nf_conntrack
nf_nat                 81920  2 nf_nat_ipv6,nf_nat_ipv4
nf_nat_ipv4            16384  2 nft_chain_nat_ipv4,iptable_nat
nf_nat_ipv6            16384  2 ip6table_nat,nft_chain_nat_ipv6
nfnetlink              16384  1 nf_tables
nf_reject_ipv4         16384  1 nft_reject_inet
nf_reject_ipv6         16384  1 nft_reject_inet
nf_tables             139264  180 nft_ct,nft_chain_nat_ipv6,nft_chain_nat_ipv4,nft_reject_inet,nft_fib_ipv6,nft_fib_ipv4,nf_tables_set,nft_reject,nft_fib,nft_fib_inet
nf_tables_set          36864  5
nft_chain_nat_ipv4     16384  2
nft_chain_nat_ipv6     16384  2
nft_ct                 20480  8
nft_fib                16384  3 nft_fib_ipv6,nft_fib_ipv4,nft_fib_inet
nft_fib_inet           16384  1
nft_fib_ipv4           16384  1 nft_fib_inet
nft_fib_ipv6           16384  1 nft_fib_inet
nft_reject             16384  1 nft_reject_inet
nft_reject_inet        16384  4
nls_cp437              20480  1
nls_iso8859_1          16384  1
ofpart                 16384  0
pcbc                   16384  0
pcc_cpufreq            16384  0
pcspkr                 16384  0
r8152                  69632  0
rfkill                 28672  4 bluetooth,cfg80211
sbs                    20480  0
sbshc                  16384  1 sbs
scsi_mod              249856  2 sd_mod,libata
sd_mod                 61440  4
snd                    98304  15 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_pcm
snd_hda_codec         151552  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_cirrus
snd_hda_codec_cirrus    20480  1
snd_hda_codec_generic    86016  1 snd_hda_codec_cirrus
snd_hda_codec_hdmi     57344  1
snd_hda_core           94208  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_cirrus
snd_hda_intel          45056  4
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               131072  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer              36864  1 snd_pcm
soundcore              16384  1 snd
spi_nor                36864  1 intel_spi
spi_pxa2xx_pci         16384  0
spi_pxa2xx_platform    28672  0
stp                    16384  1 garp
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
thunderbolt           151552  0
usbhid                 57344  0
usbnet                 49152  1 cdc_ether
vfat                   20480  1
vfio                   32768  3 kvmgt,vfio_mdev,vfio_iommu_type1
vfio_iommu_type1       28672  0
vfio_mdev              16384  0
videobuf2_common       53248  2 videobuf2_v4l2,facetimehd
videobuf2_dma_sg       16384  1 facetimehd
videobuf2_memops       16384  1 videobuf2_dma_sg
videobuf2_v4l2         28672  1 facetimehd
videodev              217088  3 videobuf2_v4l2,facetimehd,videobuf2_common
wl                   6463488  0
xhci_hcd              266240  1 xhci_pci
xhci_pci               16384  0
x_tables               45056  10 ip6table_filter,ip6table_raw,iptable_filter,iptable_security,ip6_tables,iptable_raw,ip_tables,ip6table_mangle,ip6table_security,iptable_mangle

rfkill list

0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

hwinfo "" ""

~ >>> hwinfo --netcard --bluetooth | grep -Ei "(speed|hotplug|model|status|cmd|file|detected|driver:)" | grep -v "Config S"                                                                                                            
  Model: "Broadcom BCM43602 802.11ac Wireless LAN SoC"
    Driver Status: brcmfmac is not active
    Driver Activation Cmd: "modprobe brcmfmac"
    Driver Status: wl is active
    Driver Activation Cmd: "modprobe wl"
  Model: "Realtek RTL8152 Fast Ethernet Adapter"
  Hotplug: USB
  Driver: "r8152"
  Device File: enp0s20u1u4
  Speed: 480 Mbps
  Link detected: yes
    Driver Status: r8152 is active
    Driver Activation Cmd: "modprobe r8152"

See my edit above.

Please do not perform any troubleshooting commands with your USB ethernet inserted. Remove it and reboot before running any diagnostic commands.

Please post:

inxi -Fxxxz
lspci -knnvvv | grep -i net
journalctl -b -1 --no-pager | grep wl
grep -r "blacklist\|install\|options"  /etc/modprobe.d/ /etc/modules-load.d/ /usr/lib/modprobe.d/ 
pacman -Qsq ^linux | grep ^linux | grep -viE 'api|firm|nvidia' && echo  Running Kernel $(uname -r)

Ok, I installed linux52 rt again. The mhwd-kernel command gave me this error for some reason:

:: Synchronizing package databases...
 core                     148.9 KiB   206K/s 00:01 [] 100%
 extra                   1886.9 KiB   875K/s 00:02 [] 100%
 community                  5.3 MiB  1480K/s 00:04 [] 100%
 multilib                 183.6 KiB  12.8M/s 00:00 [] 100%
error: no targets specified (use -h for help)

(I removed the loading bar cuz it was getting parsed as comments)
so I just installed linux52-rt using yay and removed 4.19 with mhwd-kernel -r linux419-rt. It seemed to work, I'm not familiar with mhwd-kernel and couldn't find any info on the error. Then I installed the headers with that command, restart, then broadcom-wl-dkms, unplugged ethernet, and restart.

Output of inxi:

System:    Host: imgay Kernel: 5.2.10-rt5-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: Openbox 3.6.1 info: tint2 
           dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Apple product: MacBookPro12,1 v: 1.0 serial: <filter> Chassis: type: 9 v: Mac-E43C1C25D4880AD6 
           serial: <filter> 
           Mobo: Apple model: Mac-E43C1C25D4880AD6 v: MacBookPro12,1 serial: <filter> UEFI: Apple 
           v: MBP121.88Z.0167.B17.1606231721 date: 06/23/2016 
Battery:   ID-1: BAT0 charge: 32.3 Wh condition: 65.9/74.8 Wh (88%) volts: 11.3/11.4 model: SMP bq20z451 type: Li-ion 
           serial: N/A status: Discharging cycles: 381 
CPU:       Topology: Dual Core model: Intel Core i5-5257U bits: 64 type: MT MCP arch: Broadwell rev: 4 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21611 
           Speed: 835 MHz min/max: 500/3100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
Graphics:  Device-1: Intel Iris Graphics 6100 vendor: Apple driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:162b 
           Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting alternate: fbdev,vesa 
           resolution: 2560x1600~60Hz 
           OpenGL: renderer: Mesa DRI Intel Iris 6100 (Broadwell GT3) v: 4.5 Mesa 19.1.5 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Broadwell-U Audio vendor: Apple driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:160c 
           Device-2: Intel Wildcat Point-LP High Definition Audio driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:9ca0 
           Device-3: Broadcom and subsidiaries 720p FaceTime HD Camera driver: facetimehd v: kernel bus ID: 02:00.0 
           chip ID: 14e4:1570 
           Sound Server: ALSA v: k5.2.10-rt5-MANJARO 
Network:   Device-1: Broadcom and subsidiaries BCM43602 802.11ac Wireless LAN SoC vendor: Apple driver: N/A port: efa0 
           bus ID: 03:00.0 chip ID: 14e4:43ba 
Drives:    Local Storage: total: 233.76 GiB used: 149.83 GiB (64.1%) 
           ID-1: /dev/sda vendor: Apple model: SSD SM0256G size: 233.76 GiB speed: 6.0 Gb/s serial: <filter> rev: SA0Q 
           scheme: GPT 
Partition: ID-1: / size: 220.47 GiB used: 149.83 GiB (68.0%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 8.26 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 64.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 210 Uptime: N/A Memory: 7.69 GiB used: 446.6 MiB (5.7%) Init: systemd v: 242 Compilers: gcc: 9.1.0 
           Shell: zsh v: 5.7.1 running in: termite inxi: 3.0.36 

output of lspci:

03:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM43602 802.11ac Wireless LAN SoC [14e4:43ba] (rev 01)

output of journalctl:

Oct 07 03:43:08 imgay kernel: wl: module license 'MIXED/Proprietary' taints kernel.
Oct 07 03:43:08 imgay kernel: wl driver (r587334) failed with code 1
Oct 07 03:43:08 imgay kernel: ERROR @wl_cfg80211_detach : 
Oct 07 03:43:08 imgay kernel: NULL ndev->ieee80211ptr, unable to deref wl

output of grep on /etc/modprobe.d/:

/etc/modprobe.d/bcwc-pcie.conf:blacklist bdc_pci

(the grep on /etc/modules-load.d/ gave no output)
output of grep on /usr/lib/modprobe.d/:

/usr/lib/modprobe.d/nvdimm-security.conf:install libnvdimm /usr/bin/ndctl load-keys ; /sbin/modprobe --ignore-install libnvdimm $CMDLINE_OPTS
/usr/lib/modprobe.d/broadcom-wl-dkms.conf:blacklist b43
/usr/lib/modprobe.d/broadcom-wl-dkms.conf:blacklist b43legacy
/usr/lib/modprobe.d/broadcom-wl-dkms.conf:blacklist ssb
/usr/lib/modprobe.d/broadcom-wl-dkms.conf:blacklist bcm43xx
/usr/lib/modprobe.d/broadcom-wl-dkms.conf:blacklist brcm80211
/usr/lib/modprobe.d/broadcom-wl-dkms.conf:blacklist brcmfmac
/usr/lib/modprobe.d/broadcom-wl-dkms.conf:blacklist brcmsmac
/usr/lib/modprobe.d/broadcom-wl-dkms.conf:blacklist bcma
/usr/lib/modprobe.d/uvesafb.conf:# options uvesafb mode=<xres>x<yres>[-<bpp>][@<refresh>] scroll=<ywrap|ypan|redraw> ...
/usr/lib/modprobe.d/uvesafb.conf:options uvesafb mode_option=1024x768-32 scroll=ywrap
/usr/lib/modprobe.d/bluetooth-usb.conf:options btusb reset=1
/usr/lib/modprobe.d/systemd.conf:options bonding max_bonds=0
/usr/lib/modprobe.d/systemd.conf:options dummy numdummies=0

The final command didn't seem to work, it just listed all the directories in my home folder like this:

~ >>> pacman -Qsq ^linux | grep ^linux | grep -viE 'api|firm|nvidia' && echo  Running Kernel 5.2.10-rt5-MANJARO                                                                                                                            [1]
grep: broadcom: Is a directory
grep: CIRCUITSIM: Is a directory
grep: data: Is a directory
grep: Desktop: Is a directory
grep: development: Is a directory

It continues like that with every non-hidden folder in my home directory, so I deleted the rest of the output cos I didn't really wanna post all my folder names. The reason the Kernel name is there instead of the command is because I piped the output to a file so I could store it while the internet wasn't connected, but the same output happened when I didn't pipe it.

Thanks for the support!

Run this command then reboot:

echo 'blacklist facetimehd' | sudo tee /etc/modprobe.d/facetimehd-blacklist.conf
1 Like

Apple hardware is tailored for macOS and vice versa.

It seems it is generally hard to get the hardware functional on recent macbooks.

Quote from above github repo on Wi-Fi support for BCM43602

The MacBook Pro models with Touch Bar come with a Broadcom Limited BCM43602 802.11ac Wireless LAN SoC (rev 02) which is also supported by brcmfmac , but has several issues rendering it unusable, caused by the available firmware. The issues are caused by failing country detection and are:

  • Only 2.4Ghz APs are shown
  • Connecting to an AP barely works or fails directly

According to Broadcom releasing a fixed firmware would require verification to ensure that it complies with regulatory limits, which is very unlikely to happen as it wouldn't provide enough return on investment for them (see https://bugzilla.kernel.org/show_bug.cgi?id=193121 for details).


Run this command then reboot:

echo 'blacklist facetimehd' | sudo tee /etc/modprobe.d/facetimehd-blacklist.conf
1 Like

It's still not detecting the adaptor in iwconfig/ifconfig/NetworkManager. The outputs are the same :confused:

Apple hardware is tailored for macOS and vice versa.

I know this, but I got this from a friend for a very cheap price and I'm unable to afford a different laptop in the near future. Also my macbook is an early 2015 model not 2016 or 2017.

The camera driver apparently can conflict with the wl driver. Blacklist the facetimehd module, it can be modprobed after startup if needed.

Run this command then reboot:

echo 'blacklist facetimehd' | sudo tee /etc/modprobe.d/facetimehd-blacklist.conf

Run this command if your Wifi has not started up after rebooting:

nmcli networking off; sudo systemctl stop NetworkManager; sleep 1; sudo modprobe -r wl; sleep 3; sudo modprobe wl; sleep 1; sudo systemctl start NetworkManager; sleep 1; nmcli networking on; sleep 1; nmcli r wifi off; sleep 1; nmcli r wifi on

If blacklisting the facetimehd module did not improve things then I would move onto the normal kernels and follow my full installation guide that I posted the link for. Leave the module blacklisted until after you have tested the regular kernels.

Personally, I would wipe your install and do fresh install as you've made so many changes that you may never figure out how to get this working. I know that bcm4360 was working on kernel 5.2 only a couple of weeks ago. Follow my install guide with kernel 5.2 as that is your best chance of getting things working.

Do the blacklist again if your Wifi is not working on the regular kernels.

Sorry, but I'm about done for today.

Good luck.

1 Like

And you know you can reinstall the macOS for your hardware - quite easy using Apple servers? Unless you like the challenge getting Linux to work - it may be more feasible to run with macOS - at least everything will work.

Just on a very off chance you might want to give this a try:

sudo systemctl mask tlp.service
sudo systemctl mask tlp-sleep.service

Reboot after those changes.

1 Like

There are hacks for the firmware, but they are a little complicated.

1 Like

I have been tempted - more than once to load Manjaro on my macBookPro (2017).

But it seems a like a windmill fight :slight_smile:

Ya I've saved notes on how to hack the 4360 firmware, but it is no small deed.

Thanks a metric tonne for your help + information, I couldn't get it to work but you've still saved me a lot of headaches and helped me learn more about manjaro and linux in general.

I'm going to reinstall and try a non realtime kernel. If that doesn't work, I'll probably reinstall Mac OS and sell it to help fund a better laptop. It's a pity because the hardware was great but personally I can't imagine using an operating system other than the linux setup I'm currently used to.

Edit: Installed again with regular linux52 drivers and it seems to be working flawlessly! :tada::tada: Very happy to have made the switch to Manjaro.


Wow, I just noticed your edit.

I'm so happy we can now mark this as solved. See persistence pays off. I kept insisting you try the regular kernel 5.2 because I knew it was reported working with this adapter very recently.

Awesome work, but if you want to save yourself a lot of headaches in the future don't buy broadcom. :smile: :+1:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by