[SOLVED] Black Screen after bootloader, both during installation and after

I am using xfce edition and installing it on X1 carbon 2016 with intel i7-6600U and integrated core graphic card.

When I boot from the USB disk and choose the "free" entry, my computer shows black screen after showing

:: running early hook [udev]
starting version 231
:: running hook [udev]
:: Triggering uevents ... 

for less than a second. I cannot switch to tty, and it gives no reaction for any keyboard button. But if I choose "nonfree" entry it boots as expected. But if I install the system after that and reboot, I still get a black screen after grub and a flash of Manjaro booting screen. No tty accessible either.

I tried to use a different USB drive and it went still. I also tried i3 and deepin edition of Manjora and met the same problem. The Arch distro works fine. However, the net edition of Manjora can boot successfully. I didn't try to really install the net edition because it didn't recognize my PCI-e hard drive (/dev/nvme0n1px).

Similar reports can be seen here, and someone pointed out in this post that it may possibly be the skylake driver (here).

Thank you for any suggestion!

When a system doesn't boot the only real way to diagnose the issue when tty is not available is to boot into a Manjaro Live environment.

Once successfully booted into a Live environment to properly diagnose an issue you need to change its working directories to your faulty system's directories. The command is chroot, but Manjaro has created a better tool called manjaro-chroot which does a few extra mappings on a Manjaro system.

So you can boot successfully into the Live boot environment using non free drivers?

If so, do so.

Now check which graphics driver is being using in Live environment

mhwd -li

To chroot from Live into a broken Manjaro system

  1. Work out which device is your system root partition. Use the output of lsblk command to work this out. It will be /dev/sda2, or something similar.

  2. You then need to mount this system root partition to a directory, for example /mnt, or any other directory name you wish. Make sure the /mnt directory exists, if not create it using mkdir. Then use the mount command sudo mount /dev/sda2 /mnt.

  3. Once your system root partition has been successfully mounted you can use manjaro-chroot to change the root directory of your live environment to that of your mounted system root partition, using sudo manjaro-chroot /mnt.

Once you have chrooted into your non booting system, all the commands you execute are applied to this system, not your Live environment.

Check the journal logs for errors from boot cycle that failed

journalctl -p err -b [-n]

where [-n] is an optional parameter to go back n boot cycles.

If the error is graphics driver related, check the graphics driver being used on your non booting system and compare it to the one used to successfully boot into Live

If they are different then remove the currently installed one, and install the one being used in Live. This should at least get you booting again.

sudo mhwd -r pci [name of old driver]
sudo mhwd -i pci [name of new driver]
1 Like

Thank you very much for your detailed instructions!
Let me try to see what's difference for intel graphic drive under non-free and free version.

One of the problem here is that the free live environment doesn't work well either.

Try bootin or switching to TTY and then install mhwd-tui, then run it and try to set up your graphics driver with it - the easy way.

I mentioned that tty is not available... I guess the boot process is not done when it turns to black screen.

1 Like

I tried it again and this time weird thing happened: I was no longer to boot into the live environment by choosing non-free entry. It went into black screen just as free entry...

What Live environment are you using?

Maybe try the new Beta Live ISO, which uses kernel 4.9 by default along with the latest video drivers.


Thank you. I used official stable version. I'll try it.

I am sorry for the delay. I finally got a chance to have a try. The beta version works fine.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by