[Solved]Blank dark screen

I suggest you ask in the forum that was last update posted, maybe someone can help there, I'm too green to help, sorry:

Actually, just to be on a safe side, I would first run these two commands:

sudo pacman -Sy manjaro-keyring
sudo pacman -S manjaro-system

This member seems to had the same problem? Look at his post how he fixed it:


i restored a backup and could update via terminal without any problems.

yet i wonder why the first attempt via gui rendered my system to a complete unresponsive state after installing the 2 manjaro packages?

now here is another little issue: pacman-mirros is now marked an orphaned package. when i try to uninstall it, it fails due to being locked. any ideas?

am i have to download manjaro iso for chroot or arch linux iso also can chroot it ?
and after get live usb what i should do ?

You didn't answer to my previous question, can you log into tty? Because if you can, you probably don't need to do chroot which is a little more advanced.

So first try to log to tty. If this fails, then you can go to next step - chroot which means you will use live USB/DVD to chroot (change root) into your system from outside.

Bellow I will post a link for steps to follow, but simple explanation what chroot is, when you boot your computer from live USB or DVD you are then inside live system, you are not inside your broken system. So, next step is, to access into your broken system from the live system. There are few steps involved though.

You asked if you need Manjaro live usb or Ubuntu will do? You can use any live USB/DVD but Manjaro live USB/DVD will save you few steps, will make chrooting a little simpler.

So what you will do next is this:

A - Easier way:
1 - log to tty
2 - update your system from there

if you can't log into tty, then you will need to do it harder way, but you need to learn it anyway:

B - Chrooting:
1 - chroot your system using steps in the link bellow
2 - update your system from there

Steps to follow:

Those steps above I followed once and they are working. There is some change happened since then, that I'm not sure exactly about. As far as I know if you follow those steps exactly, you should be fine. So just ignore what I will wrote bellow, to not confuse you, it is just some clarification question for others:

@...other experts...

Can any of experts explain exactly which step is now changed and preferred to use when chrooting? Something about instead of using "mhwd-chroot" to rather use "manjaro-chroot" which on it's own is simple enough, but then I have conflicting notes about -a flag. Which of these should be used?

manjaro-chroot /mnt
manjaro-chroot -a
manjaro-chroot -a /mnt

Can anyone with forum admin rights change the tutorial I linked above to reflect latest preferred way of chrooting?


hey hello the thing is that i can not enter tty and i have only arch linux live usb. I am living in dormitory and manjaro iso will be downloaded 14 hours later. So i need to chroot with arch linux live usb but commands which you shared is not found in arch linux chroot

Hi. Try to use arch-chroot. Details see here
EDIT. Mount /boot partition before chroot, if you have it

OK, then I will give you link, where you have steps how to chroot into your system from any other live Linux. There are few extra steps involved that way. And if anything goes wrong, I will not be able to help beginner myself. Just a quick tip for the future, don't rush with updating the system. Wait a day, see what others have a problems, read update forum first to get idea what are possible problems you may experience.

And make backup of your whole dist with clonezilla. That way if something goes wrong you can easily reverse back.

Ouch, looks like I don't have link to where are exact steps written for this, if you search internet (I'm leaving now any second) with search words "linux chrooting into my system" or something similar you should get the link, I used Manjaro live usb, sorry.

I have this link, where is chrooting explained as part of bigger process and this should probably help:

Schrool down to the part: "3. Mount your Manjaro system partition."
First you need to find out on which partition is your broken manjaro installed, run and write down partition where is manjaro installed:

lsblk -f

Link, start at: (I think all you need is there)
3. Mount your Manjaro system partition. The syntax to mount the Manjaro system partition is:


@kainonergon already posted best link, great & thank you.

1 Like


if you have no boot medium you can still try this: from the black screen, repeatedly press Ctrl-Alt-F2. It may take 10 or 20 seconds until you finally see a console login screen. It may disappear soon, so you'll have to repeat.

See my posting in this other thread for details:

1 Like

I remember to have written
manjaro-chroot -a
will mount and chroot for you. But it cannot detect btrfs subvolumes or encrypted volumes.
Therefore you need to mount / partition in /mnt, UEFI partition on /mnt/boot/efi and then
manjaro-chroot /mnt.


I see, thank you!

As @bearman wrote, there are several who managed to finally get into tty if they tried many times, 15-20 times, so I would try this first, it would be easier solution for you if it would work

i chroot ed but i can not use pacman it says pacman not found. Shoul i install base package of arch ?

check if any partition is full
df - h

Maybe you can try to use simple chroot, not arch-chroot. Read archwiki how to do mount before chroot.

I am back up and running after creating a 16.10 iso on usb and mhwd-chroot into my system then running pacman -Syyu

I have gotten a few warnings from pacman during the upgrade:

  1. warning: directory permissions differ on /usr/share/doc/nfs-utils/
    filesystem: 644 package: 755

  2. warning: /etc/lightdm/lightdm.conf installed as /etc/lightdm/lightdm.conf.pacnew

  3. looking for conflicting packages...
    warning: dependency cycle detected:
    warning: mesa will be installed before its libglvnd dependency
    warning: dependency cycle detected:
    warning: lib32-libglvnd will be installed before its lib32-mesa dependency

  4. warning: could not get file information for run/openvpn-client/
    warning: could not get file information for run/openvpn-server/

1 Like

I had the exact same issue today. I installed only the manjaro-system, then I had to shut down my computer, because my battery was dead and had to move my laptop to another room. Once I tried to boot it, I had only a black screen with no backlight and blinking cursor and backlight on without cursor alternating every few seconds.
I could get to tty with ctrl+alt+f2 only for a fraction of a second then it switched back to black screen again.

The solution was to reboot and hit ctrl+alt+f2 while the Manjaro splash screen (with the dots blinking) were still visible. Then from the terminal doing a full upgrade with "sudo pacman -Syyu" solved all issues, now xfce is up and running.


guys finally i downloaded manjaro iso but know i can not update because i am getting importing key error.
it is something like that
error: key" XXXX" could not be imported

My Manjaro suffered the same result as the OP. Killed my system, I've attempted a reinstall from a Manjaro USB but the update kills off any joy with the black screen after a series of commit errors. My next try will be the latest version of Manjaro which includes this killer update.

Forum kindly sponsored by