[SOLVED] Blue screen / Red light filter - Fix

Hi, i wanted to share my fix that i found for this problem.

The problem is this ridicules blue light covering the entire screen and burning everyone's eyes as seen in the picture:
01

The solution i found is to change "Rendering backend" from OpenGL to XRender in System settings, under hardware category.

I hope it helps someone.

I've never seen that happen before, it must be a bug with the proprietary driver and RTX2080ti specifically. Are you attempting to use redshift and the blue screen is the result? Your post isn't 100% clear on how you ended up with this situation. Xrender is software rendering (CPU) rather than hardware (GPU) so yes it is a workaround of sorts.

Sorry, but this out of nowhere "solution" needs more context. Please provide some valid information as explained here:

It was out of nowhere problem, i have nothing to add, it just happened when doing nothing.
If this is not a valid post, im fine with it being removed.
I will just have to find another place to post
Because to me this is all the information i would have needed to fix the problem, and i am sure this will happen to someone else.

No, i didn't use anything, i don't even know what redshift is.
I have no idea how i ended up with this, just at some point i restarted my pc and it happened. Tried uninstalling bunch of stuff, nothing helped, i didn't try to re-install drivers yet, but i will, and edit the post.
Tho they did work fine until now.

It is a valid post, but is incomplete. That was the only thing i pointed out.

Now, with this statement i must not agree at all, because i don't think is a proper fix.
With a complete information of your system we might know better.

That is the actual issue and you need to identify the root cause of it, because your proposed "fix" is just a mask for a symptom, not the cure for the real issue.

1 Like

redshift is also referred to as night colour by KDE system settings. either way, bogdan is right you don't need to delete anything but it would be prudent to try and work out why it happened. at least if you are able to capture it with a screenshot it rules out a loose panel cable. Anyhow, double check the settings below:

image

image

Typically I leave the above well alone and use colord-kde (and gnome color management which is a requirement of it) to load in an ICC profile for my panels on both my machines I made with a Datacolor Spyder5. You could do the same with your panel if you have a vendor supplied ICC for it. It also works fine with NVIDIA drivers as long as you don't enable NVIDIA settings color control.

I'm also experiencing this issue, exact same symptoms as the OP. The same "fix" also seems to work.
Night color/redshift and gamma settings are untouched, new install.

A DP cable is being used, sits snugly in the GPU and monitor.

The last thing I did before experiencing the issue (it was using OpenGL fine earlier), was increase the refresh rate of the monitor to 120hz.

Here's inxi -Fxzc0

That certainly seems like a driver bug then if it's refresh rate dependent and also noteworthy that it affects two different generation of hardware. Because you are both using the proprietary driver (as you should with those cards) I guess your next point of call should be the nvidia forums.

https://www.nvidia.com/en-us/geforce/forums/support/

@skindervik and @lonnie - you should both share the /etc/X11/mhwd.d/nvidia.conf and let us know if that is the default one in use or you created a new file as /etc/X11/xorg.conf ...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by