[SOLVED]Bluetooth fail after 2019-05-17 stable update

After updated to the stable version here , I can't connect to my bluetooth keyboard, however my another bluetooth devices works well.

Here is details:
Laptop: XPS-9360
Linux version: 4.19.42-1-MANJARO KDE
Device: Filco Majestouch Convertible 2

I can succesfully connect if I reset the pair and type PIN to connect, but after reboot it won't reconnect automatically and keeps connect/disconnect. The only way is to delete the pair and pair again everytime I reboot the system - it's unacceptable!

I tried bluetoothctl to see what's going on when the keyboard is trying to connect:

Agent registered
[CHG] Device <MACADDR> Connected: yes
[CHG] Device <MACADDR> Connected: no
[CHG] Device <MACADDR> Connected: yes
[CHG] Device <MACADDR> Connected: no
[CHG] Device <MACADDR> Connected: yes
[CHG] Device <MACADDR> Connected: no

It seem the device tried 3 times to connect but fails. I also tried kcmshell5 bluedevildevices:

kcmshell5 bluedevildevices
org.kde.bluez: PendingCall Error: "Input/output error"

bluez throw an error this time.

However, It's strange that my another bluetooth headset ATH-SR5BT does not meet this error and can automatically connect just like before.

Another user have the same issue with me: [Stable Update] 2019-05-17 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd
He is using XFCE so I think it's not KDE that causes the bug.
Any suggestions?

Now you can update to 2019-07-03 and this version solved the problem!

I agree, it is unacceptable. That is why I stopped buying Bluetooth keyboards a long tome ago. These peripherals are all designed for windows and I highly doubt you will find a Linux certified sticker on any product packaging. The drivers are all designed for Windows, and even on Windows I experienced this problem often. I wouldn't have high hopes for a product that often doesn't even work properly in Windows.

No bluetooth for me, problem solved on my end. :wink:

I tried journalctl | grep blue and got:

May 18 19:26:03 imwxz-pc plasmashell[1151]: file:///usr/share/plasma/plasmoids/org.k
de.plasma.bluetooth/contents/ui/logic.js:36: TypeError: Type error

may help

Have you tested alternate kernels?

Not yet. This occurs only after the update, it works well before that.

I would suggest installing and testing both older and newer kernels. Try at least two or three alternate kernels. Install kernels through Manjaro Settings Manager, and always have at least two kernels installed at all times for safety.

How to switch kernels:

When you reboot if you do not see the grub boot screen press and hold down the ESC, SHIFT or F8 key. This should show the GRUB boot menu if it doesn't appear. As soon as you see the grub boot screen, press the down arrow. Select the "advanced" menu from the choices and press enter. In the next menu you can select the different kernels you have installed to boot from. Select the regular kernel you wish boot into (not the fallback), and then press enter to complete the kernel change.


I got the same problem with bluetooth after updating and I'm on gnome. :slightly_frowning_face:

OMG It works.
I tried 5.0.15 and 4.19.42 - both fail.
But 4.19.37_rt19-1 and 5.0.14_rt9-1 connect SUCCESSFULLY.
Confused, what is rt(Real-time) kernal mean? And why it doesn't happen when I using kernal without "rt" before update?

Don't worry about the real time kernels, stick to the regular ones normally. But if the real time kernels work for you that's great.Testing different kernels should be one of the first things you try whenever something breaks after an update. Easy peasy.

Glad that got things working for you.

Cool! Thanks a lot.

1 Like

Looks like a regression in upstream, tried 4.19.42, 5.0.15 and 5.1.1, all fails with the same log as OP. This happens only bluetooth input devices (keyboard, mouse, etc.), speakers and headphones are unaffected.

same problem here with my microsoft keyboard

Same problem when i reboot my xiaomi laptop and i use kernel 4.19.49-1. I have solved it when i use kernel 4.19.37_rt20-1. Thanks a lot.

1 Like

Upgrade to 2019-07-03 completely solved the problem!
You can stick to normal version(without _rt) since then.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by