[SOLVED] Boot loop before GRUB

Secureboot is off ???

I don't think my laptop got Secureboot. There is nothing in BIOS.

Bios image if possible

All tabs in Bios. Sorry for the external link, there is some limits for new users. :slight_smile:

Ok. So i've installed New Manjaro 18 with XFCE and it is not working. The result is the same.

Right now i see only one option to install Win7 and install Linux as second OS. It will enable GRUB to load itself...:frowning:

You should try with a newer ISO.

On your current situation, you could try to boot to your installation, using Live media and the manual method, explained in this tutorial, to see if you can get to your grub menu. If it succeeds, login and run a full update, while after the update, make sure you remove quiet from /etc/default/grub, and run again update-grub

1 Like

This tutorial doesn't help at all. All those commands are not working for me. But thanks to last comment i am able to get to my system by using https://www.supergrubdisk.org/

It boots when i choose manually to boot.
And my bootloader is in "/boot". Maybe I should move it to /dev/sda? I think that's the problem.
When i installed OS, i chose /dev/sda. But it installed in "/boot".

The tutorial uses the same methodology that supergrub does, so it 's more possible you did something wrong, or misunderstood the required commands. Or you have some misconception about your system.

Nevertheless, if you want help fixing booting, please provide info from your system after booting:

sudo parted -l
sudo blkid
findmnt -s
inxi -SMpuo
cat /etc/fstab

Here is my log: https://pastebin.com/qPteHRTu

Try to assign the boot flag to your root partition. (Sda1)
You can use gparted.
Then do again as root..

grub-install --recheck /dev/sda 

That's really cool, it works! Thank you!
Do you have an idea what may be the cause for installer not to assign flag?

its not boot loop its common error I always get
You should have said that no harddrive detected error iguess its grub quiet fault, manual partition is at fault,i have to always set those flags before reboot.

It's the 2nd time this comes up. I guess @philm would know better.

It happens always. Manual installation, automatic or whatever. I reinstalled system right now, to replicate this bug and it's there. Flag is not writing at all.

All i need to do is to boot system from Live GRUB and set boot flag via Gparted.
I don't even need to reinsall GRUB.

Thanks everyone for the help.

About a year ago, I (and someone else) had the same problem. Of 4 different computers, it was happening only on one, the oldest computer. And it happened EVERY time without exception. Me and that other guy wrote about it here on these forums. But it was clear that it was computer specific, since other three computers always had set proper boot flag. All installations were MBR.

If I remember correctly, I then used different Manjaro installer (cli, not sure if it is still around, MA something) and it worked OK. So i'm assuming there may be some kind of bug in Calamares installer that triggers on certain computers?

Oh, you may want to flag post that helped you with clicking on 'solution' check mark so members are informed you don't need help any more plus someone else with the same problem can easy locate the solution.

Quite apart from the fact that you're reading from /dev/zero and from /dev/nvram into stdout so this won't have any direct effect,

what on Earth is this supposed to accomplish?

Please stop posting potentially dangerous commands without any explanation!


i miss spelled it its for restoring bios to default setting ie clearing cmos

It's very important to ensure commands you post are correct, especially anything involving dd and system device mountpoints.

According to what?

it restores my bios settings to default
ok i will type carefully with full explanation what it does from now on

Forum kindly sponsored by