[SOLVED] Boot menu cannot be hidden after 2019-09-05 stable update | Missing gmo error.

@SGS I thought you did comment out this. No?
@gohlip he has no file there

This above was grub.cfg, I did not change the 00_header.

  • Comment out the set locale_dir command in

Lines 200+

With all the answers I can't get to boot :wink:
But it's not about me, I just thought the OP might have a wrong UTF version.

set locale_dir=$prefix/locale

His $prefix. As said, most $prefix is /boot/grub (the correct place to be)
(Some, mostly later) Manjaro is in /usr/share/grub

SGS may not have locale directory at /boot/grub/ but in other place.
SGS can check where where that $prefix is.
By.. at grub prompt,
grub> echo $prefix

If $prefix shows ($root)/boot/grub
Then grub> echo $root

ps: that's the way I 'm used to.
Perhaps and I think there are at OS level, but since I don't use it, I don't know (not memory leak).

I did it to mine. Wish me luck, I will reboot...

1 Like

Clean /boot/grub/


prefix follow :slight_smile:


msdos2 = old??? no matter.

AgentSI know... everything?

13min left, something went wrong :frowning:

You okay? Don't panic, You've petsam and I here.
If we cannot boot your computer. petsam and I will.... eat our hats.

ps: is your grub 2.04-6 or vanilla-grub.
Whatever grub you have now or none or kaput or..
petsam and I can boot up for you.
But change to grub-vanilla, okay?

Here, this link that you yourself refer others to so much. :smile:.

When booted, install grub-vanilla.
Good luck.

1 Like

I am fine :smiley: thank you :slight_smile: AgentS is long time away after his changing and booting :wink:


If I wanted to switch to grub-vanilla
Is this the procedure I should use to do the install?

And if it blows up, can I send you specific hat to eat?

I was distracted by aliens!... (I decided to boot to my broken Linux Mint and I was reminded again I know nothing about troubleshooting on Debian/Ubuntu systems.

I still have an English language grub, no matter what. Even with german lang grub.
But I think we are hijacking the topic...
Just having fun...?

1 Like

It will not blow up (or down, or left...). It's just the way it should be...


This link would be the latest. . Best copy out old /etc/default/grub out first.

Of course, we'll be around if you have any questions.

Yes, I'll send you petsam's address.
ps: don't use FedEx. They tend to send everything to washington dc nowadays especially if the destination is China. That's why I'll send you petsam's address, Not because I won't eat the hat, of course. Make it a big hat. :rofl:


Tsk..tsk.. perhaps I need another partner. :rofl:
BTW, there's a big hat coming your way.
Prepare more Tzatziki sauce!

1 Like

Do not remind me , I love it (gyros) .


1 Like

Nice way to prepare a hat.
Send the recipe to petsam. :smiley:


Please, back on Topic...

My "theory" seems correct.

sudo grep locale /boot/grub/grub.cfg
  # set locale_dir=$prefix/locale

No greek translation for grub in package

pacman -Fl grub-vanilla | grep -E "grub\.mo" | grep \/el

# german is there
pacman -Fl grub-vanilla | grep -E "grub\.mo" | grep \/de
grub-vanilla usr/share/locale/de/LC_MESSAGES/grub.mo
grub-vanilla usr/share/locale/de@hebrew/LC_MESSAGES/grub.mo
grub-vanilla usr/share/locale/de_CH/LC_MESSAGES/grub.mo

I created grub.cfg and rebooted. It had Greek language in grub (though not completely translated).
Because I had downloaded grub.mo from Ubuntu grub translations and copied to /usr/share/locale/el/....
I had tried previously with only /boot/grub/locale/el.mo and it was in English.
After I copied to "system", it was in Greek.

Notice that my grub.cfg has no set locale_dir=$prefix/locale

 # set locale_dir=$prefix/locale

If it is set/enabled, the translations have to be copied over to that prefix.

Since there is not command sequence in update-grub to copy the translation to /boot, there should be no set locale_dir= in 00_header.

It is a bug.

1 Like

And the topic is....?
Certainly not grub locale.

You are on grub-vanilla. $prefix in grub-vanilla is /boot/grub; not /usr/share, right?
Please agree (or disagree) before we continue.

You don't have set locale_dir=$prefix/locale ??
Here's mine..

[pop@Dec ~]$ pacman -Q grub
grub-vanilla 2.04-2
[pop@Dec ~]$ sudo cat /boot/grub/grub.cfg | grep locale_dir
  set locale_dir=$prefix/locale
[pop@Dec ~]$ sudo cat /boot/grub/grub.cfg | grep lang
  set lang=en_US
[pop@Dec ~]$ 

Mine has. Why yours don't?


To add further... in a another topic,

you said..

But (b) you can find (if you can) your language's mo translation file for grub ( I had found mine in an Ubuntu ppa) and copy it in /boot/grub/locale .
As I said, I still have greek lang at grub.

But let's ignore this if it adds to confusion or if I misunderstand.


As usual, you don't read all posts, or you were distracted by something. :man_shrugging:

Read slowly please.

The user (or someone else) has added the "Missing gmo" to the topic title.
So, yes, grub locale... :man_shrugging:

That was me. See post #18-19.

1 Like

So... how about answering the more important question than hiding behind an insignificant, unrelated, inconsequential and useless point.
Do you have
set locale_dir=$prefix/locale
set lang=
or do you not??!!

I tried/tested this (own) advice:

So, I disabled set locale in 00_header and updated grub

Read this post with my findings and post any questions, if any.

It is not a race or fight. Just asking the guru for verification of a bug. :wink:.
Please, check.

1 Like

Forum kindly sponsored by