[SOLVED] Broadcom BCM4359 wifi not working

I have issues getting Broadcom BCM4395 working with Manjaro. Default reverse-engineered drivers did not work with this wifi adapter, I've installed broadcom-wl drivers via mhwd, and alas, card is still not working.... it is flawlessly recognized as BCM4395 based adapter, configured properly, but when I try to actually connect with network manager, all I get is "no carrier" in dmesg :frowning: anybody got this broadcom chip working?

EDIT: tried kernel 4.14 an 4.15, Manjaro KDE...

which exact driver package do you have installed?

Please post the output of

inxi -Fx

novakj@pr-nb-cis002 ~ $ pacman -Qs broadcom 
local/linux414-broadcom-wl (linux414-extramodules)
    Broadcom 802.11 Linux STA wireless driver BCM43142.
local/linux415-broadcom-wl (linux415-extramodules)
    Broadcom 802.11 Linux STA wireless driver BCM43142.
novakj@pr-nb-cis002 ~ $ inxi -Fx
Resuming in non X mode: xrandr not found. For package install advice run: inxi --recommends
System:    Host: pr-nb-cis002 Kernel: 4.15.0-1-MANJARO x86_64 bits: 64 gcc: 7.2.1
           Desktop: KDE Plasma 5.11.5 (Qt 5.10.0) Distro: Manjaro Linux
Machine:   Device: laptop System: HP product: HP ProBook 650 G2 serial: N/A
           Mobo: HP model: 80FD v: KBC Version 22.71 serial: N/A UEFI: HP v: N76 Ver. 01.15 date: 12/19/2017
Battery    BAT0: charge: 30.9 Wh 69.3% condition: 44.5/44.5 Wh (100%)
           model: Hewlett-Packard Primary status: Discharging
CPU:       Dual core Intel Core i5-6200U (-MT-MCP-) arch: Skylake rev.3 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9602
           clock speeds: max: 2800 MHz 1: 800 MHz 2: 1737 MHz 3: 1585 MHz 4: 1140 MHz
Graphics:  Card: Intel HD Graphics 520 bus-ID: 00:02.0
           Display Server: N/A drivers: intel (unloaded: modesetting) tty size: 133x36
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.15.0-1-MANJARO
Network:   Card-1: Intel Ethernet Connection I219-V driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: half mac: 34:64:a9:06:51:9b
           Card-2: Broadcom Limited BCM43228 802.11a/b/g/n driver: wl bus-ID: 02:00.0
           IF: wlp2s0 state: dormant mac: 8a:f7:a3:98:86:47
Drives:    HDD Total Size: 500.1GB (25.6% used)
           ID-1: /dev/sda model: HGST_HTS725050A7 size: 500.1GB
Partition: ID-1: / size: 449G used: 112G (27%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 9.45GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 28.0C mobo: 0.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 257 Uptime: 4 min Memory: 1826.9/15925.6MB Init: systemd Gcc sys: 7.2.1
           Client: Shell (zsh 5.4.2) inxi: 2.3.56 
novakj@pr-nb-cis002 ~ $

as you can see, even inxi does "see" the adapter, but I cannot connect to any wifi network :frowning:
and when I try to connect I get this in dmesg:

[  371.059481] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[  403.691915] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[  429.012981] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[  429.032494] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready

Yes, but the adapter is detected as:


right, but in dmesg on boot I have:

[   13.644286] wlan0: Broadcom BCM4359 802.11 Hybrid Wireless Controller (r587334)
[   13.984156] wl 0000:02:00.0 wlp2s0: renamed from wlan0

so is driver right or inxi is right? :slight_smile:

ok BCM43142 is your bluetooth drivers

main thing is - mhwd installed correctly "wl" module, which is loaded properly and even interface is showing up, it just cannot connect for whatever reason...

are the bluetooth drivers installed, you may need both installed for the card to function properly. I'm sorry I'm not familiar with broadcom drivers, I never use those cards.

bluetooth driver is complaining about missing firmware, thought it does not matter - anyways, bluetooth is working perfectly, I am using bluetooth mouse...

See the above link. You may have to blacklist other conflicting drivers
I think you will need to install the bluetooth firmware package from the AUR. If the correct firmware is not installed that may be why your wifi won't work.


I will give it a try at morning... nonworking wireless on notebook makes it pointless... I have not had these troubles with 'buntu based distros, guess there is some patch in there...

I think the missing bluetooth firmware may be the root of your issue. The firmware update may be included in ubuntu. Try both of my suggestions, and let us know how it goes.
Good luck.

Upon further reading on the Archwiki you may need other FW updates from the AUR.


The most likely being b43-firmware


From the Archwiki:

"these drivers require non-free firmware to function. Install b43-firmwareAUR, b43-firmware-classicAUR or b43-firmware-legacyAUR from the AUR."

Blacklisting may also be required according to the Archwiki.

There you have it from the authoritative source, guess the Archwiki should have been the first search performed.

Also, see the posts below, I think you have related issue. You do not want to use the broadcom-wl drivers, you should be using the b43 drivers.



Remove and re-add the connection in Network Manager, and check the output of journalctl -u NetworkManager .

mhm... strange as it sounds, deinstalling wl driver package helped, wifi is now able to connect to open and WPA2-PSK hotspots... now off to figure out WPA2-EAP :slight_smile:
I guess lession learned is - don't install drivers before checking if hardware does not work with existing drivers...

1 Like

Glad to hear you got it working.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by