[SOLVED] Bumblebee Issues with bbswitch

I've been pulling my hair out for the past few hours trying to configure my graphics drivers on my laptop. I would like to use the proprietary bumblebee drivers on my laptop, however despite installing them and having them show up onmhwd -li and the Manjaro Systems Setting window, optirun just does not seem to work. Calling optirun gives me this error:

$ optirun glxgears -info
[ 279.649738] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver
[ 279.649777] [ERROR]Aborting because fallback start is disabled.

At first this seemed like a pretty common error, while other people have reported this same error I was unable to fix mine using the same steps in their help posts.

I have removed and reinstalled bumblebee multiple times to no avail. I suspect a number of causes:

  • I added my user to "a" bumblebee group. I vaguely recall that I may have created an arbitrary group called bumblebee, but I can't remember so I may not have the correct permissions. Is there some way to verify this?

  • bumblebeed status returns the following:
    $ bumblebeed status
    [ 1088.955296] [WARN]No switching method available. The dedicated card will always be on.
    [ 1088.955478] [ERROR]Could not set the GID of bumblebee: Operation not permitted
    Perhaps this could mean something too?

I can provide more information however I'm not sure which bits are relevant, any guidance is appreciated. Thanks

can you report

inxi -Fxxxz
sudo pacman -Qs bbswitch
sudo pacman -Qs acpid
sudo mhwd -li

Sure so I omitted some information from the output of inxi -Fxxxz like Audio, Network, Battery, etc but I believe the important information should all be there (let me know if otherwise):

im not too familiar with bumblebee but you may want to read through this troubleshooting thread

Since lastest rebuild bumbebee package REQUIRED manually add user to bumblebee group!

sudo gpasswd -a $USER bumblebee

LOGOUT and LOGIN

Yes so as I mentioned in my OP, I suspected I had already done this earlier. So I am already in the bumblebee group. I verified this by running groups.

full dmesg please.

dmesg > ~/dmesg.log

paste dmesg.log file to pastebin.com site.

Here you go

DMI: Acer Swift SF314-52G/Suntory_KL, BIOS V1.08 11/28/2017

NVIDIA does not work cause

[  279.988008] nvidia: disagrees about version of symbol module_layout
[  300.142348] nvidia: disagrees about version of symbol module_layout
[ 1634.209997] bbswitch: disagrees about version of symbol module_layout
[ 4543.099733] nvidia: disagrees about version of symbol module_layout
[ 4543.214320] nvidia: disagrees about version of symbol module_layout

You need Install VALID Kernel version and VALID NVIDIA and BBSWITCH module package rebuild AGAINST new kernel version.

Paste results:

pacman -Q|grep nvidia
pacman -Q|grep bbswitch
pacman -Q|grep linux4

@philm

Ah so it could be an issue with my package versions then?

$ pacman -Q|grep nvidia            
lib32-nvidia-utils 1:415.25-1
linux414-nvidia 1:415.25-2
mhwd-nvidia 1:410.78-1
mhwd-nvidia-340xx 340.107-1
mhwd-nvidia-390xx 390.87-1
nvidia-utils 1:415.25-1
opencl-nvidia 1:415.18-1
$ pacman -Q|grep bbswitch
linux414-bbswitch 0.8-72
$ pacman -Q|grep linux4
linux414 4.14.83-1
linux414-bbswitch 0.8-72
linux414-nvidia 1:415.25-2
linux414-rt-headers 4.14.78_rt47-1

Please TRY this one:
Switch to lastest 4.20 kernel:

sudo mhwd-kernel -i linux420

Reboot. Boot from 4.20 and check

optirun nvidia-smi

Okay, I have something that looks a little more promising.

optirun nvidia-smi
Sat Dec 29 19:23:44 2018       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 415.25       Driver Version: 415.25       CUDA Version: 10.0     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce MX150       Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   39C    P0    N/A /  N/A |      6MiB /  2002MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      2255      G   /usr/lib/Xorg                                  5MiB |
+-----------------------------------------------------------------------------+

:smiley: stay with 4.20 cause it is works fine :stuck_out_tongue:

Okay great thanks so much! I have however one more question. My fan seems to run on full despite the graphics card being off supposedly. Is there someway I can turn down the fan when the graphics card is turned off?

Share NEW dmesg (del old one and create new one > pastebin)
Paste results of:

sensors 

So I ran dmesg | grep sensors and found nothing, was this what you meant?

  1. create NEW dmesg.log file:
dmesg > ~/dmesg420.log

paste it on pastebin.com

  1. paste in normal reply result of
sensors

Ah I see, sorry about that :sweat_smile:

Here's my dmesg output.

Here's my sensors output.

$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +35.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +35.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +35.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +34.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +35.0°C  (high = +100.0°C, crit = +100.0°C)

You paste of dmesg is not full :stuck_out_tongue: btw, its fairly normal that FAN works little louder :stuck_out_tongue:

Edited the link on my previous reply, but yeah my main concern is that it's running quite loudly all the time even when the GPU is off, I can understand if it's loud during GPU operation but when I don't need the GPU I'd ideally like the fan to be quieter if possible.

Forum kindly sponsored by