[SOLVED]Can not boot manjaro

When I rebooted my pc after I installed manjaro, I see "Cheking media : fail".I can boot with live usb and use my manjaro. But without usb I can not boot it.

Not much to go on.

You propably have installed grub on your usb.

Are you using Legacy or UEFI boot?

UEFI boot

You installed the bootloader on your USB drive then.
See this:

1 Like

I will try

1 Like

It did not work.

If I understand it, you can boot up installed Manjaro with the liveusb attached.
Without the install usb, it cannot be booted up.

Also, it is in UEFI mode.

We need more information from you to make a correct assessment and it can take some time. I need to log off soon so i may reply you some time later. Others can help if they wish. Appreciated.

Boot up Manjaro installed partition and provide the following (provide full info, no omission, all disks)

test -d /sys/firmware/efi && echo UEFI || echo BIOS
findmnt /boot/efi
cat /etc/fstab
sudo blkid
cat /proc/cmdline

ps: if other OS, please list and name partitions they're at.

BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0002,2001,2003,2002
Boot0000* EFI Network 0 for IPv6 (F4-CE-46-CD-68-51) 
Boot0001* EFI Network 0 for IPv4 (F4-CE-46-CD-68-51) 
Boot0002* EFI HDD Device (ST1000LM048-2E7172)
Boot0003* EFI USB Device (SanDisk)
Boot2001* EFI USB Device
Boot2003* EFI Network
#findmnt /boot/efi
/boot/efi /dev/sda1 vfat   rw,noatime,fmask=0022,dmask=0022,codepage=437,iochars
#cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>                           <mount point>  <type>  <options>  <dump>  <pass>
UUID=A0B9-C8F2                            /boot/efi      vfat    defaults,noatime 0       2
UUID=9a7d0f00-4230-4c56-af48-d20fa392b78e /              ext4    defaults,noatime 0       1
UUID=964e7861-7d3c-4f49-b734-e3ebd55803ac swap           swap    defaults,noatime 0       0

/dev/sda1: UUID="A0B9-C8F2" TYPE="vfat" PARTUUID="680ee45e-ba55-4b1b-aa1c-44de35e45d7a"
/dev/sda2: UUID="9a7d0f00-4230-4c56-af48-d20fa392b78e" TYPE="ext4" PARTUUID="7281c903-e8db-4711-9a82-ceba78e144a8"
/dev/sda3: UUID="964e7861-7d3c-4f49-b734-e3ebd55803ac" TYPE="swap" PARTUUID="765d5719-9287-455d-979d-20d8f9bf875a"
/dev/sdb1: UUID="2017-04-02-11-58-17-00" LABEL="MJRO1701" TYPE="iso9660"
/dev/sdb2: SEC_TYPE="msdos" LABEL="MISO_EFI" UUID="8607-824A" TYPE="vfat"

#cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.9-x86_64 root=UUID=9a7d0f00-4230-4c56-af48-d20fa392b78e rw quiet resume=UUID=964e7861-7d3c-4f49-b734-e3ebd55803ac

Also I tried rEFInd and bootctl.
=>rEFInd did not work.
=>bootctl almost worked. List is coming but can not find /boot/vmlinuz-4.9-x86_64

I looks like this problem.

The OP (@jb10210) there has a solution, but do the following first before using his solution.

Boot up, at terminal

sudo grub-install

Check the output of 'efibootmgr' before and after the command.
Is 'manjaro' added to the bootorder (in efibootmgr and first in bootorder?)
Reboot and see if it works and verify if 'efibootmgr' contains manjaro)


If [1] don't work, as in the link, continue as follows...
output again of

sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

Reboot and test again

The solution the OP at the list the OP used...

sudo cp /boot/efi/EFI/Manjaro/grubx64.efi /boot/efi/EFI/boot/bootx64.efi

ps: need you to test out these steps 1~3 because it might be something else bigger.
ps: can you let us know what system you're using?
@jb10210 is having "I have a MSI Z170A Gaming M7 motherboard with I7-6700 CPU and 16 GB of RAM."

If we get more of these issues needing step [3], perhaps the developers need to be alerted. It might be something (but I personally do not have this issue).

1 Like

[3] did work. THANK YOU !!!!

Please don't forget to put the topic as solved. There's a checkbox at the bottom of each post to mark a post as solution.
Mark the post that solved your problem. :slight_smile:

is it ok now ??

There's a checkbox at the bottom of each post to mark a post as solution.
Mark the post that solved your problem (for the others who want to find the solution quickly). :slight_smile:

1 Like

Glad it worked, we have @jb10210 to thank for.

But to the developers here --
It is possible some uefi firmware is not ... up to specs
Also possible some uefi bios lock out bootorder.
But we need to take a harder look or be watchful, it has happened twice in the last week.

To @furkanRF

1 Like
Windows 8 T64 bit 
Intel® Turbo Boost Technology  Intel® Core™ i5-3230M
HDD 750 GB
8,192 (4,096 + 4,096) MB, DDR3 RAM (1.600 MHz)
NVIDIA® GeForce® GT 740M
1 Like

Thanks [3] worked like a charm.

After my installation, my system couldn't boot. It couldn't pass "press F2 to access BIOS" stage.

First I restored the grub-bootloader as described here

It allowed me to boot into the system using live usb.

Then I tried [1] and [2] above but the problem continues. [3] Fixed it.

Forum kindly sponsored by