[solved] Can’t boot Manjaro on Intel NUC 8i7HVK


no, the whole screen is flickering and the keyboard is not responding properly

so but i have a lot of testing this with Debian Testing & Experimental,
and I came to the following conclusion...

Kernel 4.17 with X.Org 1.19 = Okay

Kernel 4.17 with X.Org 1.20 = Failed

Kernel 4.18 with X.Org 1.20 = Okay

X.Org 1.20 need something from Kernel 4.18 by using the new Radeon Vega M Card

So in Manjaro is X.Org 1.20, so i have to wait for an installation medium which starts with kernel 4.18

I am sorry for more detailed information about my test, my English is too bad

yes add linux418-headers


so after 2 month i have installed manjaro now on my NUC8i7HVK :grinning:

Booting with the new Manjaro-Beta_4 is the same error and it crash the X-server....

But now it is possible to change the Runlevel "init 2" to login as Manjaro and type "setup" for Terminalinstallation without GUI to install Manjaro directly with kernel 4.18.....

so i think this is now the only way for Computers with the new Radeon Vega RX M graphics card to install manjaro.
on this Machine is Manjaro only working with Kernel 4.18 :wink:

egle@NUC8i7HVK Linux 4.18.0-1-MANJARO x86_64 17.1.11 Hakoila
~ >>> cat /etc/lsb-release                                                                                                                                                                                                                            [130]
~ >>> echo $DESKTOP_SESSION                                                                                                                                                                                                                               
~ >>>  


thanks for Manjaro 18.0-beta5, with this Version is it first possible to boot correct to the Gui and used the Launch Installer....

Great Works :+1::clap::grinning:

[manjaro@manjaro ~]$ inxi -F
System:    Host: manjaro Kernel: 4.18.0-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.13.4 
           Distro: Manjaro Linux 
Machine:   Type: Desktop System: Intel product: NUC8i7HVK v: J71485-501 serial: <root required> 
           Mobo: Intel model: NUC8i7HVB v: J68196-401 serial: <root required> UEFI: Intel 
           v: HNKBLi70.86A.0040.2018.0516.1521 date: 05/16/2018 
CPU:       Topology: Quad Core model: Intel Core i7-8809G bits: 64 type: MT MCP L2 cache: 8192 KiB 
           Speed: 800 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 
           7: 800 8: 801 
Graphics:  Card-1: Advanced Micro Devices [AMD/ATI] Polaris 22 [Radeon RX Vega M GH] driver: amdgpu v: kernel 
           Display: x11 server: X.Org 1.20.1 driver: amdgpu,ati unloaded: modesetting 
           resolution: 2560x1440~60Hz 
           OpenGL: renderer: AMD VEGAM (DRM 3.26.0 4.18.0-1-MANJARO LLVM 6.0.1) v: 4.5 Mesa 18.1.5 
Audio:     Card-1: Intel CM238 HD Audio driver: snd_hda_intel 
           Card-2: Advanced Micro Devices [AMD/ATI] driver: snd_hda_intel 
           Sound Server: ALSA v: k4.18.0-1-MANJARO 
Network:   Card-1: Intel Ethernet I219-LM driver: e1000e 
           IF: enp0s31f6 state: down mac: d4:5d:df:07:4d:2d 
           Card-2: Intel I210 Gigabit Network driver: igb 
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: d4:5d:df:07:4d:2e 
           Card-3: Intel Wireless 8265 / 8275 driver: iwlwifi 
           IF: wlp6s0 state: down mac: 4e:f7:13:6a:1d:fd 
Drives:    Local Storage: total: 242.20 GiB used: 1.97 GiB (0.8%) 
           ID-1: /dev/sda vendor: Intel model: SSDSCKKW256G8 size: 238.47 GiB 
           ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade size: 3.73 GiB 
Partition: ID-1: / size: 5.81 GiB used: 154.5 MiB (2.6%) fs: overlay dev: ERR-102 
Sensors:   System Temperatures: cpu: 43.5 C mobo: 29.8 C gpu: amdgpu temp: 38 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 230 Uptime: 9m Memory: 7.75 GiB used: 1.27 GiB (16.4%) Shell: bash inxi: 3.0.18 
[manjaro@manjaro ~]$ 

When I have installed manjaro 18 beta 5in my nuc8i7hvk, I can not enter linux or bios, can you help me? Thank you.


sorry for my Google-English, my language is german....

  1. are already operating systems installed, if so which one?

  2. the NUC is so fast,... after press Power on just click the F2 key until the UEFI BIOS appears.

  3. Here you can see my UEFI-Bios settings


If you installed manjaro from Beta5 is the installation going without errors?

Sometimes i hd error that the Bootloader cannot installed :thinking:

is this so, the best way to boot Mnajro-Linux is with the supergrub-usb-stick
or another Linux-Livesystem and go with chroot in the system.

or see this thread:

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

I felt that I had run 100 installations of various Linux distributions on my NUC. And somehow I had shot the UEFI with Debian ...

But your first thing is to go in Bios and disable "secureboot", with secureboot you can only install and boot a Ubuntu-Linux only their EFI is certified..
so look on my BIOS-Screenshots...

My linux is manjaro 18.0 beta5.
Then I restarted the NUC, I found that I enter manjaro directly. I can not enter bios or grub.
Even I press F2 or other key, I still can not enter bios.
So I can not change the boot sequence, I can not reinstall system.
Maybe the UEFI is confilct with the BIOS. So I tried to recover the bios, but I failed.
Do you know how to enter UEFI shell in manjaro?
Thank you very much!
By the way, my English is also very poor:)


hmm, with F2 you must can go in the Bios :thinking:

Immediately after falling in, press the F2 key repeatedly, even if the screen is still black.
If you see the Manjaro Grub-Theme you was to slow.....

But i am not so ggod in Linux and UEFI ect.

Maby it is better to make a new Thread for the Bios-problem?

UEFi Shell....
Hmm i think with the "Super Grup Disk" (usb-Stick) you can install a UEFI Shell.

Then disable fast boot.

Scroll down till you get "Disabling Fast Boot from the power button menu".

I can't go into the bios, F2 does not work.
The NUC will enter linux directly, and never boot from USB disk.
Maybe UEFI write some wrong information in the NVRAM, and make the bios broken.
I try to recover the bios, including "the power button menu" ,"remove the bios security jumper" and "unconnect the RTC battery", but they all don't work.

I can not enter bios, and I can't enter the power button menu. I have tried to recover bios for several ways, and I failed:(


so sorry...
I cannot help?

Contact the Intel-support for help?

or your dealer, this NUC is new and with Warranty...

PS. by the Post from @Days: in the right top corner you can switch to your Mother-Language.

Or look at this (in your Language top reight coner you can select).

try a lighter version of Manjaro or the graphics chip or card is to weak

Rather use the English version. This translation is "unterirdisch" :wink:

I guess that the UEFI loader wrote some wrong information in the NVRAM when I installed LINUX.

So I want to enter the UEFI shell to reset NVRAM data, but I don't know how.

I changed boot order using efibootmgr, set win10 to be the highest priority. So when I restarted the NUC, I entered win10 automatically every time.
Last night, win10 upgraded. This morning, when I restarted the NUC, I found I can enter bios...

I guess when win10 upgraded, the system reset the NVRAM data.

It seems that the problem has been solved, although I'm not sure of the real reason.


I see this thread has been moved to "Support for Official Editions".

Isn't that a bit early?

To install you still need a Manjaro which boots with kernel 4.18 or higher.

Manjaro 17.1.12 doesn't boot directly with the kernel 4.18, or has it been changed?

Meanwhile I have also successfully installed Manjaro on a second NUC8i7HVK using the 18.0-beta-5 and update to Manjaro 17.1.12...

So I would say that it is officially supported with Manjaro 18.x :wink:

1 Like

Now the manjaro version is 18.0.4, still can not be launched on the intel nuc 8i7hvk. As described in this topic, I cannot access the installation interface. Even after I installed it on the mobile hard disk, I can't boot it on the nuc. I changed the 4.19, 4.20, 5.0 kernel, and I can't. I do not know why.
The above description 18.0-beta5 has been fixed, isn't it? Why is the current 18.0.4 still not possible. And the previous 18.0-beta5 installation package can not be found.

Maybe you need to install bios update. Sometime stock bios can have bugs in it. That can make it unable to boot. I had one issue with uefi boot will not work for a linux distro. But when I updated the biso. It fix the issue.

Here the latest biso for Intel® NUC Kits NUC8i7HNK and NUC8i7HVK

Thank you for your reply. I updated my BIOS, but it didn't bring any good changes, it was the same as before. Also, my firmware is also very new before the upgrade, is the firmware in November 2018.

Are you also using NUC? My version is NUC8i7HVK. Have you successfully installed the KDE version of manjaro?

Tried the link in my earlier post?
And if still having problem, provide info as per that link.

Mobile hard drive? Meaning external drive?
Set $esp to internal drive.
Use the link above-mentioned link?
Then provide information on that link.

Forum kindly sponsored by