[solved] Can’t boot Manjaro on Intel NUC 8i7HVK

Then disable fast boot.

Scroll down till you get "Disabling Fast Boot from the power button menu".

I can't go into the bios, F2 does not work.
The NUC will enter linux directly, and never boot from USB disk.
Maybe UEFI write some wrong information in the NVRAM, and make the bios broken.
I try to recover the bios, including "the power button menu" ,"remove the bios security jumper" and "unconnect the RTC battery", but they all don't work.

I can not enter bios, and I can't enter the power button menu. I have tried to recover bios for several ways, and I failed:(


so sorry...
I cannot help?

Contact the Intel-support for help?

or your dealer, this NUC is new and with Warranty...

PS. by the Post from @Days: in the right top corner you can switch to your Mother-Language.

Or look at this (in your Language top reight coner you can select).

try a lighter version of Manjaro or the graphics chip or card is to weak

Rather use the English version. This translation is "unterirdisch" :wink:

I guess that the UEFI loader wrote some wrong information in the NVRAM when I installed LINUX.

So I want to enter the UEFI shell to reset NVRAM data, but I don't know how.

I changed boot order using efibootmgr, set win10 to be the highest priority. So when I restarted the NUC, I entered win10 automatically every time.
Last night, win10 upgraded. This morning, when I restarted the NUC, I found I can enter bios...

I guess when win10 upgraded, the system reset the NVRAM data.

It seems that the problem has been solved, although I'm not sure of the real reason.


I see this thread has been moved to "Support for Official Editions".

Isn't that a bit early?

To install you still need a Manjaro which boots with kernel 4.18 or higher.

Manjaro 17.1.12 doesn't boot directly with the kernel 4.18, or has it been changed?

Meanwhile I have also successfully installed Manjaro on a second NUC8i7HVK using the 18.0-beta-5 and update to Manjaro 17.1.12...

So I would say that it is officially supported with Manjaro 18.x :wink:

1 Like

Now the manjaro version is 18.0.4, still can not be launched on the intel nuc 8i7hvk. As described in this topic, I cannot access the installation interface. Even after I installed it on the mobile hard disk, I can't boot it on the nuc. I changed the 4.19, 4.20, 5.0 kernel, and I can't. I do not know why.
The above description 18.0-beta5 has been fixed, isn't it? Why is the current 18.0.4 still not possible. And the previous 18.0-beta5 installation package can not be found.

Maybe you need to install bios update. Sometime stock bios can have bugs in it. That can make it unable to boot. I had one issue with uefi boot will not work for a linux distro. But when I updated the biso. It fix the issue.

Here the latest biso for Intel® NUC Kits NUC8i7HNK and NUC8i7HVK

Thank you for your reply. I updated my BIOS, but it didn't bring any good changes, it was the same as before. Also, my firmware is also very new before the upgrade, is the firmware in November 2018.

Are you also using NUC? My version is NUC8i7HVK. Have you successfully installed the KDE version of manjaro?

Tried the link in my earlier post?
And if still having problem, provide info as per that link.

Mobile hard drive? Meaning external drive?
Set $esp to internal drive.
Use the link above-mentioned link?
Then provide information on that link.

Hello @ShanwFeng,

sorry for my terrible english...

So on my NUC Manjaro is running very well, with Kernel 4.19.

What I could imagine....
In Bios you have two graphics options, one for Intel and one for Radeon.
I've deactivated Intel's and now run the Radeon with these drivers under Manjaro without any problems:

[egle@NUC8i7HVK ~]$ screenfetch

 ██████████████████  ████████     egle@NUC8i7HVK
 ██████████████████  ████████     OS: Manjaro 18.0.4 Illyria
 ██████████████████  ████████     Kernel: x86_64 Linux 4.19.28-1-MANJARO
 ██████████████████  ████████     Uptime: 2h 1m
 ████████            ████████     Packages: 1323
 ████████  ████████  ████████     Shell: bash 5.0.0
 ████████  ████████  ████████     Resolution: 2560x1440
 ████████  ████████  ████████     DE: KDE 5.56.0 / Plasma 5.15.2
 ████████  ████████  ████████     WM: KWin
 ████████  ████████  ████████     GTK Theme: Breath [GTK2/3]
 ████████  ████████  ████████     Icon Theme: maia
 ████████  ████████  ████████     Font: Noto Sans Regular
 ████████  ████████  ████████     CPU: Intel Core i7-8809G @ 8x 4.2GHz [54.0°C]
 ████████  ████████  ████████     GPU: AMD VEGAM (DRM 3.27.0, 4.19.28-1-MANJARO, LLVM 7.0.1)
                                  RAM: 3254MiB / 15991MiB
[egle@NUC8i7HVK ~]$ 

Thank you @gohlip, which post do you mean? Yes, the mobile hard drive is an external drive. That is google English, sorry.

I used the other computer to install manjaro to the external drive. It can be used normally, then unplug it and start it on the NUC. It fails, it can enter the grub interface, but the system cannot be started. Just like when I installed manjaro on NUC, NUC's fan truns very fast and the screen was black.

I even installed it on NUC using the manjaro architect version, I installed the graphics driver, 4.19 kernal, even 5.0 kernel, and KDE desktop. After the installation, I can enter the grub interface, after selecting the system still can not start, I replaced the 4.19 kernel, 5.0 kernel can not be started, so what is the problem that @EgLe mentioned in the 4.18 kernel was fixed?

I'm not the first install manjaro system, search a bit on the network, as well as the above EgLe's reply, so it seems indeed graphics driver problem.

Thank you @EgLe, you are very persistent in solving the problem, I think your method can try, but I don't know how you disable the intel graphics card, I will go to the network to search for related solutions before you reply.

There are still some problems,
Your current version is the latest manjaro 18.0.4, or is it not a beta version?
What was the problem you said was fixed in the manjaro 18.0-beta5 version?
You said that the beta5 version is directly installable and bootable, and does not require additional operations, but I can't do it now. What do you mean at that time also need to disable the intel graphics card?

OK, I will try it at night, thank you for your reply, my native language is not English, please forgive me. If it can be solved I will write a detailed process here. I hope that ordinary users can understand it.

Set $esp to internal drive.
Then you won't have a problem when you unplug the external drive.

ps: do you use the external drive OS in another computer as well?
Then you need to make sure the graphic is 'non-free' or not proprietary
And you will need to set $esp to that external drive but with a "--removable" in the grub-install command. If you don't use it in another system, then just use the $esp of that internal drive.

ps: your english is fine. no translation needed.
英语不错。 还可以。:slightly_smiling_face:

This one.
Info needed.

efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi

ps: Understand you're new here, but
When a topic like this is old (and especially solved), you should start a new topic.
You can reference this topic in your new topic.
Welcome to Manjaro. 欢迎。

Hello @ShawnFeng
My language is not english too :slight_smile:
I take the deepl.com Transalter ...

In on of the top posting i have post the Bios-Picture Gallery :wink:

Here is the Picture of my Graphics-Setting:


Hope this helps a little bit?

Think you @EgLe , I have done this before, I have seen other examples of dual graphics installation systems. But still no effect.
I did this:
Disable the intel graphics card in the BIOS setup, just like the picture you provided.
Boot from the USB flash drive. ->
Then press "e" in installation interface to modify the startup script and add "nomodeset = 1" option after "quiet".
It is like this:1225261080
Then press "Ctrl+x" to execute it. Then it starts up and then stops here,
just like a post you described earlier. According to you, after disabling the intel graphics card, it will not stop here. Is it?

I tried kubuntu, using the above process can be installed and used normally.

My installation process is just like this, My platform is the same as @EgLe, and it is also intel nuc 8i7hvk. Only I installed manjaro-kde-18.0.4, I want to know if I have done less steps?

I can't take a screenshot, so I took a photo, it's ugly, sorry.

Thank you for your reply @gohlip, this is the output of the commands in your post:
Sorry, this a picture and not a screenshot.

I read some other posts and I followed the same steps to install kubuntu and installed manjaro on other computers. So I thought it should be a problem with the graphics card.

I see that the output of those commands is some hard drive information and boot information, I think is unlikely to be the problem here.
My NUC has a solid state drive. Windows and ubuntu appear in the above information. Windows is installed on another external hard disk, use usb-c to connect to NUC. Ubuntu was previously installed in the built-in solid state of the computer, but it should have been erased now.

I am sorry, the post has been marked as resolved and I continue to ask questions because I feel that this issue has not been completely resolved... And I think @EgLe has some practical experience.
Maybe after that, thank you for your suggestion.

I am listening to your suggestion to start a new topic.@gohlip
Think you. It is here.

Looks like you did not disable 'secure boot' as EgLe has reminded you.
You must reinstall with 'secure boot' disabled.
And use the $esp in your nvme disk (nvme0n1p1) and do not format this during installation.

Note that Ubuntu can be installed with 'secure boot' enabled, but not Manjaro.

ps: I also did not see your fstab of your installed Manjaro OS.
(your output is of the livecd OS)

Forum kindly sponsored by