[SOLVED] Cannot boot Manjaro after Windows Update 'error: unknown filesystem' 'Entering rescue mode'

I have multi-boot UEFI laptop (Secure Boot disabled) with Windows 10 and several other Linux distros including Manjaro (which is in charge of grub menu as usual), then there's Linux Mint and several others. I have been using it like this for past 3 years without any problems. I like to keep up to date with other Linux distros.

But today, after a big Windows 10 update, I am faced with the following message on reboot...

Welcome to GRUB!
error: unknown filesystem.
Entering rescue mode...
grub rescue

If I reboot then...

a) If I press F2 for BIOS, I can see Manjaro looks like it is still in charge of grub but it can't boot, so it's grub is just broken I guess.

b) If I press F12 for 'Boot Options' and chose Manjaro, I get the same error

c) But if I press F12 for 'Boot Options' and chose say Linux Mint (or any other distro), I see it's own 'GNU Grub' menu and I can boot into it.

So I was wondering if there is a process where I can boot into Linux Mint and then open terminal and chroot into the Manjaro partition and run a few commands? Although I'm not entirely sure of syntax to do this.

If this was on old legacy laptop where another Linux OS put itself in charge of grub after an update, then I have a process to fix that and put Manjaro back in charge, but I guess a UEFI broken grub is entirely different?

I have found some similar issues using Google, but I see that some of the suggested solutions didn't work, and I'm afraid to adapt these solution to my situation in case I make matters worse than they are already.

here is some details for my DELL Inspiron 5559 system, I hope it helps to show my current setup...

hugh@DELL-INSP-MINT ~ $ blkid
/dev/sda1: LABEL="Recovery" UUID="1620144F201437E7" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="bcf7fd0a-6f6e-4c9a-99b5-570eddd6fd1b"
/dev/sda2: UUID="2E14-EFF3" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="ac879a29-7424-4b17-828a-4d5658c77c46"
/dev/sda4: UUID="700C2E760C2E380C" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="46e912da-0300-4a8b-9545-86b75dab3677"
/dev/sda5: UUID="30DE8164DE8122E8" TYPE="ntfs" PARTUUID="42159c44-2caf-4f8a-9fc8-13c1b78b9f5b"
/dev/sda6: LABEL="NTFS" UUID="01C9E1C7718A1F6C" TYPE="ntfs" PARTUUID="7e57b21b-54a9-474c-b23b-eec4a2b78b3a"
/dev/sda7: LABEL="MANJARO" UUID="15716d5b-626b-44ed-abe7-effb2bee3478" TYPE="ext4" PARTUUID="d8e94682-d3cb-417d-ace8-1542473fc8a4"
/dev/sda8: UUID="68feb7cd-5a05-4b94-88f3-07e0dde1eda7" TYPE="swap" PARTUUID="f151ed14-0f3f-41c0-8d9d-0cac45b2cf27"
/dev/sda9: LABEL="ANTERGOS-HD" UUID="d95a505c-59a4-4e32-8fcc-5ada3c24437e" TYPE="ext4" PARTUUID="c9f2ab64-7469-4ea8-b031-cbeb648c09b8"
/dev/sda10: LABEL="SPARE1" UUID="0df43b52-7b87-4188-9794-0d2b7e681a6a" TYPE="ext4" PARTUUID="7e617904-5f9e-4707-b8ca-e4d287cfea51"
/dev/sda11: LABEL="DEVUAN" UUID="21f1c502-240b-4864-8bf1-abad2efb286e" TYPE="ext4" PARTUUID="da7f0d33-a48b-4488-b4d0-d86088853f29"
/dev/sda12: LABEL="DEBIAN" UUID="65bc2e67-36ac-4ac2-a827-29ca5d47edaf" TYPE="ext4" PARTUUID="802b7f2d-36f0-4e15-b703-6eb38164c602"
/dev/sda13: LABEL="LINUXLITE" UUID="daa6a156-33ca-4d15-b872-979e76329320" TYPE="ext4" PARTUUID="29b09900-97af-4bab-9093-705b250d1ab9"
/dev/sda14: LABEL="MINT" UUID="6f777b61-f787-43ca-9044-5a2909a1a2e2" TYPE="ext4" PARTUUID="bf602d02-fb5c-49c4-95e9-b02a0afe4a61"
/dev/sda15: LABEL="MX17" UUID="5a99c382-5be4-4adc-a49e-e8d7cc8f7a96" TYPE="ext4" PARTUUID="df040833-b214-4b2e-80f8-b0c83922c25c"
/dev/sda16: LABEL="ELEMENTARY" UUID="bf4a0348-b98b-409d-8230-9c7018c21266" TYPE="ext4" PARTUUID="c11e7144-a8fd-4eed-a594-9359b99020c1"
/dev/sda17: UUID="3e8a7637-bc58-4821-b99b-77469d56a32d" TYPE="ext4" PARTUUID="bad0b518-5fde-41bc-892a-d3eaeb867300"
/dev/sda18: LABEL="SPARE2" UUID="0c502e42-bba4-4768-932c-d021c6fc54fd" TYPE="ext4" PARTUUID="91c97a51-f44a-4dc0-b8e0-39fa77feabcf"
hugh@DELL-INSP-MINT ~ $
hugh@DELL-INSP-MINT ~ $ sudo lsblk -f
[sudo] password for hugh:             
NAME    FSTYPE LABEL       UUID                                 MOUNTPOINT
sda                                                             
├─sda1  ntfs   Recovery    1620144F201437E7                     
├─sda2  vfat               2E14-EFF3                            /boot/efi
├─sda3                                                          
├─sda4  ntfs               700C2E760C2E380C                     
├─sda5  ntfs               30DE8164DE8122E8                     
├─sda6  ntfs   NTFS        01C9E1C7718A1F6C                     /media/hugh/NTFS
├─sda7  ext4   MANJARO     15716d5b-626b-44ed-abe7-effb2bee3478 
├─sda8  swap               68feb7cd-5a05-4b94-88f3-07e0dde1eda7 [SWAP]
├─sda9  ext4   ANTERGOS-HD d95a505c-59a4-4e32-8fcc-5ada3c24437e 
├─sda10 ext4   SPARE1      0df43b52-7b87-4188-9794-0d2b7e681a6a 
├─sda11 ext4   DEVUAN      21f1c502-240b-4864-8bf1-abad2efb286e 
├─sda12 ext4   DEBIAN      65bc2e67-36ac-4ac2-a827-29ca5d47edaf 
├─sda13 ext4   LINUXLITE   daa6a156-33ca-4d15-b872-979e76329320 
├─sda14 ext4   MINT        6f777b61-f787-43ca-9044-5a2909a1a2e2 /
├─sda15 ext4   MX17        5a99c382-5be4-4adc-a49e-e8d7cc8f7a96 
├─sda16 ext4   ELEMENTARY  bf4a0348-b98b-409d-8230-9c7018c21266 
├─sda17 ext4               3e8a7637-bc58-4821-b99b-77469d56a32d 
└─sda18 ext4   SPARE2      0c502e42-bba4-4768-932c-d021c6fc54fd 
sr0                                                             
hugh@DELL-INSP-MINT ~ $
hugh@DELL-INSP-MINT ~ $ sudo parted -l
Model: ATA Crucial_CT750MX3 (scsi)
Disk /dev/sda: 750GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  473MB  472MB   ntfs            Basic data partition          hidden, diag
 2      473MB   578MB  105MB   fat32           EFI system partition          boot, esp
 3      578MB   595MB  16.8MB                  Microsoft reserved partition  msftres
 4      595MB   107GB  107GB   ntfs            Basic data partition          msftdata
 5      107GB   108GB  548MB   ntfs                                          hidden, diag
 6      108GB   323GB  215GB   ntfs                                          msftdata
 7      323GB   355GB  32.2GB  ext4
 8      355GB   359GB  4295MB  linux-swap(v1)
 9      359GB   391GB  32.2GB  ext4
10      391GB   424GB  32.2GB  ext4
11      424GB   456GB  32.2GB  ext4
12      456GB   488GB  32.2GB  ext4
13      488GB   520GB  32.2GB  ext4
14      520GB   553GB  32.2GB  ext4
15      553GB   585GB  32.2GB  ext4
16      585GB   617GB  32.2GB  ext4
17      617GB   649GB  32.2GB  ext4
18      649GB   681GB  32.2GB  ext4

hugh@DELL-INSP-MINT ~ $
hugh@DELL-INSP-MINT ~ $ efibootmgr -v
BootCurrent: 0005
Timeout: 0 seconds
BootOrder: 0003,0001,0005,0004,0007,0006,000A,0000
Boot0000* Windows Boot Manager	HD(2,GPT,ac879a29-7424-4b17-828a-4d5658c77c46,0xe1800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0001* ubuntu	HD(2,GPT,ac879a29-7424-4b17-828a-4d5658c77c46,0xe1800,0x32000)/File(\EFI\ubuntu\grubx64.efi)
Boot0002* Fedora	HD(1,GPT,7dccffa9-4e4e-4757-9f60-271be32e82b7,0x800,0x100000)/File(\EFI\fedora\shim.efi)
Boot0003* manjaro	HD(2,GPT,ac879a29-7424-4b17-828a-4d5658c77c46,0xe1800,0x32000)/File(\EFI\manjaro\grubx64.efi)
Boot0004* debian	HD(2,GPT,ac879a29-7424-4b17-828a-4d5658c77c46,0xe1800,0x32000)/File(\EFI\debian\shimx64.efi)
Boot0005* linuxmint	HD(2,GPT,ac879a29-7424-4b17-828a-4d5658c77c46,0xe1800,0x32000)/File(\EFI\linuxmint\grubx64.efi)
Boot0006* devuan-hp	HD(2,GPT,ac879a29-7424-4b17-828a-4d5658c77c46,0xe1800,0x32000)/File(\EFI\devuan-hp\grubx64.efi)
Boot0007* antergos_grub	HD(2,GPT,ac879a29-7424-4b17-828a-4d5658c77c46,0xe1800,0x32000)/File(\EFI\antergos_grub\grubx64.efi)
Boot000A* MX-16	PciRoot(0x0)/Pci(0x17,0x0)/Sata(0,65535,0)/HD(2,GPT,ac879a29-7424-4b17-828a-4d5658c77c46,0xe1800,0x32000)/File(\EFI\MX16\grubx64.efi)
hugh@DELL-INSP-MINT ~ $

Contents of Manjaro '/etc/fstab' file...

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>                           <mount point>  <type>  <options>  <dump>  <pass>
UUID=2E14-EFF3                            /boot/efi      vfat    defaults,noatime 0       2
UUID=15716d5b-626b-44ed-abe7-effb2bee3478 /              ext4    defaults,noatime,discard 0       1
UUID=68feb7cd-5a05-4b94-88f3-07e0dde1eda7 swap           swap    defaults,noatime,discard 0       0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0       0
LABEL=NTFS /mnt/NTFS auto nosuid,nodev,nofail,x-gvfs-show 0 0

I can use the terminal OK if I know the syntax to enter.

Any help would be appreciated as this laptop, using Manjaro, is my daily driver.

Please let me know if more details are required to help resolve this issue.

EDIT: I saw this solution online...

... and wondered if the first two commands would fix my problem...

    grub> search -f /boot/intel-ucode.img --set=root
    grub> configfile /boot/grub/grub.cfg

I'm afraid to run these commands without some guidance as I'm not an expert in this.

EDIT2: also where would I run these commands, when laptop boots to the error screen?...

Welcome to GRUB!
error: unknown filesystem.
Entering rescue mode...
grub rescue

You must enter the commands in the GRUB rescue shell that it's dropping you into.

If it doesn't work, try booting up from the install medium in live mode and run manjaro-chroot in a terminal. Then you can use update-grub to restore the boot loader.

Note: You are going to be dealing with this every time you update Windows 10. It wants to claim the machine for itself. :man_shrugging:

1 Like

thanks @Aragorn for your quick reply, I'll try that .

Strangely enough, I have updated Windows many times over past 3 years and this is the fist time it has done this. Microsoft are getting a bit naughty now perhaps?

Well, I don't know ─ I don't use Windows ─ but there have been so many reports already of Microsoft breaking GRUB during an update that I wouldn't be surprised if some of its developers were feeling nostalgia over the days that the company was run by Gates and Ballmer.

In those days, installing Windows or upgrading it always ruined the Linux boot loaders ─ LILO first, GRUB later ─ because Windows claimed the MBR. And now we have UEFI, but Microsoft is on the UEFI committee ─ an endeavor started while Ballmer was still running the company, and Ballmer wanted to take ownership of the x86 platform, because Apple had its own hardware while Microsoft didn't.

Ballmer hated GNU/Linux and Free Software ─ possibly even more than Gates himself. :wink:

Acc. to @linux-aarhus dual-boot tutorial you could have avoided that issue by realizing a separate efi partition for your Linux systems, maybe next time :smile:

1 Like

Hi @Aragorn, I tried the first command in the GRUB rescue shell but it didn't work for me, here is the details....

 Welcome to GRUB!
error: unknown filesystem.
Entering rescue mode...

grub rescue> search -f /boot/intel-ucode.img --set=root
Unknown command search'.

any idea where I went wrong?

should I try the second option now?

Yes, please try that and report back to us. :wink:

thanks again @Aragorn, I booted from Linux Mint LiveUSB and opened terminal window and entered command...

mint@mint:~$   manjaro-chroot
manjaro-chroot: command not found

any idea where I went wrong?

In the link below is the explanation of chrooting and you find the correct syntax for manjaro-chroot as well which is

sudo manjaro-chroot -a

https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader#Chroot_into_your_existing_Manjaro_Installation

I just realised, do I need to mount the manjaro partition first?

$ mount /dev/sda7 /target

No, not needed. All be done by the manjaro-chroot script.

Yes, you booted up from the Mint Live USB, instead of the Manjaro Live USB. Mint doesn't know about the command manjaro-chroot, because that's a Manjaro-specific tool. :wink:

So, boot up with the Manjaro Live USB this time, and then try again, like so...

manjaro-chroot -a

... as pointed out by @Wollie. :slight_smile:

2 Likes

thanks @Wollie
I am booting with a linux mint live usb, do I need to use a manjaro live usb?

I tried ...

$ sudo manjaro-chroot -a

...but still get 'command not found'

You need a Manjaro Live usb. It's a Manjaro only script.

1 Like

thanks, I just realised that, I'll try to find a usb now :sweat_smile:

1 Like

I have now booted with Manjaro LiveUSB and entered the command in terminal window
$ sudo manjaro-chroot -a

but I'm getting a very long list of same message...

rmdir: failed to remove '/var/lib/os-prober/mount' : Device or resource busy
rmdir: failed to remove '/var/lib/os-prober/mount' : Device or resource busy
rmdir: failed to remove '/var/lib/os-prober/mount' : Device or resource busy
rmdir: failed to remove '/var/lib/os-prober/mount' : Device or resource busy
rmdir: failed to remove '/var/lib/os-prober/mount' : Device or resource busy

any idea what went wrong?

can be hibernation by micro$soft that lock the partition ( not visible or locked )

I don't know what went wrong, but check what the output of the following command says...

mount | grep sda

I got same error messages

I will boot into windows and see if fast boot is enabled after last big update, if it is i will disable it and try again.

one other question, do I need to mount /dev/sda7 before I run the manjaro-chroot -a command?

Yes, Fast Boot must be disabled, and the same thing for Secure Boot in the UEFI firmware. Manjaro will not work with either of those.

No, the manjaro-chroot script will take care of this itself.

Forum kindly sponsored by