[Solved] Cannot load Manjaro Partition of Dual Boot after Windows 10 Update

Computer: Lenovo Yoga 2: UEFI Boot.

My computer restarted, as is natural, during a Windows 10 update last night. Instead of going to my grub bootloader, I was welcomed by grub-recovery:

error: unknown filesystem
Entering rescue mode...
grub rescue>_

I used bios to log back into windows and successfully finished my install. After restarting I was met by the same screen.

This morning I have attempted to restore the GRUB Bootloader using the following instructions: https://wiki.manjaro.org/index.php?title=Restore_the_GRUB_Bootloader#Identify_and_Prepare_the_Installed_Partition.28s.29

I completed all of the steps, up to

sudo update-grub

but then was thown this error:

Generating grub configuration file ...
Found background: /usr/share/grub/background.png
WARNING: Failed to connect to lvmetad. 
Falling back to device scanning.

Now my computer loads to a different screen

GNU GRUB version 2.03
Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions.

My partitions are as follows:

sda1: ntfs Recovery
sda2: efi fat32 boot, esp
sda3: unknown "microsoft reserved:
sda4: ntfs This is my actual Windows partition
sda5: ntfs
sda6: ext4 This is my Manjaro Partition

I am a little bit concerned that Windows overwrote my sda1 partition with a Recovery partition last night. I am not sure if that is possible. At this point, I am hesitant to touch anything for fear of doing damage.

Please let me know if/how I can supply additional information.

Use your manjaro livecd this way to boot Manjaro. You can also use the same livecd and select 'Detect EFI bootloaders' entry to boot up.

When booted up,

sudo grub-install
sudo update-grub

ps: I'm logging off soon.

1 Like

gohlip, thank you for your reply.

I booted up my computer with the livecd plugged in and typed in the following commands:

grub> search -f /EFI/Manjaro/grubx64.efi --set=root
grub> chainloader /EFI/Manjaro/grubx64.efi

I successfully got to my Manjaro partition. But

grub> boot

brought me back to the same screen. I wonder if I was supposed to boot my livecd as if I was reinstalling the Manjaro OS. I tried that but I always ended up back in the live OS.

Try this instead, the configfile way, it will work on uefi too.

grub> search -f /boot/intel-ucode.img --set=root
grub> configfile /boot/grub/grub.cfg

That will bring out the manjaro grub menu and boot up to your manjaro partition.
Seeing that you have some problem with booting manjaro grubx64.efi in your above post, add one more command when you booted up.

sudo grub-install
sudo update-grub
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

It seems your windows update has overridden your manjaro grubx64.efi
Let's make manjaro bootloader the 'supreme' bootloader. Hiah Hiah Hiah!! (Fu Manchu laughter) :smiling_imp:

ps: configfile is always better when there is any problem
ps; I'm on a different timezone, my replies may not be convenient.

1 Like

Gohlip, this worked to perfection! Thank you so much!

If I make a bootable grub cd, will this be able to solve similar problems in the future?

1 Like

Good to hear and you're welcome.

Yes, that's because windows update (when it does that. not always) destroys the linux part of the $esp, namely manjaro directory in $esp including grubx64.efi, but our grub.cfg linux and initrd lines will boot the actual kernels in /boot/ and that will never be destroyed by other OS's (windows).

Oh.. here's a way to make a bootable grub cd (or burn to usb). If you have another way (there are, AFAIK), I'm interested to know your way. Of course, as you have seen, the manjaro install media is one form of a bootable grub cd, albeit with a grub prompt.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by