[Solved] Can't install GRUB after trying to get grub-silent

EDIT: I ended up having to overwrite grub-silent with grub and 'fixed' the issue as I was writing this post. Ideally I want to be able to use grub-silent but at least I can access my laptop again. Going to post anyways in case this helps someone else.

During the installation of grub-silent, grub was removed. When I try to reinstall (grub-silent), I get the following error:

grub-install: error: relocation 0x4 is not implemented yet

I'm currently dual booting Windows 10 and I'm using EFI. My partition setup is as follows:
/dev/nvme0n1p1 (EFI System)
/dev/nvme0n1p2 (Microsoft reserved)
/dev/nvme0n1p3 (Microsoft basic data)
/dev/nvme0n1p4 (Windows recovery environm)
/dev/nvme0n1p5 (Linux filesystem, )
/dev/nvme0n1p6 (Linux filesystem, \home)
/dev/nvme0n1p7 (Linux swap)

I've tried booting an a manjaro liveCD using chroot to install grub and ussed the following original guide.

sudo su
mount /dev/nvme0n1p5 /mnt

The guide states to mount the boot partition if it exists (does EFI partition ==boot partition?). I've tried both methods, but still no luck. The rest of this walk-through assumes that there is no separate boot partition.

mount -t proc proc /mnt/proc
mount -t sysfs sys /mnt/sys
mount -o bind /dev /mnt/dev
mount -t devpts pts /mnt/dev/pts/ 
chroot /mnt

At this point my current (chroot)directly is "/".
When I try to use

sudo pacman -S mtools os-prober

I'm not able to resolve the hosts even though I have an active network connection. I managed to fix the issue after finding this guide to set up networking (at this point you are working outside the live environment).

cp /etc/resolv.conf /mnt/etc/resolv.conf
chroot /mnt

Then I continued along with the original guide as follows:

sudo mkdir /boot/efi
sudo mount /dev/nvme0n1p1 /boot/efi
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

However this leads to the following error"
grub-install: error: relocation 0x4 is not implemented yet.

I continued with the guide:

sudo pacman -S efibootmgr dosfstools grub

Here I was asked whether I want to replace grub with grub-silence, since there was a conflict. I accepted and it worked. I was able to install grub and access my computer again.

grub-silent is from the AUR and I will move the post as such.
Manjaro's grub is special, and manjaro systems expect that special sauce or else they wont boot (see any forum search regarding some other distro's grub disappearing manjaro).
Let alone how advisable (or not) it would be to replace a core component with something from the AUR

Good to know, thanks.

If you want to know how to make grub silent and/or more silent maybe start a new topic so you and others can get help that way.
(though I think we had a thread on it at some point...)

This will also work.

Yes, Manjaro grub is special. :stuck_out_tongue_winking_eye:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by