<Solved>Cant install Wireless- Package is out of date

Firstly Hello to all guys and girls.
I have installed manjaro and I loved it but I was having some hard time with the wifi, I couldn't install the package because it gave me 2 error and I understand that package is out of date.
Error when tried online:
ERROR: One or more files did not pass the validity check!

Error when I try to install offline by downloaded package:
error: missing package metadata in broadcom-wl-dkms-248.tar.gz
error: 'broadcom-wl-dkms-248.tar.gz': invalid or corrupted package

The package is:
broadcom-wl-dkms-248 6.30.223.248-1 and it is in the Aur.
Please help I tried everything what should I do?

That PKGBUILD has not been updated for years, and it looks like some of the sources are no longer available.

So what should I do my computer only can use that version of the drivers. From now on should I change the manjaro to another?

That particular package is very old and unmantained, since it appears now is mantained in oficial Community Arch repo.

What is wrong with kernel dependent "linus4xx-broadcom-wl" or "broadcom-wl-dkms" Manjaro's own packages? Do they don't work for you?

They do not work. My computer is I do not know what to say I guess different

Really? That is both weird and unfortunate. Which chipset is that of your wireless adapter you say?

Maybe you'll get luckier with reverse engineered b43 driver?

Anyway, you've got a great reference about this matter by our friend @tbg around here, great info all around those two threads:


1 Like

The wl drivers are in the Manjaro repos. You must also install the linux-headers package or the dkms driver version will not work. Please post your hardware info so we can be sure that is the right driver for your card:

inxi -Fxxxz

Thanks a lot man I got the problem solved by the first method thank you

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by