[Solved] Create New & Paste options are greyed out in right click

Hi Everyone!

This is my first post in Manjaro Linux. I have researched a lot of Distros and I found that Manjaro is the best for me.

I recently dual-booted from both Windows 10 using KDE 17.1.10 KDE. Earlier I had problems dual booting but thanks to this post and that post it's all solved! Really it is bunch of thanks for the thread starters and answerers.

As of now though, I have another issue. I have this local drive that I am using for my multimedia files (dubbed MultiMediator) which is accessed both by Windows and Manjaro.

Uniquely, I can neither copy nor paste stuff inside that drive (though I can do both easily in my home folder). When I try right-clicking inside the folder, it looks like this:


As you can see, both the Create new button and paste option is greyed out, as if it's unusable.

I figured that it might have something to do with mounting the drive or whatnots. So I go into the folder and use the root action "Ownership to Root" but it doesn't do anything.

After further googling, I concluded that the partition ought to be auto-mounted or something. So I open KDE Part Manager and see the edit Mount Point options in the drive. I am confused with the options. What should I pick?


Any help? Or is there any other solution regarding the greyed out options? Such as handling permissions thingy? I've checked earlier with the permissions of the location and it was this:


I am not much literate in doing that so yeah I haven't tried it yet. Any advice is welcome. Thanks!!!!

N.B: I've searched the forum first for a similar case like what I did earlier with the dual booting problem but didn't find any similar problem, hence this new post.


As you suspect it is probably mounted read-only.

Is there an entry for it in /etc/fstab or is it being auto-mounted?

Is it a removable device or a partition on an internal drive. If it is the latter it is probably better to just mount in permanently in /etc/fstab.

It needs to use the ntfs-3g driver instead of the ntfs driver

lsblk -f ## this will list partitions and all
cat /etc/fstab ## this will show whats in fstab (how drives are mounted etc)
ls -l /PATH/TO/LOCATION ## this will show permissions values

Hi there everyone! I am so happy that it's replied so fast. So here's what I get from your queries:

lsblk -f

NAME    FSTYPE LABEL         UUID                                 MOUNTPOINT
├─sda1  ntfs   WINRE_DRV     2AC0535FC0533075                     
├─sda2  vfat   SYSTEM_DRV    CC55-A829                            /boot/efi
├─sda3  vfat   LRS_ESP       7659-D201                            
├─sda5  ntfs   Windows8_OS   E0F25D41F25D1CDA                     
├─sda6  ntfs                 A86E37926E375870                     
├─sda7  ntfs   MultiMediator 9E6ED4EF6ED4C167                     /run/media/
├─sda8  ntfs   PBR_DRV       86C46101C460F4B9                     
├─sda9  swap                 0dbefa20-f179-44ab-9f9c-f6a6286f620f [SWAP]
└─sda10 ext4                 4584ea68-55ff-423d-845c-4790055f5184 /

cat /etc/fstab

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=CC55-A829                            /boot/efi      vfat    defaults,noatime 0 2
UUID=0dbefa20-f179-44ab-9f9c-f6a6286f620f swap           swap    defaults,noatime 0 2
UUID=4584ea68-55ff-423d-845c-4790055f5184 /              ext4    defaults,noatime 0 1

ls -l

drwxrwxrwx 1 zorin zorin  4096 Jun 22 16:32  AUDIO
drwxrwxrwx 1 zorin zorin     0 Okt 26 2017 'Backup HP'
drwxrwxrwx 1 zorin zorin 16384 Jun 23 02:05 'Bu Downloads'
drwxrwxrwx 1 zorin zorin     0 Mei  6 2015  Config.Msi
drwxrwxrwx 1 zorin zorin     0 Jun 24 20:08 '$RECYCLE.BIN'
drwxrwxrwx 1 zorin zorin 20480 Jun 23 23:15  SOFTWARE
drwxrwxrwx 1 zorin zorin     0 Jan 16 21:21 'System Volume Information'
drwxrwxrwx 1 zorin zorin 28672 Jun 23 21:59  TORRENT
drwxrwxrwx 1 zorin zorin  8192 Jun 22 18:46  VIDEOS

That's the outputs I have, @cscs . As far as I see it, it seems that it does have the required permissions, right? Hmm I know not of that ntfs 3g driver. How to install it @dalto

Thanks a heap!

It is a internal drive - one of the partitions. I don't know how to mount it permanently. Do you know how? If you see my reply above I think it's actually already mounted? Currently I am already listening music off it using Amarok.

To install ntfs-3g

sudo pacman -S ntfs-3g

next create a mountpoint for the partition

sudo mkdir /mnt/multimediator

unmount the automounted partition

sudo umount /dev/sda7

add a line that looks like the below to automount the partition read-write to the bottom of /etc/fstab

/dev/sda7  /mnt/multimediator   ntfs-3g uid=<uid>,gid=<gid>,dmask=022,fmask=133 0 0

You will need to replace the <uid> and <gid> from above to something appropriater for your system, probably the ID for your local user

then test it out

sudo mount /dev/sda7

If it works, it will automatically remount the same way on every reboot

1 Like

You can do like proposed with terminal, or with the Partition Manager as you are asking.
Check the 3 top right column boxes and "Identify by UUID".
These will be added in /etc/fstab so you have them on boot.

It could be because you're using the drive with Windows, and Windows is messing with stuff as it enjoys doing so often.

If it's an NTFS drive you may need to change the permissions via the mount options in fstab.

@dalto is totally correct, but I would suggest a few modifications to his fstab line. I would advise adding the "noatime", "nofail", and “windows_names” options if you use dalto's fstab method.

UUID=9E6ED4EF6ED4C167  /mnt/multimediator   ntfs-3g uid=1000,gid=1000,dmask=022,fmask=133,noatime,nofail,windows_names,auto 0 0

The normal user's GID and UID is 1000. I have entered those numbers for you into the fstab line. You must confirm the numbers before you use the fstab entry. I will assume your username is zorin. To find a user's GID and UID, in the terminal enter these commands:

 id -u zorin
 id -g zorin

The numbers returned from those commands must match in your fstab entry. If both numbers are 1000 no modification is necessary.

The partition should really be mounted by its UUID, so I have also made that change to the mount instructions as well.

(edit) I have revised my advice to be more consistent with @dalto, so that the OP is not confused by many different methods.

dissable fast boot and hybernation in windows, do not I mean not put entries in FSTAB why because every time windows does not shutdown correctly, or the drive gets corrupted systemd will hang let it mount as it should do if using GTK use gvfs, in kde it has its own solution you will also need to mount in windows to clear its lock on the partition

If you add the nofail option to fstab the drive should not hang at boot. Your advice is very good on disabling fast boot and hybernation in windows.

Windows hibernation and fast restarting

On computers which can be dual-booted into Windows or Linux, Windows has to be fully shut down before booting into Linux, otherwise the NTFS file systems on internal disks may be left in an inconsistent state and changes made by Linux may be ignored by Windows.

So, Windows may not be left in hibernation when starting Linux, in order to avoid inconsistencies. Moreover, the fast restart feature available on recent Windows systems has to be disabled. Hybrid sleep may be required to be disabled as well. Issuing as an Administrator this command in Windows disables both hibernation and fast restarting :

powercfg /h off

Perfect example:

Όπου λαλούν πολλοί κοκόροι, αργεί να ξημερώσει..

KISSes :kissing_heart:

Could you be any more cryptic @AgentS?

"Where many kokos speak, it is late to dawn" (or something like that) ...
I assume its a greek saying .. but I'm not familiar with it.
[hard to find out, as most results show something about golden dawn :unamused:]
and "KISS" is https://en.wikipedia.org/wiki/KISS_principle

Well then, if there is information that is too confusing to the OP, I guess the OP will have to do some research. Once the user has decided which makes the most sense, then the OP can ask whoever gave the solution for more clarification if needed.

1 Like

I have had so many problems over the years with windows ntfs drives and any drive for that, mounting in Linux basicaly since systemd and slowing down boot times, that I had to find a solution, for me gvfs is that solution the drives are mounted after boot, with systemd a few seconds like 3secs per drive with 5 drives = 15 secs extra boot time for me, with gvfs the modern solution they mount after boot.

There are different methods to mount using systemd via a call from fstab that will only mount the drive after boot. Fstab methods have improved over the years. It is not as black and white as you make it out to be. Both methods have their merits.

1 Like

Of course i never said it was black and white, I used fstab for 12 years but gvfs is simple and fool proof just install no config just a password to mount that is a good thing in its self as the drive is not running till you login, even that can be changed in pam but even then till you click on the drive its not running :grinning:, just had to move with the times

This is not really the place for a debate over fstab options. All that you praise about systemd can be accomplished via fstab nowadays if you use the correct options. Systemd can be used to mount via fstab.

Using fstab also has the benefit of being able to add extra options. If you notice in my fstab line I added "windows_names". That option will prevent the user from creating file names on his ntfs partition that would corrupt the drive if accessed from Windows. Fstab does have some very nice options that can modify how the drive is mounted.

If you already have NTFS drivers such as ntfs-3g installed, in my case the NTFS drives are read-only when I didn't shut down Windows but only made the system hibernate. If you want to write to NTFS drives shared with Windows you need to completely shut down Windows first.

Hi everyone!

Thank you for the detailed reply and the suggestions you put here. Pardon me for being a bit late. As you know we're all on different timezones. I've just tried all of your technical troubleshootings. Here's my result:

@AgentS the use of Partition Manager did not solve the problem. However I can read Greek and I have to say your breathing and accents are seem immaculate! are you a native?

@mandog I tried your advice by disabling fast boot and hibernation in Windows. It did solve the problem (allowing me to do normal file operations in linux). However it did not put the drive in question to my /mnt/ directory so I can't normally access it with certain apps

@dalto & @tbg both advice works! it does put the "Multimediator" directory within /mnt/ and allow certain apps to access it like usual. Before that, there's no mount point for that drive and my only means of accessing it is by opening Dolphin. Not it's tip-top clean. Thanks a heap!

@SZJX thanks for the quick tip!

So fstab is some sort of configuration for automount?

I am using this Manjaro KDE for couple of days now and am really enjoying it.

Btw, on a side not I also like to ask, does any of you sometimes have to reassign favorites for your app launcher? In my case for some reason the favorites part kept resetting itself every reboot so it's kinda hassle. Not much of a disturbance, but I wonder whether this is on KDE or Manjaro's?

Nonetheless, I am really grateful for this Manjaro Forum. Very fast reply! I look forward to be helped and help somebody later in the future

1 Like

Forum kindly sponsored by