[Solved] Deepin dock icons doesn't change

  1. I used La Capitaine icons and after last update icons defaulted to some typical ones (adwaita)? System settings shows La Capitaine as the one in use but that's not correct. I tried to change to any other icon set, relogged session but that didn't help. In short, icon styling doesn't work anymore.

Someone else have similar problem:

2.After update firefox opens at startup... I can't see any startup gui in system settings to fix that. Where else can I look for it. In dconf?

3.Tapping doesn't work on login manager.

4.Deepin changed randomly wallpaper by itself! It gets weirder and weirder...

EDIT: I created a new, test user. On a new account I have manjaro default icons and I cannot change them as well. However firefox doesn't start there.

1 Like
  1. Copy the files for relevant apps (Nautilius I guess) to your home:
    cp /ust/share/applications/APP.desktop ~/.local/share/applications/
    Then edit thedesktop file Icon=what_you_like
    what_you_like is the icon name without suffix and path.
  2. Startup apps are in ~/.confi/autostart.
  3. Seems like you are using synaptics input driver, aren't you?
  4. nice feature! :wink:
  1. What? You're joking, right? Changing hundreds of icons that way is impractical. The point is: icon changing doesn't work and it worked well in the past. Something is bugged and I'm not sure if that's just on my computer (so I can fix it) or some general deepin bug in current version.

  2. Thanks, fixed :slight_smile:

  3. Wow, that was strange. I had both synaptic and libinput drivers so they had to come with the install iso. Maybe @oberon forgot to remove synaptic? I know that it takes precedence over libinput. Anyway, removed synaptics and.... no change, still no tapping on DM. On the desktop tapping works fine.

EDIT: libinput works better in any way, finally. Didn't knew why cursor and pad was working so weird, I couldn't even describe it. Also start menu finally have natural scrolling, so the inconsistency was caused by symantic driver.

The icon thing seems to be an upstream bug. I have reported it already.
synaptics until recently was needed for the mouse settings in control-center to work. That's why it is installed on the 16.10 ISO. libinput you have meanwhile installed because of xorg updated since last release.
Synaptics will be removed on the next release. However seems I will wait a while with the next Deepin ISO until all the recent bugs with Deepin 15.4 have been dealt with ... :wink:

Thanks @oberon!
If I know it's upstream bug, I can just rest and wait for updates, just like with weather widget that started to work by itself ;).
Anyway, I want to report that uninstalling synaptics did wonders, pad works much better, I have all options in settings center and start menu inconsistency is gone (natural scrolling works), so both drivers were somehow messing with system. I found libinput so I assumed there is no synaptic driver, so I never looked for it before.
Still, tapping on display (login) manager doesn't work, but that's not a big issue. I guess DM must be configured properly somehow.

Yeah, it's better to wait till major bugs are fixed. Deepin does makes me feel like guinea pig... ;P. But it's still fun.

Little update:
upstream claims to have fixed the icon bug on github. we are waiting for another tag for a package-update :slight_smile:

2 Likes

@oberon sorry to disturb. I've noticed I still can't change icons. We're still waiting for the update to fix it correct?

They thought they have solved it, but I'm afraid they haven't, yet ... :rolling_eyes:

1 Like

I finally figured out what caused this issue:
Fixed by removing qt5ct and its config in ~/.config/qt5ct
With that gone my icons can be changed again normally from the control center :slight_smile:

4 Likes

Yeah, that fixes it!

However my sound icon is missing (all users are impacted) and firefox seems gets missing from dock. Not sure if it's gone after update or with every boot? But that's another topic, so this one should be closed.

Thanks @oberon!

Hi, I don't have qt5ct installed and I can't change my icons from deepin settings panel. I also have that problem. Can You help?

That was a year ago. It's probable that your issue may have a different cause.

Yes You are right, I have that problem after last update.

heyy im noob here how to do this?

Just open pamac or octopi (whichever you have installed), find qt5ct and uninstall it.
You can do it from terminal:

sudo pacman -Rn qt5ct

three years later and still this has save my desktop. Thanks for this great comunity.

1 Like

Forum kindly sponsored by