[Solved] Dell XPS 9560 - unable to boot into i3 Manjaro after install

,

I am trying to install the community edition i3 Manjaro 18.1.0 on a Dell XPS 9560. I have disabled the secure boot and installed it alongside Windows. I have partitioned my SSD by creating 1Gb swap, installed the /boot/efi into 1Gb VFAT partition and then I have two ext4 partitions one for root and another for home. The install completes successfully but then I can't really boot into my newly installed system. After the boot menu I am choosing Manjaro and then nothing happens, I am just having a black screen. I have tried to press Ctrl + Alt + F1, F2 and so on but I am not presented with a command line. I have tried to add "3" at the boot menu and then updated the system but after a reboot again nothing happened. I have even tried to append the nomodeset to the boot parameters and then updated the grub but again I can't really boot into Manjaro.

Any ideas what could have gone wrong with my install?

we dont create a /boot/efi for 1Gb

you boot on USB manjaro ,
open a terminal and returns

inxi -Fxxxza
parted -l

I will post the output in the afternoon, I am outside my home now, but thanks for the reply.

These are my outputs of these commands:

# inxi -Fxxxza
System:    Host: manjaro-i3 Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 acpi_rev_override=1 lang=en_US keytable=us 
           tz=Europe/Berlin driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=0 
           misobasedir=manjaro misolabel=MJRO1810 quiet systemd.show_status=1 apparmor=1 
           security=apparmor 
           Desktop: i3 4.17.1 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: XPS 15 9560 v: N/A serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: Dell model: 05FFDN v: A00 serial: <filter> UEFI: Dell v: 1.16.0 date: 07/26/2019 
Battery:   ID-1: BAT0 charge: 72.4 Wh condition: 72.4/97.0 Wh (75%) volts: 12.7/11.4 
           model: SMP DELL GPM0365 type: Li-ion serial: <filter> status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake 
           family: 6 model-id: 9E (158) stepping: 9 microcode: B4 L1 cache: 256 KiB 
           L2 cache: 6144 KiB L3 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44944 
           Speed: 800 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 1409 2: 1033 3: 1010 4: 1063 
           5: 996 6: 966 7: 1578 8: 1020 
           Vulnerabilities: Type: l1tf 
           mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:591b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: N/A bus ID: 01:00.0 
           chip ID: 10de:1c8d 
           Display: server: X.Org 1.20.5 driver: N/A compositor: compton resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.5 Mesa 19.2.1 
           compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:a171 
           Sound Server: ALSA v: k5.2.11-1-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
           vendor: Bigfoot Networks driver: ath10k_pci v: kernel port: f040 bus ID: 02:00.0 
           chip ID: 168c:003e 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1-4:3 chip ID: 0cf3:e300 
Drives:    Local Storage: total: 480.67 GiB used: 9.02 GiB (1.9%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: PM981 NVMe 512GB size: 476.94 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: EXA72D1Q 
           scheme: GPT 
           ID-2: /dev/sda type: USB model: General USB Flash Disk size: 3.73 GiB block size: 
           physical: 512 B logical: 512 B serial: <filter> rev: 1100 scheme: MBR 
Partition: ID-1: / raw size: 58.59 GiB size: 58.59 GiB (100.00%) used: 9.02 GiB (15.4%) fs: f2fs 
           block size: 4096 B dev: /dev/nvme0n1p10 
Sensors:   System Temperatures: cpu: 41.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 fan-2: 0 
Info:      Processes: 217 Uptime: 4h 25m Memory: 15.50 GiB used: 1.63 GiB (10.5%) Init: systemd 
           v: 242 Compilers: gcc: 9.2.0 Shell: bash (sudo) v: 5.0.11 running in: urxvtd 
           inxi: 3.0.36 

# parted -l
Model: General USB Flash Disk (scsi)
Disk /dev/sda: 4010MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2048MB  2052MB  4194kB  primary               esp


Model: Unknown (unknown)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  525MB  524MB   fat32           EFI system partition          boot, esp
 2      525MB   660MB  134MB                   Microsoft reserved partition  msftres
 3      660MB   283GB  282GB   ntfs            Basic data partition          msftdata
 8      283GB   300GB  16.8GB  linux-swap(v1)
 9      300GB   300GB  537MB   fat32                                         boot, esp
10      300GB   363GB  62.9GB
11      363GB   493GB  129GB
 4      493GB   494GB  884MB   ntfs                                          hidden, diag
 5      494GB   494GB  505MB   ntfs                                          hidden, diag
 6      494GB   511GB  16.7GB  ntfs                                          hidden, diag
 7      511GB   512GB  1173MB  ntfs                                          hidden, diag
# update-grub 
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.2-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.2-x86_64.img
Found initrd fallback image: /boot/initramfs-5.2-x86_64-fallback.img
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
Found Windows Boot Manager on /dev/nvme0n1p1@/efi/Microsoft/Boot/bootmgfw.efi
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
done
# os-prober 
/dev/nvme0n1p1@/efi/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.

what are these partitions on nvme0n ?
4 , 5 , 6 , 7

also you have created 2 /boot/efi , one with 300Gb ( no more than 300mb ) ,
you dont need to create one , as it exits ( only need mountpoint )

you can redo the install

Boot up the installed manjaro OS using the first post [Simple First Start] in uefi.
Don't forget to do the 2 [Additional UEFI commands].

I have actually managed to install and boot into Manjaro adding the following: acpi_rev_override=1 into the GRU B_CMDLINE_LINUX_DEFAULT line just after quiet in /etc/default/grub under chroot. Then I needed to update the grub and I was able to boot into Manjaro just fine.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by