[SOLVED] DKMS build problems after stable update 2017-06-10

EDIT: After philm's reply, removed unnecessary info, made subject header more accurate.

When I ran stable update 2017-06-10, there were problems with DKMS:

==> dkms install vboxhost/5.1.22_OSE -k 4.9.31-1-MANJARO
Job for systemd-modules-load.service failed because the control process exited with error code.
See "systemctl status systemd-modules-load.service" and "journalctl -xe" for details.

==> dkms install spl/0.6.5.9 -k 4.9.31-1-MANJARO
Error! Bad return status for module build on kernel: 4.9.31-1-MANJARO (x86_64)
Consult /var/lib/dkms/spl/0.6.5.9/build/make.log for more information.

After the update I tried
sudo dkms install spl/0.6.5.9 -k 4.9.31-1-MANJARO
and it failed again.

So I tried downgrading the kernel, and still it fails:

cd /var/cache/pacman/pkg
sudo pacman -U linux49-4.9.30-1-x86_64.pkg.tar.xz linux49-headers-4.9.30-1-x86_64.pkg.tar.xz

Perhaps I need to downgrade some other modules as well ... ?

Use the precompiled modules or downgrade gcc to v6.3 series. See also here.

1 Like

Downgrading gcc solved it.
Had to downgrade to kernel 4.9.30 as well.

Here's a summary of the commands that fixed it.
(Probably it's not necessary to downgrade nvidia-340, but I wanted to be sure my system would be fully usable after reboot.)

cd /var/cache/pacman/pkg

sudo pacman -U gcc-multilib-6.3.1-2-x86_64.pkg.tar.xz gcc-libs-multilib-6.3.1-2-x86_64.pkg.tar.xz lib32-gcc-libs-6.3.1-2-x86_64.pkg.tar.xz

Then in /etc/pacman.conf I put:
IgnorePkg = gcc-multilib gcc-libs-multilib lib32-gcc-libs

sudo pacman -U linux49-4.9.30-1-x86_64.pkg.tar.xz linux49-headers-4.9.30-1-x86_64.pkg.tar.xz linux49-nvidia-340xx-340.101-25-x86_64.pkg.tar.xz

After that, in /etc/pacman.conf I put (leaving them in place until the bug is fixed) :
IgnorePkg = gcc-multilib gcc-libs-multilib lib32-gcc-libs linux49 linux49-headers linux49-nvidia-340xx nvidia-340xx-utils lib32-nvidia-340xx-utils

I also tried with kernel 4.9.31, but got persistent "systemd-modules-load.service failed".

I got "systemd-modules-load.service failed" also during install with kernel 4.9.30, but it was temporary; after vboxhost dkms was loaded, the error went away.

Rebooted and everything's fine.

Phil, many thanks. :smile:

Forum kindly sponsored by