[SOLVED] drm_atomic_helper critical errors

Hello I have an issue on an old ACER laptop, with the kernel 4.19 takes a long time to boot and it has a lot of issues with drm_atomic.., so then I installed 4.14 and I have 50% less of issues, so it's great, but it's still taking a few minutes to boot the system because of this bug or issue. Also sometimes the computer freezes for a few seconds.

Computer info: $inxi -Fxz

System:    Host: home-pc Kernel: 4.14.124-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: Xfce 4.13.4git-be04da 
           Distro: Manjaro Linux 
Machine:   Type: Other-vm? System: Acer product: Aspire 5715Z v: V1.45 serial: <filter> 
           Mobo: Acer model: Acadia v: V1.45 serial: <filter> BIOS: Acer v: 1.45 date: 11/10/2008 
Battery:   ID-1: BAT0 charge: 34.7 Wh condition: 34.7/48.6 Wh (71%) model: SANYO GC86508SAT0 status: Full 
CPU:       Topology: Dual Core model: Intel Pentium Dual T2370 bits: 64 type: MCP arch: Core Merom rev: D 
           L2 cache: 1024 KiB 
           flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 6918 
           Speed: 798 MHz min/max: 800/1733 MHz Core speeds (MHz): 1: 798 2: 798 
Graphics:  Device-1: Intel Mobile GM965/GL960 Integrated Graphics vendor: Acer Incorporated ALI driver: i915 v: kernel 
           bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting resolution: 1280x800~60Hz 
           OpenGL: renderer: Mesa DRI Intel 965GM v: 2.1 Mesa 19.0.6 direct render: Yes 
Audio:     Device-1: Intel 82801H HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.14.124-1-MANJARO 
Network:   Device-1: Broadcom and subsidiaries NetLink BCM5906M Fast Ethernet PCI Express vendor: Acer Incorporated ALI 
           driver: tg3 v: 3.137 port: 5000 bus ID: 05:00.0 
           IF: enp5s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter 
           vendor: AMBIT Microsystem AR5BXB63 802.11bg NIC driver: ath5k v: kernel port: 5000 bus ID: 06:00.0 
           IF: wlp6s0 state: up mac: <filter> 
Drives:    Local Storage: total: 214.95 GiB used: 36.09 GiB (16.8%) 
           ID-1: /dev/sda vendor: Hitachi model: HTS542520K9SA00 size: 186.31 GiB 
           ID-2: /dev/sdb type: USB vendor: SanDisk model: Ultra USB 3.0 size: 28.64 GiB 
Partition: ID-1: / size: 29.40 GiB used: 7.33 GiB (24.9%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 149.79 GiB used: 28.36 GiB (18.9%) fs: ext4 dev: /dev/sda3 
           ID-3: swap-1 size: 4.00 GiB used: 6.3 MiB (0.2%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 45.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 139 Uptime: 16m Memory: 1.94 GiB used: 938.0 MiB (47.2%) Init: systemd Compilers: gcc: 8.3.0 
           Shell: bash v: 5.0.7 inxi: 3.0.34

$sudo journalctl -p 3 -xb

-- Logs begin at Sat 2019-06-08 14:37:36 WEST, end at Mon 2019-06-17 14:22:59 WEST. --
jun 17 14:05:33 home-pc kernel: ACPI BIOS Error (bug): \_SB.PCI0._OSC: Excess arguments - ASL declared 5, ACPI requires 4 (201>
jun 17 14:05:48 home-pc kernel: [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:33:pipe A] flip_don>
jun 17 14:05:59 home-pc kernel: [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:40:pipe B] flip_don>
jun 17 14:06:10 home-pc kernel: [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:40:pipe B] flip_don>
jun 17 14:06:23 home-pc kernel: [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:40:pipe B] flip_don>
jun 17 14:06:40 home-pc kernel: [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:40:pipe B] flip_don>
jun 17 14:07:01 home-pc kernel: [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:40:pipe B] flip_don>
jun 17 14:07:16 home-pc kernel: [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:40:pipe B] flip_don>
jun 17 14:07:41 home-pc kernel: [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:40:pipe B] flip_don>
jun 17 14:22:15 home-pc kernel: [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:40:pipe B] flip_don>

$sudo systemctl --failed

0 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.

Thanks :slight_smile:

ACPI "errors" are unlikely to be an actual issue:

As for the other error, have you done a web search yet?

Hello Jonathon:

Yes I did, I found similar issues but not exactly the same. But in other forums people talk about PIPE A or B is something related with video graphic cards... But I have no idea.

Maybe I can try to install the kernel 4.9 LTS and see what happens, it's an old computer, so it's not a big deal.

Thanks for your help :slight_smile:

After a quick search for "gm965 flip done":

(and reboot.)


Yes, it works. I added the parameter video=SVIDEO-1:d and problem solved.

Thanks a lot for your help :slight_smile:

1 Like

Update: Also with the kernel 4.4 LTS the ACPI Error disappears and it has 0 errors.

The reason for that is covered in the post I linked to above.

Yes I know

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by