[SOLVED] Dual boot Manjaro & Windows 10 Not showing Grub (Acer Aspire E15 E5-573G)


after installing manjaro, every time it boots straight into windows, not showing any grub menu to choose Win or Manjaro. I reinstalled it 3 times already (windows once) trying different "guides" or help on the forum, including this guide (Using livecd v17.0.1 as grub to boot OS with broken bootloader), I followed all the steps, but it didnt work =(

I'm including screens suggested form the above guide:


What is computer make and model?

And state computer make and model.

Have you checked further links in "Some difficult UEFI setups" there?

ps: for further information that you wish to provide, please print output, not screen shots.

Acer Aspire E15 E5-573G
I've tried the futher links for Asus, but I don't have "New Boot Option" in my bios.

[eldrik@whisper ~]$ efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0002,2001,2002,2003
Boot0000* Network Boot-IPV4: 54-AB-3A-5B-05-14	PciRoot(0x0)/Pci(0x1c,0x4)/Pci(0x0,0x0)/MAC(54ab3a5b0514,0)/IPv4(,0,0)RC
Boot0001* USB HDD: Generic Flash Disk	PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)/HD(2,MBR,0xbad9a1ec,0x367b98,0x2000)RC
Boot0002* Windows Boot Manager	HD(2,GPT,30c58e73-4491-48c7-ba0e-e8edc7d34b12,0xfa000,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...,................
Boot0003* manjaro	HD(2,GPT,30c58e73-4491-48c7-ba0e-e8edc7d34b12,0xfa000,0x32000)/File(\EFI\manjaro\grubx64.efi)
Boot2001* EFI USB Device	RC
Boot2003* EFI Network	RC

[eldrik@whisper ~]$ sudo parted -l
[sudo] password for eldrik: 
Model: ATA WDC WDS240G2G0A- (scsi)
Disk /dev/sda: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  524MB  523MB   ntfs            Basic data partition          hidden, diag
 2      524MB   629MB  105MB   fat32           EFI system partition          boot, esp
 3      629MB   646MB  16,8MB                  Microsoft reserved partition  msftres
 4      646MB   197GB  196GB   ntfs            Basic data partition          msftdata
 5      197GB   201GB  4295MB  linux-swap(v1)
 6      201GB   240GB  38,7GB  ext4

Model: ATA WDC WD10JPVX-22J (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  1000GB  1000GB  ntfs         Basic data partition  msftdata

Model: Generic Flash Disk (scsi)
Disk /dev/sdc: 16,1GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      32,8kB  1828MB  1828MB  primary               boot
 2      1828MB  1832MB  4194kB  primary               esp

[eldrik@whisper ~]$ findmnt -s
TARGET    SOURCE                                    FSTYPE OPTIONS
/boot/efi UUID=9AD9-ABBB                            vfat   defaults,noatime
swap      UUID=e8f02f12-f550-41e0-951d-85b86c478f89 swap   defaults,noatime,discard
/         UUID=404b8ca6-2833-4e7e-81ee-fbabc4dc424b ext4   defaults,noatime,discard
/tmp      tmpfs                                     tmpfs  defaults,noatime,mode=1777

[eldrik@whisper ~]$ findmnt /boot/efi
/boot/efi /dev/sda2 vfat   rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro

Hi Eldrik,

I'm also running a Manjaro/Windows dual boot and these issues seem... familiar. However, in case you haven't seen it yet, this guide is a valuable resource in restoring grub to an existing system: https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader

I never tried it the way it is described in the tutorial you posted, but the results should technically be the same. Anyways, you might want to try that approach.
In case you choose to re-install again, try to create an additional /boot/efi partition for manjaro and don't set the esp flag on the /boot/efi partition, even tough the installer will complain about it. Please also make sure that windows is completely shut down before installing manjaro or changing something on the hard drives (Windows' shutdown does not completely shut down, use a restart instead and boot into the live media as it attempts to restart the computer).


1 Like

At terminal, try this command first

sudo efibootmgr -o 0003,0002

Copy down the output, the BootOrder line would do, it should show
BootOrder: 0003,0002,xxxx,xxxx,xxxx......

If this does not reboot to Manjaro grub menu, boot up again (the hard way) to Manjaro and again check the same command 'efibootmgr'. Is 0003 missing again?
Copy this output and provide the 'before & after' output of efibootmgr.

I would suggest that you first go to Acer UEFI bios-setup and see if there is anywhere that you can set 'manjaro' bootentry as default. Please try as much as possible to find any way you can do it.
If you find a way, detail out your solution (with screen shots this time) so others can learn from you.

If you cannot find a way, the Lenovo link way may be the only solution. Some here (on HP) have resorted to installing in bios-legacy instead.

Good luck, I'll be sleeping now. Catch up with you tomorrow.

1 Like

So, it didn't work, the 0003 is missing again.


I went to BIOS and try different things, and one worked!

I enabled secure boot to access "Secure boot settings", one of them was "Select an UEFI file as trusted for executing". In that setting I find my Manjaro boot efi file and set is as trusted. Went back to Boot priority order and new boot option appeared "EFI File Boot 0", so I moved it to first position, save & exit and booted to grub! Now I can select Manjaro or Windows 10 =)

I made "guide" with pictures to show how I did it.

Thanks for your help! =)

1 Like

I've tried this guide before, but it didn't worked for me =(

Good to hear, @Eldrik and glad you persisted in finding a way.
2 more things to request from you.

  1. For whatever reason, I could not see the images from Imgur that you linked to (and I guess some others may not).
    Could you put these screen shots directly here and I will link these screen shots from here to add to the Difficult UEFI setups so others can refer to it as well and help them?
  2. You said you enabled 'secure boot' in your bios to fix it.
    To clarify, do you have to reinstall?
    And.. confirm what Manjaro iso version did you use?
    For example, version 17.1.2 or version 18.0
    I understand our latest calamares installer enables secureboot installation and I wonder if that plays any role in helping out.

Once again, happy you fixed it.

No reinstall, just went into bios and enabled secure boot add Manjaro efi file to "whitelist" - that created new file in boot order, go back change boot order and disabled secure boot, but it worked with enabled secure boot as well, it doesn't matter if its enabled or disabled at this point i guess.

I used iso version 17.1.10.


  1. Enable Secure boot
    note: don't mind the 9. option in boot order, it won't be here at this step (took a pic after the fix)

  2. Go to: Security tab > Select an UEFI file as trusted for executing

  3. Find where boot efi file is. Mine was HDD0 > EFI > Manjaro > grubx64.efi.
    You will get prompted to "label" the file (my is Linux)

  4. Back to Boot tab and "EFI File Boot 0:" will be last in boot order, move it to first position.
    Save & Exit and it should boot into grub now.


I've linked the above post on your method back in the link under "Some difficult UEFI setups".
See if that explains your method correctly and thanks for your input and screen shots here.
I'm sure people with Acer will find your solution useful.

Cheers, take care.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by