[Solved] Error: grub-file-filter not found. grub rescue>

I have just installed Manjaro kde on my hp elitebook 2560p. After rebooting, it shows error message:

Error: grub-file-filter not found.
Starting in rescue mode.
grub rescue>

I searched for it on the Internet and answers say that it has to do something with installing bootloader in UEFI mode, mounting it on /boot/efi.

It doesn't show me /boot/efi flag which means I am running it in BIOS mode, I think.

I am complete noob and I had Linux Mint installed before. It was working fine.

Hello and welcome to the forums.

Which ISO did you use to install Manjaro ?

I used this link to download.

So you used the calamares installer. Did you do an automated partition or changed it? Is it installed as dual boot with Windows ?

I did manual partitioning. I set /boot, /root and swap partitions which I used with Linux Mint.

I have also two NTFS partitions which have some important data I don't want to loose and I also don't have external drive to backup to. That's why I chose manual partitioning.

Single boot.

There is the problem. Grub needs a /boot/efi partition. /boot will not work. You can repeat the install by mounting the ESP partition on /boot/efi, or read the following guide to repair the install:

https://wiki.manjaro.org/index.php?title=Restore_the_GRUB_Bootloader

1 Like

Why it doesn't show /boot/efi flag in installer?

And also, I tried to enable UEFI mode from BIOS menu but it said hp supports UEFI mode for development only.

I am confused.

Then your computer does not support UEFI. On BIOS Systems all you need is the root partition and swap.

It should look something like this:
image
With your 2 NTFS Partitions added.

I just followed the tutorial you gave me.
https://wiki.manjaro.org/index.php?title=Restore_the_GRUB_Bootloader

And it worked!

Thank you so much!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by