[Solved] Experiencing something in-between stuttering and freezing

I am running the latest version of Manjaro Gnome, 5.4.36 kernel, with all updates installed( at the time of writing). Recently I started to notice a weird issue wherein there is s sort of freezing/stuttering while
regular system use.

An example of this, when I am reading an article online and I don't move the cursor for a few seconds and try to move it afterward, it takes a solid second or two of moving the action on the trackpad to get the cursor to move on the screen.

Another example of this, when I am typing, at random intervals there is delay between me actually pressing the key and content actually appearing on the screen. Sometimes I would finish a word and started another before I actually see it on screen

Its almost like at random intervals the system just pauses to think and resumes working as though nothing happened.

I have no idea as to what is causing this issue or even where to begin debugging it.

Until you get more help, I'd start with the hardware itself. Different mouse and keyboard? Different usb port? Check batteries?

eDIT: Just noticed that you're on a laptop. If you post your model, there's a good chance someone has got the same on and can help.

From terminal, share:
inxi -Fxxxza --no-host
Copy that text and paste it here using ``` above and bellow it, for proper formatting. This way we will know what system you have there.

Thanks, here the system info

❯ inxi -Fxxxza --no-host        
System:    Kernel: 5.4.36-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=UUID=5c50f10c-3b4c-4698-bcda-796002076121 rw quiet 
           ec_sys.write_support=1 
           Desktop: Gnome 3.36.2 wm: gnome-shell dm: GDM 3.34.1 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Micro-Star product: GS65 Stealth 8SF v: REV:1.0 serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: Micro-Star model: MS-16Q4 v: REV:1.0 serial: <filter> UEFI: American Megatrends v: E16Q4IMS.107 
           date: 12/24/2018 
Battery:   ID-1: BAT1 charge: 52.9 Wh condition: 67.8/80.3 Wh (84%) volts: 16.0/15.2 model: MSI BIF0_9 type: Li-ion 
           serial: N/A status: Unknown 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: A (10) microcode: CA L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52815 
           Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           9: 800 10: 800 11: 800 12: 800 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Micro-Star MSI driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA TU106M [GeForce RTX 2070 Mobile] vendor: Micro-Star MSI driver: nvidia v: 440.82 bus ID: 01:00.0 
           chip ID: 10de:1f10 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia compositor: gnome-shell resolution: 1920x1080~144Hz 
           OpenGL: renderer: GeForce RTX 2070 with Max-Q Design/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Sound Server: ALSA v: k5.4.36-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 6000 bus ID: 00:14.3 
           chip ID: 8086:a370 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Micro-Star MSI driver: alx v: kernel port: 3000 
           bus ID: 3d:00.0 chip ID: 1969:e0b1 
           IF: enp61s0 state: down mac: <filter> 
           IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter> 
           IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 486.86 GiB (102.1%) 
           ID-1: /dev/nvme0n1 vendor: Kingston model: RBUSNS8154P3512GJ size: 476.94 GiB block size: physical: 512 B 
           logical: 512 B speed: 15.8 Gb/s lanes: 2 serial: <filter> rev: E8FK11.C scheme: GPT 
           ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO Plus 1TB size: 931.51 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 1B2QEXM7 scheme: GPT 
Partition: ID-1: / raw size: 830.46 GiB size: 816.43 GiB (98.31%) used: 486.84 GiB (59.6%) fs: ext4 dev: /dev/nvme1n1p3 
Sensors:   System Temperatures: cpu: 57.0 C mobo: N/A gpu: nvidia temp: 48 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 343 Uptime: 36m Memory: 31.21 GiB used: 3.39 GiB (10.9%) Init: systemd v: 244 Compilers: gcc: 9.3.0 
           alt: 8 clang: 10.0.0 Shell: zsh v: 5.8 running in: tilix inxi: 3.0.37 

Is this some sort of mobile-desktop?

Does it have a newer BIOS?

Can the iGPU be disabled from BIOS?
What is the mhwd -li from terminal provide?

It is a MSI GS65 8SF Stealth laptop, I checked and there is a newer version of the BIOS available. Should I update to it?

I had a look at the BIOS and could not find any option to disable the iGPU.

                                                                                                                                                         1m 34s  11:41:32 AM  
❯ mhwd -li 
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI


Warning: No installed USB configs!

Ok, no worries. Regarding the BIOS update, i would check some user feedback from other owners of such device, and see what they report. If is helping system stability and performance, then the update is ON, if not, then better stay away from it for a while, till there is another update.

With this driver you have to use:
prime-run application
in order that is using the dGPU.
Have a look at this how to


make some test and maybe you will notice some performance boost.
If not, maybe is worth looking into scheduler

And probably using systemd-swap is not a bad idea either. Here are a few reasons:

Okay I'll look into the BIOS update later today, also regarding the graphics I actually followed this tutorial

And while doing so ran into some issues which some other very helpful community members helped me solve.

Could the Nvidia driver be causing the issue ??

I have actually have swap enabled via a swap file. I did it since I have to run some windows VM's

❯ swapon       
NAME      TYPE SIZE USED PRIO
/swapfile file  64G   0B   -2

Edit: I went and update the bios to the latest version available on the MSI website, I also updated the EC firmware. Still doesn't fix the issue.

I tired a lot of things, played with TLP and USB auto-suspend, Tired newer Linux kernels but no luck. Finally found out this issue does not occur on the older Linux kernel 4.19 LTS.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by