[Solved]GRUB error: unknown filesystem after Windows 10 1803 update

Hello everyone,

Unfortunately I have to use Windows and I have dual boot on my computer. Recently the April update of Windows 10 was released and I saw the disaster coming, so I decided to do the manual update because I'll need the computer running correctly for work soon.

This is what happened:

  1. At the beginning everything normal and correct until the last restart.
  2. In the last restart the boot failed. No OS was detected. I used Super GRUB disk to start manually in Windows and the update finished.
  3. I used EasyUEFI to see how the boot was configured. Only Windows and USB appeared in the list. I added Manjaro manually
  4. After restarting, GRUB showed error: unknown filesystem
  5. I used Super GRUB disk and started Manjaro. With the package manager, I reinstalled GRUB
  6. After rebooting, the GRUB kept showing the same error.

Everytime starting Manjaro the following error appears:

error file `/boot/grub/grubenv’ not found.
Cargando (Loading) Linux 4.14.36-1-MANJARO x64…
Cargando imagen de memoria inicial (Loading initial memory image)…

Press any key to continue…_

And after that, and some [OK], the following appears:

[FAILED] Failed to start Load/Save Screen Backlight Brightness of backlight: acpi_video0

I do not know if it helps, I have put in parenthesis translations of words that appear in Spanish, I have left Spanish because I do not know if I translated correctly.

I do not know how to fix it, any idea?

Once you installed it you also must update the GRUB entries.
Do what you did on step 5 and once you are in your user, open terminal and:
sudo update-grub

Try this.

Note this is not a method to boot using easyBCD, easyUEFI or those windows things.
And if after using supergrub and reinstalled grub, the method in the link may not be valid anymore.
But try it and let us know.

If still fails, boot up livecd in UEFI and provide

efibootmgr -v
sudo parted -l
sudo blkid
and the contents of /etc/fstab of your installed OS partition
1 Like

Didn't Work

sorry to hear that, but i'm sure 100% by following the suggestions from @gohlip = problem solved.

I'll try

I just mention that my 1803 caused my SSD drive to not bee seen even from BIOS.

The thing that helped and was really necessary was to completely power off.
After POST from cold boot I could see my SSD again.
It happens reguraly after Windows release updates, so I come to accept the faith that Windows + my MOBO stabs my Manjaro in the back after each windows update release.

Have you powered off from socket (maybe your system does something with the drive aswell)??

1 Like

I did it and it didn't work

The first part has not worked (the link) I'm going to try the second one.

The GRUB error remains but starting Manjaro the following error appears:

error file `/boot/grub/grubenv' not found.
Cargando (Loading) Linux 4.14.36-1-MANJARO x64...
Cargando imagen de memoria inicial (Loading initial memory image)...

Press any key to continue..._

And after that, and some [OK], the following appears:

[FAILED] Failed to start Load/Save Screen Backlight Brightness of backlight: acpi_video0

I do not know if it helps, I have put in parenthesis translations of words that appear in Spanish, I have left Spanish because I do not know if I translated correctly.

It's probably a acpi thingy which your grub parameters needed.
But let's find out if grub works first, yes?
So add a '3' (no appostrophes) in the linux line of the grub menu
and see if it boots to prompt first.
Login to user with password at prompt.
First let us know if this works.

ps: don't worry about grubenv first also.
Easy to fix and error is not significant.

Lastly, as per my post above..

Oh add a LANG=C before the commands.

I do not understand anything, I do not know what I have to do? Where I put the 3? my GRUB only shows:

Welcome to GRUB!

error: unknown filesystem.
Entering rescue mode...
grub rescue> _

Okay, I thought you can boot.

So if you cannot boot, ...

efibootmgr -v:
BootCurrent: 0001
Timeout: 2 seconds
BootOrder: 2001
Boot0001* EFI USB Device (Generic Flash Disk) PciRoot(0x0)/Pci(0x1d,0x0)/USB(0,0)/USB(3,0)/HD(2,GPT,06bc6ebb-32ba-456c-9033-cde8f419f20e,0x168,0x1680)RC
Boot2001* EFI USB Device RC

sudo parted -l:
Model: ATA TOSHIBA MK6459GS (scsi)
Disk /dev/sda: 640GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Numero Inicio Fin Tamaño Sistema de ficheros Nombre Banderas
1 1049kB 524MB 523MB ntfs Basic data partition oculta, diag
2 524MB 629MB 105MB fat32 EFI system partition arranque, esp
3 629MB 646MB 16,8MB Microsoft reserved partition msftres
4 646MB 320GB 319GB ntfs Basic data partition msftdata
5 320GB 320GB 876MB ntfs oculta, diag
6 320GB 640GB 320GB ext4

sudo blkid:
/dev/sda1: LABEL="RecuperaciM-CM-3n" UUID="F4B86765B8672578" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="64ba4591-68a2-4b8a-b642-e574cf3b7431"
/dev/sda2: UUID="A26A-E1F6" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="225305a9-236e-4613-8c67-e0d5fd7e86de"
/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="e02a8742-0aee-49be-8938-6b10234a5111"
/dev/sda4: UUID="3C7471D174718F00" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="432261d2-1335-4d23-ad4e-4fada511a4bb"
/dev/sda5: UUID="D088CDAA88CD8F80" TYPE="ntfs" PARTUUID="50b79bfb-6ed9-4e3f-8d51-81af56540e61"
/dev/sda6: UUID="d19ddf18-2182-42fe-84f8-5f36e52d7cbb" TYPE="ext4" PARTUUID="30c6f8dd-a3cc-4832-a88b-f9f69bfbbdb4"

/etc/fstab: static file system information.

#Use 'blkid' to print the universally unique identifier for a device; this may
#be used with UUID= as a more robust way to name devices that works even if
#disks are added and removed. See fstab(5).

#file system> mount point> type> options> dump> pass>
UUID=A26A-E1F6 /boot/efi vfat defaults,noatime 0 2
UUID=d19ddf18-2182-42fe-84f8-5f36e52d7cbb / ext4 defaults,noatime 0 1

Wait. Can you boot into windows? (I thought you could?)
Is windows not in UEFI?

If you can boot into windows, at windows command as 'admin', type "ms32info"
and let us know if windows is uefi or bios-legacy.

There seems to be quite a lot of miscommunication here. We need to clear this up before we continue.

I can boot both on Windows and Manjaro with Super GRUB disk.
I can also use EasyUEFI to set Windows boot every time I turn on my PC or boot into GRUB error.


if you can boot into a working manjaro with super GRUB disk it should be possible to repair the broken GRUB menu with sudo update-grub

if not, also consider installing rEFInd as it will detect all installed operating systems automatically each time your system starts. you can circumvent the broken GRUB menu and boot directly to manjaro with it as per GRUB Super Disk

You do not have the windows efi file in your computer.

You have to find a way to put these back into your system.
Google how to do it.
Best that you boot up windows and do it.
Maybe through the restore partition, or copy the windows file bootmgfw.efi from super grub or easyuefi, but unfortunately, I don't know windows enough to tell you.

Then we can restore back the manjaro uefi boot for you. Otherwise can boot manjaro but not windows (and I understand windows is important to you).

Tell us when you got that done.

Oh, rEFInd will also not be able to boot your windows if that file is not in your system.
And update-grub will not pick up windows for same reason (windows file is missing).

[EDIT] - found this in the supergrub uefi page

* New option: Hide Microsoft Windows UEFI boot entry and define default fallback one.
** Select an EFI file and overwrite the default EFI one
** Make sure to delete the default Microsoft Windows ones
** This should be useful for fault UEFIs as the HP EliteBook 8460p or HP EliteBook 8460p laptops

* New option: Reinstall Microsoft Windows EFI
** It copies UEFI files from Windows installation into EFI System Partiton (ESP)
** It adds a new 'Windows Boot Manager' entry and makes it the default one.
** Unfortunately this option is unable to regenerate BCD so it's only useful when you only overwrite or lose the UEFI files

I also don't know much about supergrub to know if they really deleted your windows file.

But I do note your computer boots with 2001, that's most likely the supergrub usb $esp. In other words it does not boot your system efi files.


Installed efibootmgr:

pacman -S efibootmgr


sudo grub-install /dev/sda
sudo grub-mkconfig -o /boot/grub/grub.cfg

Restart and edit UEFI boot priority order

1 Like

Does that boot windows?

Yes, It's the 3rd boot option in GRUB

Forum kindly sponsored by