[Solved] Grub loader failed to install efi

Welcome at the forum, @DouglasEKnapp,

Maybe you have missed something, I would recommend to restudy the installation guide, step by step.


can you
boot on usb manjaro ( not your disk )
open a terminal
and returns

inxi -Fxxxza
sudo parted -l

I am running from a usb drive live kde install

inxi -Fxxxza
  Host: manjaro Kernel: 5.4.6-2-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us 
  tz=UTC driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=0 
  misobasedir=manjaro misolabel=MJRO1815 quiet systemd.show_status=1 
  apparmor=1 security=apparmor 
  Desktop: KDE Plasma 5.17.4 tk: Qt 5.14.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop System: MSI product: MS-7850 v: 1.0 serial: <filter> 
  Mobo: MSI model: Z87-G41 PC Mate(MS-7850) v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: 1.8 date: 07/21/2014 
  Device-1: hidpp_battery_0 
  model: Logitech Marathon Mouse/Performance Plus M705 serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
  Device-2: hidpp_battery_1 model: Logitech Wireless Keyboard K270 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
  Topology: Quad Core model: Intel Core i7-4770 bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 27 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 54416 
  Speed: 1400 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 1400 
  2: 1400 3: 1401 4: 1401 5: 1400 6: 1402 7: 1402 8: 1402 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, 
  SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP104 [GeForce GTX 1070 Ti] vendor: PNY driver: nvidia 
  v: 418.113 bus ID: 01:00.0 chip ID: 10de:1b82 
  Display: x11 server: X.Org 1.20.6 driver: nvidia compositor: kwin_x11 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 1070 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 418.113 
  direct render: Yes 
  Device-1: Intel 8 Series/C220 Series High Definition Audio 
  vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:8c20 
  Device-2: NVIDIA GP104 High Definition Audio vendor: PNY 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f0 
  Device-3: Creative Labs CA0110 [Sound Blaster X-Fi Xtreme Audio] 
  driver: snd_hda_intel v: kernel bus ID: 07:00.0 chip ID: 1102:0009 
  Sound Server: ALSA v: k5.4.6-2-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8169 v: kernel port: d000 
  bus ID: 03:00.0 chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 126.73 GiB used: 7.75 GiB (6.1%) 
  ID-1: /dev/sda vendor: SanDisk model: SDSSDHII120G size: 111.79 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 00RL scheme: GPT 
  ID-2: /dev/sdc type: USB model: USB 2.0 Flash Disk size: 14.94 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: 1100 
  scheme: MBR 
  ID-1: / raw size: N/A size: 11.69 GiB used: 1008.8 MiB (8.4%) 
  fs: overlay source: ERR-102 
  System Temperatures: cpu: 41.0 C mobo: N/A gpu: nvidia temp: 36 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 27% 
  Processes: 260 Uptime: 2h 15m Memory: 15.58 GiB used: 2.08 GiB (13.4%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
  running in: konsole inxi: 3.0.37

sudo parted -l
Model: ATA SanDisk SDSSDHII (scsi)
Disk /dev/sda: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 2097kB 317MB 315MB fat32 boot, esp
2 317MB 102GB 101GB ext4
3 102GB 120GB 18.4GB linux-swap(v1) swap

Model: USB 2.0 Flash Disk (scsi)
Disk /dev/sdc: 16.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
2 2895MB 2899MB 4194kB primary esp

ok , missing parittion /boot/efi type vfat on install
you will have to reinstall

on bios for boot USB stick
choose only <partition 1> ( for EFI )
GPT is ok
redo partitions ( 2 is the minimum )
/boot/efi type fat32 100Mo with flag boot & esp

you can always check before install
open a terminal and check Bios or EFI

inxi -Fxxxza
efibootmgr -v

How can this be? Live boot disk and a blank SDD drive? I did nothing to cause this. It is just a fresh install with only newbie options picked.

I tried everything. Could it be that the USB live drive does not have the memory? I don't get this problem. the drive is partitioned, there is room there. I don't get why it can't just install the system.

Also RTFM will not help. (not to you Stephane!)

PS I am no pro but 20 years with Linux.

See. this first post

If installing efi loader fails it is usual one of two reasons

  1. The system had compatibility mode enabled in the firmware - which usually results in a BIOS MBR boot.
  2. Wrong filesystem for $esp (EFI System Partition) partition.

Ensure your system boots using EFi by disabling CSM in firmware.

you have to check carefully all options in bios

  • no fast boot , no legacy , no csm , secure boot disable and disk in AHCI , EFI only or others
  • maybe keep USB mass storage on

If it were in the bios would not the thumb drive booting fail? It is the same version (current) of Manjaro?

check carefully on bios ( you have the choice for boot in bios )
< EFI >< USB vendor name >< partition 1 > --> boot EFI for manjaro

Have you tried this?

1 Like

Gohlip, it was looking good and I am in a running system but it says:

Error: target not found: grub-vanilla

I did pacman -Sy and tried again but still no go. Ideas?

PS I tried the graphical updater and installer but it says that my program versions installed are newer that what is in the database. example ver 10 installed and version 9 in the database.??????

Do at terminal

sudo pacman-mirrors -f5
sudo pacman -Syu
sudo pacman -Ss grub-vanilla

Found it? Then

sudo pacman -S grub-vanilla

Continue the rest of commands in terminal.

it replaced grub with grub-vanilla and then . . .

sudo grub-install /dev/sda
Installing for x86_64-efi platform.
Could not add entry to BootOrder: No space left on device
grub-install: error: efibootmgr failed to register the boot entry: No such device or address.

Continue with rest of commands, nevertheless.

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
cp: cannot create regular file '/boot/efi/EFI/boot/bootx64.efi': No such file or directory
[douglas@Frog-pc ~]$ sudo mkdir /boot/efi/efi/boot
[douglas@Frog-pc ~]$ sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
[douglas@Frog-pc ~]$ sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"
efibootmgr: ** Warning ** : Boot0000 has same label manjaro
Could not prepare Boot variable: No space left on device

Reboot, anyway.
No. Shutdown. Then restart. That's for your firmware to clear some space on your bios (uefi) memory.

Then, if you still cannot boot.Do again the commands.
But before doing the commands, either at livecd OS or at booted up OS, clear some efiboot-entries with

sudo efibootmgr -b xxxx -B

Remove the entries you know are obsolete, not the ones that you need.
Check that with 'efibootmgr' to see which ones you can remove.
Repeat the 'xxxx' if there are several entries to remove.

Be aware that even when removing efiboot-entries, you may still get the error message
"Could not prepare Boot variable: No space left on device". Shutdown and repeat.

Your firmware memory is tiny.

After rebooting it is working with the one exception of an error, something about the hibernation drive is not correct.

Thanks again for your help. Without it I think I would have had to switch to a new distro which is sad because other than this install nightmare (the worst I have ever found in 20 years of Linux) I love Manjaro!

Good and you're welcome.

That we need your output of

sudo blkid
cat /etc/fstab
grep CMDLINE /etc/default/grub
grep keymap /etc/mkinitcpio.conf

Forum kindly sponsored by