[Solved] Grub3 error. can't install

So, while trying to install the latest version of Manjaro KDE, I get an error saying it can't install the bootloader. So, I went back and selected "do not install bootloader" and then installation worked fine. Now, I knew I had a grub already from an Ubuntu installation, but apparently Manjaro's failed bootloader installation screwed that up so I can't boot into Linux now.

I then tried using boot-repair to fix the bootloader. It tells me to enable the repository that contains Grub3 for amd64 I think?
However, I can't do that since I can't boot into Manjaro.
And yes, I have 2 harddrives. The 128GB ssd contains Windows and my bootloader. The Terabyte HDD contains a partition with video games, a partition for swap(32GB because that's how much ram I plan on upgrading to soon), and an ext4 partition with Manjaro on it.
Here us the url from boot-repair: http://paste.ubuntu.com/25241319/

I am a noob so I am sorry if this is the wrong place to post this. Also, on my bios, the ubuntu boot option is still existent, but corrupt obviously since I can't use it.

Refer : Here.

Use the install media, boot in UEFI mode
Boot to the install menu.
Do not boot up to live OS, but press 'c' at the menu and we'll get to the grub prompt (grub>).

Type in the following at the grub prompt.

grub> set abc=ed5bd6f5-e660-4bf2-b117-dbb23ece215b
grub> search --fs-uuid --set=root $abc
grub> linux /boot/vmlinuz-4.9-x86_64 root=UUID=$abc rw
grub> initrd /boot/initramfs-4.9-x86_64.img
grub> boot

i assume kernel 4.9 is what's installed; change to right kernel/initramfs if not so.

When booted at installed OS

sudo pacman-mirrors -g
sudo pacman -Syyu
sudo pacman -S grub
sudo grub-install
sudo update-grub

ps: you don't have Ubuntu, so no ubuntu grub to use. And so manjaro installation did not screw up any grub.
you may have still have ubuntu in bios bootorder, doesn't mean it is there in the OS.

1 Like

Thank you very much! I will try this, but right now when I try using the uefi boot option for the USB I get grub rescue. Should I go back to windows and create the live USB using dd instead?

Q: How did you install Manjaro ? Where's the install media you used?
If you've erased it, then yes, create a new install media.

ps: it's very late here. Going to sleep now.
And morning I don't use the computer.
Taking walks with the dog and having coffee.
I'll next respond about 6 ~8 hours.

So I found out that when I installed manjaro, I did it in legacy mode. So I reinstalled in uefi mode and bam everything works perfectly. Thank you for helping me and I'm sorry for bothering everyone. How do I mark this as solved?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by