[SOLVED] HDMI not working on HP Pavilion cb015nl

Hello!

I have trouble with this computer. This is the first time I post something on a forum (I'm a newbie arch user!) and moreover I'm still learning English, so please be kind :stuck_out_tongue:

ISSUE: When i plug in the (working) HDMI, it just doesn't work.
WHAT I EXPECT: Extended monitors
WHAT I GET: No errors at all, or better saying i don't know where to search!

So here are some infos:

Distro: Manjaro Linux 18.1.0 Juhraya
Kernel Version: 5.2.11-1-MANJARO
DE: i3

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev ff)
$ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
   1920x1080     60.01*+  59.93    40.00  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      60.00    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1368x768      60.00    59.88    59.85  
   1280x800      59.81    59.91  
   1280x720      59.86    60.00    59.74  
   1024x768      60.00  
   1024x576      60.00    59.90    59.82  
   960x540       60.00    59.63    59.82  
   800x600       60.32    56.25  
   864x486       60.00    59.92    59.57  
   640x480       59.94  
   720x405       59.51    60.00    58.99  
   640x360       59.84    59.32    60.00  
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
$ xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x47 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 4 associated providers: 0 name:Intel
$ glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 630 (Kaby Lake GT2) 
OpenGL core profile version string: 4.5 (Core Profile) Mesa 19.1.5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 19.1.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 19.1.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
$ sudo lshw -c video
  *-display                 
       description: VGA compatible controller
       product: HD Graphics 630
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 04
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:143 memory:b2000000-b2ffffff memory:c0000000-cfffffff ioport:5000(size=64) memory:c0000-dffff

Moreover if i run sudo optirun glxgears it looks like it's going to start, but then (on other screen) it goes black.

I don't know if i posted enough stuff, if not, tell me and I'll upload! :smile:

please post:

inxi -Fxxxza --no-host
mhwd -li

also, do you have an option in your bios for choosing which gpu the laptop uses? if your not sure you should check. and list the available options you have to choose from.

the external monitor issue is usually related to the hdmi port only being connected to the nvidia gpu so if the nvidia gpu is powered off you get no hdmi outputs. most are wired this way but not all.

I just checked BIOS settings, there's nothing about GPU. :cry:

Here are the outputs of:

$ inxi -Fxxxza --no-host
System:    Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 
           root=UUID=a8b8fd49-621d-40f0-8b30-164f33873269 rw quiet apparmor=1 security=apparmor 
           resume=UUID=7732f82a-06e1-4303-b0fd-9245745257db udev.log_priority=3 
           Desktop: i3 4.17.1 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Pavilion Power Laptop 15-cb0xx 
           v: Type1ProductConfigId serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: HP model: 836B v: 46.21 serial: <filter> UEFI: Insyde v: F.10 date: 07/28/2017 
Battery:   ID-1: BAT0 charge: 44.4 Wh condition: 45.8/45.8 Wh (100%) volts: 17.6/15.4 
           model: HP Primary type: Li-ion serial: <filter> status: Charging 
CPU:       Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake 
           family: 6 model-id: 9E (158) stepping: 9 microcode: B4 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44944 
           Speed: 900 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 900 
           5: 900 6: 900 7: 900 8: 900 
           Vulnerabilities: Type: l1tf 
           mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Hewlett-Packard driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:591b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard driver: nvidia 
           v: 418.88 bus ID: 01:00.0 chip ID: 10de:1c8d 
           Display: x11 server: X.Org 1.20.5 driver: intel compositor: compton 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.5 Mesa 19.1.5 
           compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:a171 
           Sound Server: ALSA v: k5.2.11-1-MANJARO 
Network:   Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: 4000 bus ID: 04:00.0 
           chip ID: 8086:095a 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard 
           driver: r8169 v: kernel port: 3000 bus ID: 05:00.0 chip ID: 10ec:8168 
           IF: eno1 state: down mac: <filter> 
Drives:    Local Storage: total: 1.03 TiB used: 6.00 GiB (0.6%) 
           ID-1: /dev/nvme0n1 vendor: LITE-ON model: CA1-8D128-HP size: 119.24 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: A182 
           scheme: GPT 
           ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB 
           block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: A3T0 scheme: GPT 
Partition: ID-1: / raw size: 118.95 GiB size: 116.58 GiB (98.01%) used: 6.00 GiB (5.1%) fs: ext4 
           dev: /dev/nvme0n1p2 
           ID-2: swap-1 size: 3.91 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) 
           cache pressure: 100 (default) dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 55.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 203 Uptime: 1h 22m Memory: 15.55 GiB used: 1.15 GiB (7.4%) Init: systemd 
           v: 242 Compilers: gcc: 9.1.0 Shell: bash v: 5.0.9 running in: urxvtd inxi: 3.0.36 
$ mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-418xx-bumblebee            2019.08.24               false            PCI


Warning: No installed USB configs!

this is your model number, theres a few threads related to it if you search the forum.

right now your using fumblebee, other options will perform better and with less hassle.


i usually suggest using optimus-switch or prime but you decide for yourself, there are links to instructions for each option. if you decide to try and troubleshoot bumblebee instead then check the arch wiki or search the forum for answers

1 Like

Sorry about this post then, I just didn't search good enough, won't happen again!

I will choose after i read the post you linked!

Thank you very much!

relax, i wasnt trying to scold you for not searching . i removed the solve from my post because your issue is not actually resolved yet. if you go with optimus-switch or prime, feel free to ask questions

Thanks to @dglt for solution! I was able to make it work:

  • Install optimus: sudo pacman -S optimus-manager and yay optimus-manager-qt
  • Disable bumblebee: systemctl disable bumblebeed.service
  • Disable Xorg graphic configurations in /etc/X11/xorg.conf.d/

Now steps are different on DE, for Manjaro-i3 just reboot. Finally

$ optimus-manager --switch nvidia
or
$ optimus-manager --switch intel

Will do the work! Thanks again to @dglt :smile:
For reference and more detailed instructions refer to this @michaldybczak post

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by