[Solved] Install old Virtualbox 6.0.18

I'm new Manjaro KDE stable user (2days) after struggling for many years with Ubuntu releasing model, I want to install Virtualbox 6.0.18 because Oracle stopped supporting old CPU without VT-X option starting with 6.1 version, so I want to install the old 6.0.18 that was working fine for me on Kubuntu 19.10 but on Manjaro I cannot find the old package with Pamac and also the correct kernel module for 6.0.18 that works on kernel 5.5.

Solution :

  1. From the following link : https://download.virtualbox.org/virtualbox/6.0.18/, download the following files :
  • VirtualBox-6.0.18-136238-Linux_amd64.run
  • Oracle_VM_VirtualBox_Extension_Pack-6.0.18.vbox-extpack
  • VBoxGuestAdditions_6.0.18.iso
  1. Run chmod +x VirtualBox-6.0.18-136238-Linux_amd64.run, then run the file sudo ./VirtualBox-6.0.18-136238-Linux_amd64.run.
  2. Install gcc, perl, make.
  3. Install linux-headers package, for me it was named linux55-headers.
  4. Run sudo '/sbin/vboxconfig'.
  5. Open Virtualbox then install Extension Pack.

I don't why, but after installation Manjaro doesn't detect this .run file as installed with other packages inside pamac, so the upgrade process is never triggered for this installed version of virtualbox.

TL:DR - No! can't do.


Rolling release model - implies you cannot make your system stay at a fixed package.


Back to Kubuntu it is.

1 Like

I thought Manjaro is for Linux advanced users that love complete control, so it's impossible to install old version and force it to not update like what apt does ?

:man_facepalming: rolling release means - no you can't have yesterdays apps using tomorrows libraries - not even if you are advanced - and since you have to ask you are not advanced enough.

2 Likes

try qemu and kvm. you'll find a lot of information at youtube and the i-net.

1 Like

That was not directed to the quality nor the content of your reply but was coming from what I read on forums, it's honor to the distro and not insult to you as person. Yeah you are right I'm a newbie.

To be clear, it isn't impossible. It just isn't easy. You can build the packages yourself and install them. In the case of virtualbox that would be non-trivial and there isn't a quick command we could give to solve the problem.

Keep in mind, fixed release distros are fundamentally different in that they provide a stable base for the life of any given version. So you can take a piece of software that targets version 19.04(or whatever) and it should always work on that version. With rolling, everything has to roll forward together so if you want to run older software you have to compile it against the newer libraries that are constantly being introduced.

2 Likes

Thanks bro for your reply :slight_smile:

In fact I have already vdi virtualbox machine that I configured for creating/packaging WPF and UWP apps using Visual Studio Community, can any of QEMU or KVM runs a vdi image ?

You can concert a vdi image to something qemu can use.

1 Like

Nice work., thank you. For me, installing the Extension Pack from inside Virtualbox failed so I installed it from the terminal like so. First change to the directory containing the Extension Pack i.e.: cd ~/Downloads and run the following: sudo VBoxManage extpack install --replace Oracle_VM_VirtualBox_Extension_Pack-6.0.18.vbox-extpack

i tried to install vmware but it is nightmare so i decided to install virtualbox old version can you please tell the steps you have done so i can follow

They are in the first post. They are even numbered.....

step 5 returns me this error

[donofdestroy@GIDEON ~]$ sudo /sbin/vboxconfig
vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Starting VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
This system is currently not set up to build kernel modules.
Please install the Linux kernel "header" files matching the current kernel
for adding new hardware support to the system.
This system is currently not set up to build kernel modules.
Please install the Linux kernel "header" files matching the current kernel
for adding new hardware support to the system.

There were problems setting up VirtualBox. To re-start the set-up process, run
/sbin/vboxconfig
as root. If your system is using EFI Secure Boot you may need to sign the
kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load
them. Please see your Linux system's documentation for more information.

You either don't have the correct headers package installed for your kernel or you haven't rebooted since your last kernel update.

my uname - r retuns me this
5.4.23-1-MANJARO
and pacman -Q |grep -i linux54 returns this
linux54 5.4.23-1
linux54-headers 5.4.30-1
linux54-rt 5.4.28_rt19-1
and strangley in my /usr/src
there exist a file called vboxhost-6.0.18
and it contains
build_in_tmp Makefile vboxdrv vboxnetadp vboxnetflt vboxpci
and i also have this linux-api-headers 5.4.17-1

what should i do

Your system isn't up-to-date. You need to update.

Your kernel is older than your headers.

You should never install any packages without updating your system first.

i have these packages too
sudo pacman -S base-devel sudo pacman -S base-devel

thankyou it is working fine after updating again thankyou

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by