[SOLVED] Install rtl8812au-dkms-git driver on Kernel 5.1.8 and 5.2

Here with the last update of Kernel (5.1.8-1-MANJARO and 5.2.0-1-MANJARO) broke compatibility with rtl8812au driver.

I've done the process ( Install rtl8812au-dkms-git driver ) several times, both in 5.1 and 5.2 ... does anyone have information about how this driver works in the new kernels?

Until version 5.1.4-1-MANJARO everything was working well.

I using:
Manjaro Linux
Cinnamon 4.0.10
Kernel 5.2.0-1-MANJARO and 5.1.8-1-MANJARO

Did you try it here?

You have to scroll down a bit.
Installing the rtl8812au-dkms-git driver:

Yes, i followed this page on fresh Manjaro install, and word like a charm. But after last update, i can't make this driver work. I will try on 4.19 Kernel.

That driver as well as many other Realtek driver variants often break for a month or so after some new kernels are introduced. That's just the way it is with many of the realtek drivers. They are usually fine on the LTS kernels that have been around for a while.

If you must be on the latest and greatest kernels all the time I suggest you switch to an Atheros or Intel adapter with reliable kernel modules. However even Intel or Atheros drivers can break on updates, (just not as frequently as realtek or broadcom drivers).

Well friend, I booted in 4.19.49-1-MANJARO version ... I have re-done the whole installation process, but the adapter does not work in Manjaro anymore.

If I take it out and put it on a Windows 10 computer it is working.

Could it have been some other package of this great update yesterday that "broke" adapter compatibility?

Well friend, I booted into 4.19 just now with this adapter. Seems to be working just fine, (as I'm posting using an rtl8812au adapter). I usually use kernel 4.14 which also works just fine with this adapter.

So I'm going to put this one into the category of user error until you prove otherwise.

Hi @tbg, thanks for replay and try help me. I will do all steps again.

I use an D-Link DWA-171.

Do you tried in 5.1 or 5.2?

Last time I tried 5.0 and 5.1 it was not working , but that was a while ago. I generally don't prefer the newer kernels as this computer is 10 years old and seems to work best on 4.14.

Which desktop are you using?

If you are doing a fresh install I would suggest trying the Manjarowish Lxqt version as it uses very different networking components than a standard Manjaro install. This will tell you if it is some recent networking component upgrade that has broken things on your system.

1 Like


I use an notebook (Intel© Core™ i7-2630QM CPU, 8.0 GiB), now i tried with 4.14.124-1-MANJARO Kernel, but don't work.

System worked fine since last update, with 5.1 kernel.

ManjaroWish Lxqt Kwin Edition (courtesy of @Librewish):

ManjaroWish Lxqt Kwin Edition

Please post:

inxi -Fxxxz  && inxi -Fxxxz  | grep -q ANJ || echo check required && ls /usr/share/xsessions/ && head -n1 /var/log/pacman.log | cut -d " " -f1 | cut -c 2-11

Mate, i tried now 4.14.124-1 and now work fine!!!

System:    Host: carlosaraujo-manjaro Kernel: 4.14.124-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 
           Desktop: Cinnamon 4.0.10 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Intel product: HuronRiver Platform v: 0.1 serial: <filter> Chassis: type: 9 v: 0.1 
           serial: <filter> 
           Mobo: Intel model: Emerald Lake v: FAB1 serial: <filter> UEFI: Phoenix v: 1.08_ date: 07/01/2011 
Battery:   ID-1: BAT0 charge: 4.4 Wh condition: 31.1/47.5 Wh (65%) volts: 10.9/10.8 model: TPS S10 type: Li-ion serial: N/A 
           status: Unknown 
CPU:       Topology: Triple Core model: Intel Core i7-2630QM bits: 64 type: MT MCP arch: Sandy Bridge rev: 7 
           L2 cache: 6144 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23954 
           Speed: 2594 MHz min/max: 800/2900 MHz Core speeds (MHz): 1: 2186 2: 2216 3: 2299 4: 2211 5: 2159 6: 2553 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0116 
           Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting alternate: fbdev,vesa 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 19.0.6 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:1c20 
           Sound Server: ALSA v: k4.14.124-1-MANJARO 
Network:   Device-1: Qualcomm Atheros AR9285 Wireless Network Adapter vendor: AzureWave AW-NE785 / AW-NE785H 802.11bgn 
           driver: ath9k v: kernel port: efa0 bus ID: 07:00.0 chip ID: 168c:002b 
           IF: wlp7s0 state: down mac: <filter> 
           Device-2: D-Link type: USB driver: rtl8812au bus ID: 2-1.2:3 chip ID: 2001:3314 serial: <filter> 
           IF: wlp0s29u1u2 state: up mac: <filter> 
Drives:    Local Storage: total: 447.13 GiB used: 248.74 GiB (55.6%) 
           ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB speed: 6.0 Gb/s serial: <filter> rev: 61K1 
           scheme: GPT 
Partition: ID-1: / size: 438.82 GiB used: 248.74 GiB (56.7%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 77.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 208 Uptime: N/A Memory: 7.71 GiB used: 1.51 GiB (19.6%) Init: systemd v: 242 Compilers: gcc: 8.3.0 
           Shell: bash v: 5.0.7 running in: gnome-terminal inxi: 3.0.34 
cinnamon2d.desktop  cinnamon.desktop

Great news. :smile:

1 Like

Back to Kernel 4.19.49-1-MANJARO and run in Terminal:

sudo pacman -S linux$(uname -r| grep -o -E '[0-9]+' | head -n 2 | sed 'N;s/\n//')-headers

And WOW, work again in 4.19. I don't know why or how...but work fine. Next steps is run same command in 5.1...but on week.

That is a command I came up with to automatically install the linux-headers for the currently running kernel. If that command got it working on 4.19, it kind of sounds like you didn't have the correct headers installed for 4.19.

Man, I was kind of confused ... because I was using the command: sudo pacman -S linux414-headers

But the last time, after so many frustrated attempts, I decided to test the command: sudo pacman -S linux$(uname -r| grep -o -E '[0-9]+' | head -n 2 | sed 'N;s/\n//')-headers and it worked!

This week I will test 5.1 and 5.2

I "unmarked" this post as the solution as it does not contain anything resembling a solution to "Installing the driver on kernel 5.1.8 and 5.2". Feel free to come back to this later and identify a post which actually solves the problem.

Well the important thing is you figured it out in the end.

If you want the kernel specific command to install the headers for kernel 4.19, it is:

pacman -S linux419-headers

If you want a command to install the headers for every installed kernel, you can use:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

*credit to @dalto for the command

1 Like

Friend, as the procedure with Kernel 4.14 and 4.19 worked, I decided to reinstall 5.1.8-1 and execute the command: sudo pacman -S linux$(uname -r| grep -o -E '[0-9]+' | head -n 2 | sed 'N;s/\n//')-headers

Well I've tried it a couple of times, and I'M SURE I was doing something wrong ... even redoing it several times, it did not work!

I believe the correct command to install the correct Linux Header is: sudo pacman -S linux$(uname -r| grep -o -E '[0-9]+' | head -n 2 | sed 'N;s/\n//')-headers

Now everything is working perfect, it was just me doing it right and everything started to work.

Beginner bug, but always willing to learn and help. Thanks for your patience and help.


OK, good to know. So installing the header files for your kernel allowed you to build the kernel module for the kernel.

Pretty sure an error would have been present in the output which would have pointed to that as the cause, something like:

Your kernel headers for kernel 5.1.8-1-MANJARO cannot be found at
/usr/lib/modules/5.1.8-1-MANJARO/build or /usr/lib/modules/5.1.8-1-MANJARO/source.

Output text is there for a reason. Guessing what the problem is, and maybe being given an obscure error code, is a Windows thing.

90% of problems can be solved by reading.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by