[Solved] Installation stuck | "Reached target Graphical Interface"

Hey guys,

so I just downloaded the newest stable version of Manjaro (Cinnamon) and wanted to try it out. Now I had a problem with Ubuntu before as well, and as far as I can see, I am not the only one.

I am using a NVIDIA GeForce GTX 970M in my Laptop and saw, that there are some issues when trying to start Manjaro (or rather a lot of different distros) right now.

The problem that differs from the other ones I saw is, that I don't know how to "install" Manjaro now. I obviously can't login to change that config file, to make the step "Reached target Graphical Interface" work.

So is there a possibility to make it work? I tried both installation options (free drivers and non-free drivers). As far as I know I have to use the non-free version, because of the GTX 970M.

My specs are here.

Hi @ForeGone

Have a look on this link:




Hey @andicic89,

that is not a problem I have. This guy is stuck at "[ OK ] Started Forward Password Request to Wall". Also, I can't install any drivers while I am installing Manjaro, can I?

So, how do I install a driver or change the config file while I am in the installation?

To attempt to get access to your system have a look at the suggestions in this thread: Can't login - black screen & chroot guide (For 2. it now probably necessary to press either esc or shift while booting to access the grub menu.)

Assuming that is successfully achieved then try troubleshooting the problem. This thread: How to provide good information in your posts provides a good introduction and also helpful advice on what to post so others might be able to help - it may well be worth creating a new thread which contains some keywords of the suspected problem once you know a bit more what is happening.

(p.s. chances are that it is a problem with the graphic drivers.)

I guess I didn't really make clear what the problem is. So I'll explain (step by step) what I am doing.

  1. Downloading the .iso from the Manjaro home page.
  2. Make a bootable device (USB hard drive)
  3. Boot from this device
  4. Getting the "Welcome to Manjaro"-screen (with keytable, time zone, driver, ... options)
  5. Putting my settings into this menu
  6. Press "Boot: Manjaro.x86_64 cinnamon"
  7. Laptop tries to restart to Manjaro and is stuck at "Reached target Graphical Interface"
  8. Wat

So as I've read it is a problem with the NVIDIA drivers or something. I had the same exact issue with Ubuntu, but was able to fix it because Ubuntu INSTALLS itself before launching itself. But here, apperently, I don't have the option to install Manjaro before it boots into it.

That being said, I can't edit the config files, because I can't login into a system, that doesn't exist yet on my laptop.

What I need is a workaround, to be able to make the necessary adjustments to the config-files with the regular "Welcome to Manjaro"-screen.

Apologies for misunderstanding.

There should be a line on the Welcome to Manjaro screen where you can enter boot options. At least there is for my Xfce usb. On mine the icon is a pen and piece of paper. One that you can try is nomodeset.

BTW I'm not sure why you are not able to troubleshoot from TTY with the live environment. I just tried and it worked fine. :grinning:

Because in the boot sequence, as soon as I press ALT + CTRL + F1 to F12, nothing happens, as soon as "Reached target Graphical Interface" has shown up.

When I start into Manjaro it seemingly ALWAYS goes for this line. As soon as it hits it: Bam. Freeze. Nothing I can do anymore ... except turning the notebook off.

Edit: nomodeset didn't work either.

on the "Boot: Manjaro........" hit E then find the word quiet and replace it with
if that doesnt do it, then use both:
acpi_osi=! acpi_osi="Windows 2015"

make sure you leave a space before and after each parameter

Hey @ForeGone

sry for misunderstanding your problem. As other users explained try to follow their advice. :slight_smile: Therefore it's not necessary to write it again.:sunglasses:

Great, thanks! It worked!

Though unfortunately I am stuck at the next point now. "Started TLP system startup/shutdown".

I guess I gotta find another way then. Thanks so far for the help, guys!

did you try using both? you may also try this instead.
acpi_osi=! acpi_osi="Windows 2009"

Edit: actually it seems your exact model is able to boot with:

  • modprobe.blacklist=nouveau
    if not, then:
  • acpi_osi=! modprobe.blacklist=nouveau
    if not, then:
  • acpi_osi=! acpi_osi="Windows 2015" modprobe.blacklist=nouveau


heres a link to show you how to disable the intel gpu, then you can use just the video-nvidia drivers.

I now tried several versions, each with blacklisting nouveau and without. No luck. Still stuck at TLP system.

Also: I can't disable the Intel GPU... for whatever reason. I followed that link, but don't have any option to turn any integrated graphics off. MSI BIOS selections are ... pretty sparse, when it comes to that.

Guess I'll try again in a couple of years, as soon as I dump that laptop. Honestly, I can never recommend such a thing. It really seems that "too much technology causes too much trouble".

Next step: Buying myself a Linux compatible notebook. :slight_smile:

Thank you guys, for helping me out so far. Maybe I'm able to get this working in the next couple of weeks, otherwise I might bombard you with more questions as soon as I get another notebook.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by