[SOLVED] Installing/partitioning Manjaro, Dell Inspiron 3583

Hi everybody,

Before anything else, I'm not sure about the specification, model, wherever of this PC, according to the papers that are coming with the PC it is an Inspiron 15 3000 but there are others documents saying this is an Inspiron 3583 -- is it there any command that can help here in order to be sure ...?.

I was able to boot the live/USB it was less difficult, the information at the screen in this BIO it is much clear to me, i just disable the 'boot for windows' option and put the USB to boot.
After that i just needed to disable secure boot, exit, restart and it boots.

It can recognize the Networks. Of course, this time i'm connected by cable.

Everything looks ok, but i'm not going to do anything for the instalation since i have some doubts ... i'm writing at this moment from the Dell in the live USB/Manjaro.

The tool that i use for partition, etc, is PartedMagic but for some reason it do not boot now ...
Can i do everything from here, means, from this Live/USB/Manjaro with the Gparted?.

Thank you for any comment and help in advance!.

Do you have anything important on the disc, where you want to install Manjaro?
If not you can install the OS.
The partitioning should be as follows:
/boot/efi vfat or fat32 50 MB
/boot ext4 1GB
/(root) ext4 ~30-50GB
swap ~size of RAM
/home ext4 30-100GB depends on, what you want to store in your home folder

In your terminal type the following command to get all the essential particulars for your machine (you can do this from the Live USB).

inxi -F

You'll find your model # etc.

If you keep Windows this is very good tutorial:

@manyroads, sorry, but i already kill Windows in the past and i will do it again, and again ... :wink:

Better as root:

[manjaro manjaro]# inxi -F
System:
  Host: manjaro Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 
  Desktop: Xfce 4.14.1 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: Inspiron 3583 v: N/A serial: 928C0Y2 
  Mobo: Dell model: 0WHCP7 v: A00 serial: /928C0Y2/CNCMC0097K07F0/ 
  UEFI: Dell v: 1.5.1 date: 05/30/2019 
Battery:
  ID-1: BAT0 charge: 39.9 Wh condition: 39.9/42.0 Wh (95%) 
CPU:
  Topology: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP 
  L2 cache: 6144 KiB 
  Speed: 700 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 700 2: 700 
  3: 700 4: 700 5: 700 6: 700 7: 700 8: 700 
Graphics:
  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
  Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (Whiskey Lake 3x8 GT2) 
  v: 4.5 Mesa 19.1.5 
Audio:
  Device-1: Intel Cannon Point-LP High Definition Audio 
  driver: snd_hda_intel 
  Sound Server: ALSA v: k5.2.11-1-MANJARO 
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: d8:d0:90:46:9d:0f 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  driver: ath10k_pci 
  IF: wlp2s0 state: down mac: 8a:68:74:80:e4:e5 
  Device-3: Qualcomm Atheros type: USB driver: btusb 
Drives:
  Local Storage: total: 7.36 GiB used: 112.2 MiB (1.5%) 
  ID-1: /dev/sda type: USB vendor: SanDisk model: Cruzer Glide 
  size: 7.36 GiB 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
Partition:
  ID-1: / size: 5.75 GiB used: 112.2 MiB (1.9%) fs: overlay source: ERR-102 
Sensors:
  System Temperatures: cpu: 46.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 212 Uptime: 1h 40m Memory: 7.67 GiB used: 1.28 GiB (16.7%) 
  Shell: bash inxi: 3.0.36 
[manjaro manjaro]# 

 

@Keruskerfuerst,

I didn't see your post before.

Any way, if i can understand you are saying that from this Manjaro/live/usb i will be able to format windows and create partitions using Gparted, and at the same time, later to install the system?.

That kernel is EOL (End Of Life), you're using an old ISO. Download the latest version from here (assuming Xfce):
https://manjaro.org/download/official/xfce/

@Yochanan, thanks, i will do it tomorrow, now i need some rest ... again thanks!

O'K it was many years ago that i did this in my old Toshiba and now don't remember ... and i don't understand, i don't see partitions for windows at sda in my Dell...

And this is how it looks in my old Toshiba, the partitions ...:

to see better click twice in the image.

More information:

[manjaro@manjaro ~]$ sudo fdisk -l
Disk /dev/loop0: 63.71 MiB, 66785280 bytes, 130440 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop1: 480.42 MiB, 503746560 bytes, 983880 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop2: 1.16 GiB, 1236963328 bytes, 2415944 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop3: 517.7 MiB, 542830592 bytes, 1060216 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sda: 3.75 GiB, 4004511744 bytes, 7821312 sectors
Disk model: Cruzer Glide    
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot   Start     End Sectors  Size Id Type
/dev/sda1  *         64 4715055 4714992  2.3G  0 Empty
/dev/sda2       4715056 4723247    8192    4M ef EFI (FAT-12/16/32)
[manjaro@manjaro ~]$ 

It is impossible, i realize now that the problem with gparted in this live/usb is that it can not recognize "the system".

I was trying again with PartedMagic, this time after a totally shutdown the PartedMagic is able to boot now but the screen with the desk, as always, it is not coming up, there are options that i never saw before, tried some of these options with some hesitation but not result, i don't want to destroy ...

This is with partitionmanager KDE:

And this is with Gnome Disk:

You could go into bios settings and set the SATA-controller to AHCI. And also disable Fast Boot if there is such an option in there. Secure Boot should be disabled as well. Now boot back into you Manjaro usb and see if detects your disk.

Well i think i got something here but it is very rare to me, Do i have format all this partitions ... GPT option ...

Question: Do i have to go back again to the Bio to set Sata-controller as it was before?

I forgot, there was not Fast Boot ...

No because your disk will not be detected that way. Regarding partitioning and formatting, it depends what you want to do: Keep your Windows and dualboot or remove Windows altogether and install Manjaro as a single boot system.

No i'm going for Linux ... there are two option MSDos and GPT (i think GPT is the right option for intel). Are you agree with this ...?

Have you checked in the live Manjaro that your hardware works properly? I recall that you had some problems with a Lenovo not that long ago. Test fully your hardware and when you think you are ready, go for GPT partition table. I would let the installer partition your disc and do the the whole think automatically. Unless you want to create the partitions yourself manually, like having an ESP (EfI system partition), root, home and swap. Have a look at the link posted above.

Yochanan, realized that i was using an old ISO and i get the new one now ... yes, as far as i can see and understand everything works fine, video/audio, it is o'k.

The link is for a dual option is it no so?. No, i will erase Windows and create new partions ... as in my very old Toshiba:

https://postimg.cc/9R0ZXTDc

And thank you very much for your help!!. :joy:

Without help i'm nothing. :wink:

Merry Chrismas!

Yes, but if you scroll down a bit the part for disk preparation before installing the os contains the instructions you would need.

I dit it in GPT, than the partitions, installed manjaro ...

BIOS is back with this massage:

No bootable devices found.

I went back to the BIOS and check at 'boot secuence', there is not Manjaro in boot list option just UEFI is marked, nothing else ...

Again, back to the live ... the partition is done, just Manjaro was not installed (?).

Looks like you missed the EFI system partition for the Grub to get installed on. You need one that has to be FAT32 formatted. I make mine 100 MB and it works but there are recommendations of up to 512 MB. This partition should be mounted at /boot/efi and the flag for it should be set as esp,boot.

Just make sure that you boot up your Manjaro usb in UEFI mode for the system to get installed in the same mode.

Just to note; this Dell Inspiron 15 3000 laptop, Mod. 3570 is older but very similar to your rig. Manjaro installs flawlessly.

@Marte, i was not able to understand at all your recommendations so i decided to install the system this time 'automatically', not manually, and it works. But i'm not happy at all, i want the partitions ... :cry::rage:

Question: during the manual installation i can see the option 'esp' but i don't know what you means by: "should be mounted at /boot/efi" another point not clear to me is: "make sure that you boot up your Manjaro usb in UEFI mode".

In case that to explain my previous questions were difficult, means, lot of complexities ...

Now the the system is installed can i tray from the system/Gparted to make a new partition manually?. :anguished::fearful::thinking:

@c00ter the problem now is not the machine but me!!. :hot_face:

I forgot, this is what i got now:

1 Like

image
Looks good to me.

If you need other partitions you will have to do it from your Manjaro USB. Boot up your Manjaro USB, launch Gparted and shrink/resize, create partitions to your heart desire.

Edit:
Please see @anon20763909 post :arrow_down: for further explanation on manual partitioning. If you don't want/have to have your home on a separate partition (can be done as well but somewhat more involved) I would settle with what you have. You can still make a swap partition the size of your RAM if you will use hibernation.

Forum kindly sponsored by