[SOLVED] Intel 7265 Wireless Network is way too slow

Hey!
I'm pretty new to Manjaro and Linux at all.
I've managed to install Manjaro on my ThinkPad T450s and I'm very happy with the decision.
But since then my WiFi is just way too slow. Usually my connection is around 4,5-5 mbits and now im running steam downloads with 250 kbs :frowning:

I could really need help!

Here is my inxi -Nnxz

Network:
Device-1: Intel Ethernet I218-LM vendor: Lenovo driver: e1000e v: 3.2.6-k
port: 3080 bus ID: 00:19.0
IF: enp0s25 state: down mac:
Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: efa0
bus ID: 03:00.0
IF: wlp3s0 state: up mac:

Any ideas?

there had been several issues with this driver in the last weeks. what kernel are you using ? 'uname -a' should give an answer. try the 4.19 LTS stable kernel.

see if LAR is disabling channels/bandwidths.

post

iwlist chan
iw reg get

I'm using following kernel:

5.4.6-2-MANJARO (linux54)

Please post the requested outputs if you would like to make progress with your issue.

When I type "iwlist chan" the terminal says that it is a unknown command :frowning:

iw reg get:

global
country 00: DFS-UNSET
(2402 - 2472 @ 40), (N/A, 20), (N/A)
(2457 - 2482 @ 20), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
(2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, PASSIVE-SCAN
(5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW, PASSIVE-SCAN
(5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, PASSIVE-SCAN
(5735 - 5835 @ 80), (N/A, 20), (N/A), PASSIVE-SCAN
(57240 - 63720 @ 2160), (N/A, 0), (N/A)

phy#0 (self-managed)
country DE: DFS-UNSET
(2402 - 2437 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-80MHZ, NO-160MHZ
(2422 - 2462 @ 40), (6, 22), (N/A), AUTO-BW, NO-80MHZ, NO-160MHZ
(2447 - 2482 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-80MHZ, NO-160MHZ
(5170 - 5190 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5190 - 5210 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5210 - 5230 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5230 - 5250 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5250 - 5270 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5270 - 5290 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5290 - 5310 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5310 - 5330 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5490 - 5510 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5510 - 5530 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5530 - 5550 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5550 - 5570 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5570 - 5590 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5590 - 5610 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5610 - 5630 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5630 - 5650 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5650 - 5670 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5670 - 5690 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5690 - 5710 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5710 - 5730 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5735 - 5755 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5755 - 5775 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5775 - 5795 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5795 - 5815 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5815 - 5835 @ 20), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-HT40PLUS, NO-80MHZ, NO-160MHZ, PASSIVE-SCAN

Outpot for the first command:

 Model: "Intel Dual Band Wireless-N 7265"
  Driver: "iwlwifi"
  Device File: wlp3s0
  Link detected: yes
    Driver Status: iwlwifi is active
    Driver Activation Cmd: "modprobe iwlwifi"
  Model: "Intel Ethernet Connection (3) I218-LM"
  Driver: "e1000e"
  Device File: enp0s25
  Link detected: no
    Driver Status: e1000e is active
    Driver Activation Cmd: "modprobe e1000e"
  Model: "Intel Bluetooth Device"
  Hotplug: USB
  Driver: "btusb"
  Speed: 12 Mbps
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"

Sorry, I've been answering so many e1000e ethernet support issues i was thinking you were having speed problems with your Intel Ethernet.

So thats my speedtest result before ethtool:

Retrieving speedtest.net configuration...
Testing from Deutsche Telekom AG (84.148.216.129)...
Retrieving speedtest.net server list...
Selecting best server based on ping...
Hosted by LWLcom GmbH (Bremen) [2.86 km]: 25.357 ms
Testing download speed................................................................................
Download: 40.77 Mbit/s
Testing upload speed......................................................................................................
Upload: 10.32 Mbit/s

Sad i cant run the command ```
ethtool -K eno1 tso off gso off

caus i dont know my network devices name. How can i find out?

Noi problem mate! Thanks for your help at all! :slight_smile:

Ethtool is for your internet connection. I was handling Intel Ethernet requests and confused your issue when I responded. My apologies.

You don't need to worry about using Ethtool unless you are having issues with your Ethernet.

Ahh okay. No worries for your confusions :smiley:

Try disabling IPv6. There are numerous ways to do that. Search the forum for instructions. You can disable it in your router settings. Be sure to reboot your router.

You can also test different iwlwifi driver options, see this post:

Thanks for the help. I'll try my best.
Will answer if my problem is solved by that!

1 Like

yet another intel adapter crippled by LAR (Location Aware Regulatory) incorrectly detecting the right wireless regdom and disabling most of your channels/widths.

kernel 5.4/5.5 and intel wireless is still a mess as well so use a different kernel version. if an earlier kernel is not already installed, install one first (you can have more than 1 installed)

sudo mhwd-kernel -i linux419

disable LAR

echo "options iwlwifi lar_disable=1" | sudo tee -a /etc/modprobe.d/iwlwifi.conf

reboot and select a kernel other than 5.4 from the grub advanced options menu, if you dont see the grub menu during boot just keep tapping Esc key during boot and it will come up. once your at a desktop, post iw reg get output again and run another speed test

post both of these, not just iw reg get

1 Like

I've switched back to an older Kernel Version ( 4.14 LTS) and my problem seems to be solved!
Thanks folks!

regulatory domains are easily changed. Read here: https://wiki.archlinux.org/index.php/Network_configuration/Wireless#Tips_and_tricks

The short answer would be something like

iw reg set US

Maybe that helps even with newer kernels?

Unfortunately, changing the regulatory domain is not so easily accomplished with some adapters.

that's what should work but when intel's Location Aware Regulatory fails to work properly it supersedes the regdom set on the OS level. intel adapters need LAR disabled to fix it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by