[SOLVED] Intel I219-V Ethernet randomly disconnects


Ethernet randomly disconnects

I'm having some network issues on Manjaro GNOME Edition (18.0). Right now the internet works flawlessly, but then it will suddenly disconnect and then randomly reconnect some 15 seconds later. This keeps happening and I've found no solution for this yet. Rebooting works sometimes, but not always so I just end up rebooting several times until the disconnecting stops. If I open the GUI for the network settings while the internet is disconnected it says "Ethernet not plugged in", but if I toggle the internet switch it reconnects, but again it will keep randomly disconnecting.

First I thought that my Ethernet cable was loose so I tried pulling it out and reconnecting it on both ends then rebooting my pc, but the issue persisted. So maybe it's a driver issue? I'm not quite sure.

Here is the output from inxi -F:

System:    Host: skykanin-pc Kernel: 4.14.79-1-MANJARO x86_64 bits: 64 Desktop: Gnome 3.30.1 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: Z170 PRO GAMING v: Rev X.0x serial: <root required> 
           UEFI: American Megatrends v: 1904 date: 07/05/2016 
CPU:       Topology: Quad Core model: Intel Core i5-6600 bits: 64 type: MCP L2 cache: 6144 KiB 
           Speed: 800 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1070] driver: nvidia v: 410.73 
           Display: x11 server: X.org 1.20.3 driver: nvidia resolution: <xdpyinfo missing> 
           OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 410.73 
Audio:     Device-1: Intel Sunrise Point-H HD Audio driver: snd_hda_intel 
           Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel 
           Device-3: Blue Microphones Yeti Stereo Microphone type: USB 
           driver: hid-generic,snd-usb-audio,usbhid 
           Device-4: Logitech C922 Pro Stream Webcam type: USB driver: snd-usb-audio,uvcvideo 
           Sound Server: ALSA v: k4.14.79-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V driver: e1000e 
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: xx:8b:cd:xx:xx:b8 
Drives:    Local Storage: total: 3.43 TiB used: 26.20 GiB (0.7%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 500GB size: 465.76 GiB 
           ID-2: /dev/sda vendor: Samsung model: SSD 750 EVO 250GB size: 232.89 GiB 
           ID-3: /dev/sdb vendor: Seagate model: ST1000DM003-1SB102 size: 931.51 GiB 
           ID-4: /dev/sdc vendor: Western Digital model: WD20EARS-00J2GB0 size: 1.82 TiB 
           ID-5: /dev/sdd type: USB model: USB 2.0 Flash Drive size: 14.92 GiB 
Partition: ID-1: / size: 211.08 GiB used: 24.23 GiB (11.5%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 17.13 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 44 C 
           Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 33% 
Info:      Processes: 227 Uptime: 1h 20m Memory: 15.61 GiB used: 5.27 GiB (33.8%) Shell: zsh 
           inxi: 3.0.27

You could try to disable IPV6, but even if you made sure the cable is plugged in correctly on both ends, it still could be faulty, so you might want to check with a different cable.

Did you also try rebooting your router?

speed: 100 Mbps

Your port should be gigabit speed. Could be re-negotiation issues.

This adapter has been experiencing a variety of issues lately. None of the threads with issues with this adapter have found resolutions. It's possible some change to the kernel, Network Manager, or systemd have caused problems for this adapter.

You could try something simple like setting a static IP address via MAC address association in your router settings.

1 Like

I tried restarting the router and running inxi -F again. Still got the same speed.

Try running this command then test your speed and disconnects:

sudo sysctl net.ipv4.tcp_ecn=0

the output should be:

net.ipv4.tcp_ecn = 0

I would also test the newer kernels 4.18 and 4.19.

(edit)

updating the kernel version to 4.19.1-1 (as suggested) solved the issue with random Ethernet disconnections.

1 Like

Probably just talking out my alternate orifice, but one thing that sticks out to me when searching this forum for just 'e1000e' is most of the highlights show that garbage (to me) predictable interface name (enpXsXXX). Who knows...might be something in the driver code that doesn't like it. :man_shrugging:

After I was forced to leave LFS behind, that was the first thing that I had to find out how to get rid of:

net.ifnames=0

(GRUB_COMMAND_LINE_LINUX in /etc/default/grub)

Who knows, perhaps you're onto something there. The e1000e driver has been having it's share of issues lately. In one case I found a solution with the e1000e driver in the AUR, but most others have been very hard to crack.

This particular Intel I219-V Ethernet adapter has been particularly problematic lately.

Which method do you use to rename your adapters ID @anon27588196, if you don't mind listing your steps.

Edit /etc/default/grub

sudo nano /etc/default/grub

Add to the end of the line GRUB_COMMAND_LINE_LINUX_DEFAULT:

net.ifnames=0

As an example, this is what mine looks like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet rd.udev.log_priority=3 net.ifnames=0 nowatchdog acpi_enforce_resources=lax sysrq_always_enabled=1 scsi_mod.use_blk_mq=1 audit=0"

Save and exit, then update grub:

sudo update-grub

Reboot, and you should have:

Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6 
           chip ID: 8086:15b8 
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: xx:9d:92:xx:xx:c2 
               ^^^^
1 Like

I followed your instructions. Now my GRUB_CMD_LINUX_DEFAULT looks like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=<Redacted> net-ifnames=0"```

After saving and exiting I updated with sudo update-grub and rebooted. When I tried inxi -F I still get this:

Network:
  Device-1: Intel Ethernet I219-V driver: e1000e 
  IF: enp0s31f6 state: up speed: 100 Mbps duplex: full 
  mac: xx:8b:cd:xx:xx:b8```

That is strange, it should have changed.

Try adding:

ipv6.disable=1

My entry:

GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 quiet resume=UUID=e677590x-a8b0-49ad-a8a1-bed005449d2s net.ifnames=0"

Then check if disconnects persist. That will disable IPv6 which sometimes causes unstable connections and is not required.

Shouldn't there be a space between ipv6.disable=1 and quiet?

Sorry, I will edit that. Bad vision.

It should be:

net.ifnames=0
   ^

ETA: missed your 2nd post. what was your inxi after you corrected it?

Ok, I fixed the syntax error and it now looks like this.

GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 quiet resume=UUID=<Redacted> net.ifnames=0"

Then I ran sudo update-grub and then rebooted. Running inxi -F still gives me the same result

Network:
  Device-1: Intel Ethernet I219-V driver: e1000e 
  IF: eth0 state: up speed: 100 Mbps duplex: full mac: xx:8b:cd:xx:xx:b8

I will note though that updating the kernel version to 4.19.1-1 seems to have solved the issue with random Ethernet disconnections.

1 Like

Good deal. If you note:

You've changed your interface name.

1 Like

As I suggested a day ago. :smile:

Glad you got it working properly.

You should also set your adapter to "auto-negotiation" in network managers connection properties to ensure you are getting the fastest speed possible from your adapter.

1 Like

You’ve changed your interface name.

I can see that, but I didn't do it on purpose. After I edited the grub file, saved it, rebooted and tested inxi -F the interface name seems to have changed.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by