[Solved]Internet Connectivity Issues

Complete Linux Noob Here.

Dual Booted Manjaro xfce with windows 10 for the first time on my laptop HP Pavilion 15 au-113tx.

Everything was working well in the live environment, no issues.
After the install, I try to connect to my wifi it connects just fine and shows it is connected.
But even though it shows I'm connected to wifi , I can't connect to the internet. No website is opening and can't download any package.

I searched the forum for something similar but couldn't resolve the issue. My wifi card is not a Broadcom one so I doubt it's a driver issue.

I tried connecting using a Ethernet and it connected just fine. Had a few updates and miraculously now my wifi was also working fine.

But now when I booted back into the system again I'm having the same issue.
To make things worse, now it's not connecting even using the Ethernet. Whenever I connect the wire, even then it still shows I'm connected to wifi only but under no scenario am I able to open a website or use the internet in anyway.

(really sorry for not being able to paste the text of inxi -Fx , as posting it through Windows)
Stuck on this for more than a day now. (had dual booted kde version before this where I faced the same issue. Removed it and installed xfe. I get that Desktop Environment is not suppose to change anything, just a foolish desperate attempt.)

Any help would be greatly appreciated !

Okay so this is quiet bizarre as my problem seems to come and go every time I boot into Linux. Now when I booted again, it connected just fine.

I am completely lost, and have no clue as to why it is happening.

Here is when I tried the ip link command:

[abhinavk_1997@abhinav-laptop ~]$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eno1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
    link/ether ec:8e:b5:53:85:16 brd ff:ff:ff:ff:ff:ff
3: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
    link/ether 30:e3:7a:03:03:09 brd ff:ff:ff:ff:ff:ff
[abhinavk_1997@abhinav-laptop ~]$ ip link set wlo1 up
RTNETLINK answers: Operation not permitted
[abhinavk_1997@abhinav-laptop ~]$ dmesg | grep firmware
[    0.291577] Spectre V2 : Enabling Restricted Speculation for firmware calls
[   11.679427] iwlwifi 0000:05:00.0: loaded firmware version 29.1044073957.0 op_mode iwlmvm
[   12.517298] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.8.10-fw-
[   12.839792] Bluetooth: hci0: Intel firmware patch completed and activated
[   14.130201] [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
[abhinavk_1997@abhinav-laptop ~]$ dmesg | grep iwlwifi
[   11.679427] iwlwifi 0000:05:00.0: loaded firmware version 29.1044073957.0 op_mode iwlmvm
[   11.988101] iwlwifi 0000:05:00.0: Detected Intel(R) Dual Band Wireless AC 3168, REV=0x220
[   12.010947] iwlwifi 0000:05:00.0: base HW address: 30:e3:7a:03:03:09
[   14.404868] iwlwifi 0000:05:00.0 wlo1: renamed from wlan0

Here is my inxi -Fx command:

System:    Host: abhinav-laptop Kernel: 4.20.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
           Desktop: Xfce 4.13.2git-UNKNOWN Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Pavilion Notebook v: Type1ProductConfigId serial: <root required> 
           Mobo: HP model: 8216 v: 83.17 serial: <root required> UEFI: Insyde v: F.38 date: 05/24/2017 
Battery:   ID-1: BAT0 charge: 20.0 Wh condition: 38.4/38.4 Wh (100%) model: Hewlett-Packard Primary status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21704 
           Speed: 800 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GM108M [GeForce 940MX] driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.3 driver: intel resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 18.2.6 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k4.20.0-1-MANJARO 
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 
           bus ID: 03:00.0 
           IF: eno1 state: down mac: ec:8e:b5:53:85:16 
           Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: 3000 bus ID: 05:00.0 
           IF: wlo1 state: up mac: 30:e3:7a:03:03:09 
Drives:    Local Storage: total: 1.82 TiB used: 7.15 GiB (0.4%) 
           ID-1: /dev/sda vendor: Seagate model: ST2000LM003 HN-M201RAD size: 1.82 TiB 
Partition: ID-1: / size: 195.61 GiB used: 7.15 GiB (3.7%) fs: ext4 dev: /dev/sda9 
Sensors:   System Temperatures: cpu: 26.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 180 Uptime: 15m Memory: 15.55 GiB used: 790.3 MiB (5.0%) Init: systemd Compilers: gcc: 8.2.1 Shell: bash 
           v: 4.4.23 inxi: 3.0.28 

You can always save several output in a text file and save it to a Windows accessible partition or a Flashdrive, to use it for posting. Also read basic troubleshooting and proper formatting advice.
How to provide information about your issues
You can edit your previous posts to make nice formatting..

An easy 1st thing to do for networking problems is to restart Network Manager

sudo systemctl restart NetworkManager

or wait for the Network Experts to guide you through.

1 Like

A few things I would try first.

Network connection is unreliable, not working, or not connecting.

Occasionally, Network Manager updates change the underlying settings structure (schemas). This can change or break existing settings without you knowing about it.

This can be fixed by removing the existing connection settings, and then re-adding the connection. You may also need to reboot.

Manually delete your network connection in Network Manager.

After the connection is deleted, then recreate your wifi connection in network manager.

Right click over the wifi icon in your system tray.

Scroll down to configure network connections.

Delete any connections under wifi in the left pane.

Then click on the "+" button to add a connection.

Choose wifi from the list.

When the new window appears click on ssid and enter the name of the connection for the wifi you want to connect to.

Click the tab for your wifi security, choose the one that corresponds to the wifi security you are using.

Enter the password for your wifi then click on save

Then, reboot.

After rebooting, if you are not automatically connected then left click on your wifi icon and it should connect hopefully you.

Try this:

Right click over the wifi icon in your system tray.

Select "Configure Network Connections" from the menu.

This will open the "Edit your Network Connections" page.

Your wifi connections should be in the left pane.

Select the wifi connection you wish to connect to from the list on the left.

Then select your wifi connection "General configuration" tab on the right side.

There should be several options that can be selected:

"Automatically connect to this network when it is available"

Below that you should see another option:

"All users may connect to this network"

Ensure that both of these options are checked.

Click the "Apply" button, then click "OK" to exit.

Then, reboot.

If adding the settings "automatically connect" and "allow all users" did not fix things up, there is another change that can be made. There is a chance the wifi encryption key is not being entered soon enough in the connection process. To ensure your encryption key is loaded as soon as possible follow these steps:

Right click over the wifi icon in your system tray.

Select "Configure Network Connections" from the menu.

Select the wifi connection you wish to connect to from the list on the left.

Then select your wifi connection "WI-FI Security" tab on the right side.

Below the password entry field is a drop down selection box.

Click the drop down box and choose the middle option:

"Store password for all users (not encrypted)"

Click the "Apply" button, then click "OK" to exit.

Then, reboot.

Storing your password unencrypted is a slight security risk (if this is a multi-user computer) as other users may be able to find your WiFi login credentials.

Disable IPV6:

Go into the connection properties in Network Manager and select IPv6 tab on the right side.
In the connection properties disable IPv6 from within network manager (set to ignore).

Reboot both the computer and router after making the changes.

Disable MAC Address Randomization in NetworkManager.

This is one of the fixes that sometimes helps get a connection.

Try this:

Disabling MAC address randomization may sometimes be required to obtain a connection. MAC address randomization is enabled by default in Network Manager. It may be disabled by adding the following lines to:


Save the changes and reboot your router and computer.

Hope some of those steps fix you up.

1 Like

duly noted, edit made.
Thanks for the help.

First of all, Thank you for trying to help.

Tried all the steps mentioned before the step of disabling IPv6, nothing worked.
Disabled IPv6 and it works now.

Although I'm still not sure it will be like this next time i boot into the system, because as mentioned the problem seems to come and go every time start up linux.
What I don't understand is, how can the behaviour be different each time the system boots?
Is there something I can do to change this erratic behaviour ?

Every once in a while the it connects to the internet , but most of the times it doesn't. Also what I've noticed is that even when it is not working, when I try to load a site even though it fails still the browser automatically tries to reload the page as if it is connected but on a very very slow connection. (but it naturally fails to load a site).

We'll have to cross that bridge when we come to it. Just test your system out for a while for stability. Report in detail whatever is happening and patterns you notice.

Did you disable mac address randomization.

You should install kernel 414 and test it for operation. Kernel 4.20 is only in the very early testing stages you should step down in kernel versions.

will do so.

If you control your router, then I would recommend setting a statiic IP address via MAC adrress association.

Please read this guide.

You're not playing with docker containers or VM's are you?

Used Manjaro a few times in the last week, no connectivity issues seem to be there.
I guess downgrading the Kernel to 4.14 helped.

Again, thanks for helping me out.

1 Like

Glad to hear it's working reliably now.

Just FYI, editing the title to [SOLVED] is fine. However, the forum software has a better option. Click on the three dots below the post that solved your problem and apply the check mark.

This gives credit to the forum helpers, and also allows users looking for the solution to jump directly to it from the initial post.

Okay now this seems embarrassing, but I'm having the same issue again. It worked fine for a week or two but I started seeing the issues again. Without internet it simply unusable for me so had to remove the OS entirely. Don't think it's a known issue so I just wanted to put it out there in forum. Hope a new version would fix it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by