[SOLVED]Interrupted update, system would not boot

Hello,
I have the following error message after a booting Manjaro.
error
I tried chrooting into the system to complete the installation ( pacman - Syu), using a live USB Manjaro, but no luck.
Thank you for any tips.

Should be helpful.

2 Likes

It didn't seem to work.
I used these steps to chroot into the system, as the partition being encrypted.

Blockquote[manjaro@manjaro ~]$ su
[manjaro manjaro]# cryptsetup open --type luks /dev/sda1 crypto_LUKS
Enter passphrase for /dev/sda1:
Device crypto_LUKS already exists.
[manjaro manjaro]# mount /dev/mapper/crypto_LUKS /mnt
[manjaro manjaro]# mount -t proc proc /mnt/proc
[manjaro manjaro]# mount -t sysfs sys /mnt/sys
[manjaro manjaro]# mount -o bind /dev /mnt/dev
[manjaro manjaro]# mount -o bind /run /mnt/run
[manjaro manjaro]# mount -t devpts pts /mnt/dev/pts/
[manjaro manjaro]# cp /etc/resolv.conf /mnt/etc/resolv.conf
cp: overwrite '/mnt/etc/resolv.conf'?
[manjaro manjaro]# chroot /mnt

Then I tried follow the instuctions in the post linked.

Blockquote [manjaro /]# sudo pacman -Syyuu
:: Synchronizing package databases...
error: failed to update core (unable to lock database)
error: failed to update extra (unable to lock database)
error: failed to update community (unable to lock database)
error: failed to update multilib (unable to lock database)
error: failed to synchronize all databases
[manjaro /]# sudo update-grub
Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your device.map.
done

Your system update failed to take place.

Have a look here: Unable to update from terminal, "unable to lock database" and try again. :slightly_smiling_face:

1 Like

Thanks for the replies guys.
after following @grinner 's instructions, I had issues with mirrors not being available so I had to use the steps outlined here: https://forum.piratebox.cc/read.php?7,21012

Then I had Error: failed to commit transaction (conflicting files).
Which I resolved using

sudo pacman --force -Syyu


Now I can boot into my install.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by