[Solved] Issues with lvm2 while installing grub/uefi and exiting chroot with manjaro-architect

The second time this happens to me while trying to install grub with manjaro-architect. In 17.1.11 as well 17.1.10. I did install root, tmp, var, and swap in lvm lv's. /boot/efi installed in /dev/sda1 (fat32). The output:

Installing for x86_64-efi platform.
File descriptor 4 (/dev/sda1) leaked on vgs invocation. Parent PID 11:
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
File descriptor 4 (/dev/sda1) leaked on vgs invocation. Parent PID 11:
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Installation finished. No error reported.
Generating grub configuration file ...
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Found theme: /usr/share/grub/themes/manjaro/theme.txt
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Found memtest86+ image: /boot/memtest86+/memtest.bin
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
done

So, I chroot, while still in architect, and I enabled lvm autoactivation and metadata caching in /etc/lvm/lvm.conf, by setting use_lvmetad = 0. [Edit] Later on (e.g. before exiting chroot or even after) you have to rechange it to 1, otherwise...

Then, update-grub and I had some noticeable outputs:

File descriptor d (pipe:[p]) leaked on vgs invocation. Parent PID n;
...
...
...

But, according to this, it seems to be "only cosmetic". After I: sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck && sudo update-grub , and all ok.
However, when I did exit from chroot, i was returned to architect and the program started blinking. I was unable to do anything (e.g. fg) other than kill the process.

I manually umount -R /mnt and rebooted. All good, although not so smoothly (had some errors but i'll not describe them).

Do you use lvm? Was the target installation device a removable device?

Yes, and no. I use lvm2 for /dev/sda3 where I have lv's for /root, /tmp, /var, and /swap. But for /boot/efi, I did a /dev/sda1 fat32 partition and did set esp on. The target was a 1TB hdd. The only removable device was a flash usb i did use to boot the iso.
(Obs.: this output is from jun 10th, 2018, when I had installed manjaro in /dev/sda2 also with architect, but it's essentially the same result I had installing today.)

sudo nano /etc/lvm/lvm.conf
use_lvmetad = 0               <<========= To disable it

Overlook Your Info Sorry

Yes, this did solve my issue.

No problem :slight_smile:

I edited my post and marked as [Solved], as well i did mark the SpiritOfTux reply as a solution.
What most annoyed me was the exiting chroot thing. I do not know if this also happens w/o lvm and if it's a bug or a feature, tough :p.

I have not met this issue yet. What should happen is

  1. You exit the chroot and are dropped to the shell you ran manjaro-architect from
  2. you run fg to return to manjaro-architect

It seems to me that for some reason, you are getting blinking afterimages of the previous manjaro-architect screen. Does this happen in tty or some terminal emulator?

I just tested running # manjaro-architect both urxvt and getty in the i3 minimal iso, and this didn't happen. I can normaly exit from chroot and then fg into architect without any problems. Only happens when I do it lauching architect with mod+Ctrl+a keybinding from the i3wm.

I just looked the i3 config, and this keybinding is for exec terminal -e 'setup'. And setup is for /usr/bin/setup, a bash script:

# !/bin/bash
#
# Architect Installation Framework (2016-2017)
#
# Written by Carl Duff and @mandog for Archlinux
# Heavily modified and re-written by @Chrysostomus to install Manjaro instead
# Contributors: @papajoker, @oberon and the Manjaro-Community.
#
# This program is free software, provided under the GNU General Public License
# as published by the Free Software Foundation. So feel free to copy, distribute,
# or modify it as you wish.
 
[[ -e /run/miso/bootmnt ]] && [[ "$TERM" == linux ]] && setfont ter-116n
 
while [[ ! -n "$(curl -Is https://manjaro.org | head -1)" ]]; do
    if [[ $(cat /proc/1/comm) == "systemd" ]];then
        if [[ $(systemctl is-active NetworkManager) == "active" ]]; then
            dialog --backtitle ":: Manjaro Architect ::" --yesno "\nPlease connect to the internet:\n" 0 0 && \
              clear && nmtui && continue || \
              clear && exit 0
        else
            dialog --backtitle ":: Manjaro Architect ::" --title " Error: " --msgbox "\nNo network service detected!\nquitting." 0 0 && \
              clear && exit 0
        fi
    else
        dialog --title " Error: " --msgbox "\nAn active internet connection is needed!\n" 0 0 && \
        clear && exit 0
    fi
done
 
echo "updating the installer ..."
sleep 1
sudo -E pacman -Sy manjaro-architect --noconfirm
 
echo "launching Manjaro Architect ..."
sudo -E manjaro-architect "$@"

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by