[SOLVED] KDE joystick acting like a mouse

Sorry if its already asked ... I didn't find any similar questions in the forum
Today I plugged in my xbox 360 controller, everything fine
I go to System Settings, Hardware, Input devices.. the gamepad works fine, but suddenly it starts working like a mouse.. I moved the sticks, and it moved my mouse cursor over the screen.. also the gamepad buttons act like mouse buttons.. Its nice, but I don't need this feature..
I didn't see any option to disable this behavior.. I just want to use my gamepad in games.. I found a solution in google involving the modification of a system text file, 50-joystick.conf ? but I cannot find this file on my system..

I have the latest Manjaro KDE version, everything is updated
Please help

To do this, create and edit /etc/X11/xorg.conf.d/50-joystick.conf with the following content:

Section "InputClass"
Identifier "joystick catchall"
MatchIsJoystick "on"
MatchDevicePath "/dev/input/event*"
Driver "joystick"
Option "StartKeysEnabled" "False" #Disable mouse
Option "StartMouseEnabled" "False" #support
EndSection

Take a look at the following topic:

3 Likes

Thank you for the easy solution. Works perfectly for me too.

Works.. thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by