SOLVED (kinda) Can't boot on fresh install

I managed to mess up an existing install I think by removing some openrazer package which altered the kernel, and in turn gave me a dependancy hell with Nvidia. It would not boot after this, so I just tried a fresh install. I am getting the same error message on failed boot with the new install. FWIW, I have two physical hard drives. One for the os, the other for /home.

I'm on my phone, and I tried to take a picture of the error, but I can't tell if it worked. So:
There is a "failed to load kernel modules" and then several "ok" lines, and then it gets stuck on: "starting wait for Plymouth boot screen to quit....cket."

Any help is greatly appreciated

Oh, I CAN get to a try if that helps

Then login and remove your current gpu driver with mhwd, update mirrors and system and install your gpu driver again. Also run

sudo mkinitcpio -P
sudo update-grub

and reboot.

Using mhwd, on reinstalling Nvidia, I get:
Error: Pacman failed!
Error: script failed!

Post the command you used, please.

Edit: and also the output of this


sudo mhwd -i pci video-nvidia

I went ahead with upgrading grub, and now I get a black screen with no access to a tty. On a hunch, I booted with "nomodeset" and can now once again get a try, but am still stuck at the terminating Plymouth boot thing.

Boot to TTY by editing Grub menu
Check your available drivers


Remove splash from Grub commandline

sudo nano /etc/default/grub

Install one of the drivers reported from previous mhwd command. If Grub is not updated from this script (watch the output log), then do it manually

sudo update-grub

Ok, thanks. I get that part. But first, I just re tried to install Nvidia. Here is the output:
Sudo mhwd -i pci video-nvidia
Installing video-nvidia
Using default
Had lib32 support: true
Sourcing /var/blah blah/MHWDCONFIG
processing classic Id: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classic Id: 0302
Syncing databases
Error: target not found: linux416-nvidia
Core up to date
Extra ditto
Community ditto
Multilub ditto
Error: Pacman failed
Error: script failed

Sorry had to manually type on phone

check mirrors
pacman-mirrors -f0
pacman -Syyu

add another kernel
mhwd-kernel -i linux417
mhwd-kernel -i linux418

reboot , and remove
mhwd-kernel -r linux416

This is a deprecated kernel. Remove it, having installed another one first, of course .


We are getting somewhere kinda. Removing 416 allowed me to install Nvidia. On restart, still removing quiet to be able to get to tty - haven't made it permanent yet, I can get to agraphical login screen. This is cinnamon, so whatever it uses.

However, I am unable to login this way. Inputting name and password just resetts the screen to the login. If I switch to a TTY and try to start, I get a black screen. It is now - must have changed to this after several minutes - showing:

Xinit server error
Xauth: error in locking authority file /home/Shawn/.Xauthority

Thanks for all your help ( both of you) so far. Btw, it seems to have kept the kernels from the old install, as I had 4.14, 4.16, 4.17 all installed. I can't imagine a fresh install would carry all of these.

Google tells me I can delete the authority file and it will probably let me log in. Not sure how to do that with nano or whatever.

Edit:. Well, I tried rm the file, and it says it does not exist.

You need to uninstall 4.16. It is not in the repos anymore and will create problems to your updates.

Yes. It is now uninstalled.

To be clear, the problem now is that I cannot start x, and the error started above about the .Xauthority file

I see now that there is a bug in the installer. Apparently, when you switch between hard drives (i have a separate hard drive for the / and /home partitions) it resets the value of keep/reinstall to keep. So, that is why all the old kernel stuff. I am guessing that is how the xauthority thing got messed up as well. I am going to try reinstalling with the cli installer to see if that fixes it.

I remember -- like 2 years ago -- when I last installed on this machine, that there were in fact 3 different installers. now there is only 2 i guess. I don't know what I am using, and what the one that actually worked was...

Which installer do you mean? You said this is an old installation, so the installer is far away from this problem.
Do you happen to have a full disk (no free space)?

It was originally an old installation that messed up with the update. I decided to do a fresh install with Cinnamon DE. The installer - Calamaries apparently - did not correctly overwrite the drive when using manual partitioning. (I have an ssd for the / drive, and a reg hard drive for the /home drive. I believe the partition editor in the installer gets confused when trying to point to both of them.) This is why I had all those old kernels, and also why (i assume) it did not correctly set up the xauthority in the /home folder.

So, I managed to trick calamaries into reformatting by picking the ssd drive (the one that I wanted reformatted) last. But, what it instead did was reformat both of them (even though in the summary screen it did not say this). This is not ideal, but okay because I do have my stuff backed up. Just a LOT of installing of steam games to go through. At the bright side, I now have a working system again. Thank you for your help.

I will, when I get my installs finished (lol), file a bug report for calamaries.

This is very serious issue, if you are sure you have not made a mistake. Wiping out Home partition is close to a disaster (if you have no backup). I believe this has to be reported ASAP to Calamares devs @philm

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by